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What is a Thesis?
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Different names of a thesis

* An academic thesis is a proposition can be challenged
® According to UTM convention

UG FYP - Final year project report

Master by taughtcourse project - project report

Master by taughtcourse and research (mixed-mode) - dissertation
Master by research and PhD - thesis

® The main difference is in the substance, not form

UTM Thesis
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Organizing ideas in the thesis

In general, thesis flow must have one solid story-line

¢ On the importance of the research

¢ On the current state-of-the-art solutions and their limitations
The central concept of the proposed solution to the problem
Validation of the solution
Implication of findings and contribution to knowledge
¢ Significance of findings and the way forward

UTM Thesis
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Writing thesis requires...

® Structuring thesis based on best practices (and your supervisor’s
recommendation)

® This requires some forms of mind-map (or a good ToC)
® Visualize how ideas can be conveyed and results can be best represented
® Collating and formatting figures — very time consuming!

¢ Use standard modeling diagrams when appropriate
® Go for scalable/vector graphics

® Re-reading many references to connect all dots

UTM Thesis
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UTM Thesis Manual 2018

® Each university has its own thesis style
The UTM Thesis Manual 2018 defines on how theses should be formatted

® Available to download from
http://sps.utm.my/thesis-formatting-2018/

® UTM also provide templates

* MS Word template
® LaTeX/LyX templates

® Using one of these templates will save a lot of your precious time to deal with the
thesis content

UTM Thesis 7/62
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Why not just using MS Word?

® MS Word is the mostly used word processor, but only practical tool for (very)
simple documents IMHO

* The use of LaTeX help typesetting complex documents such as books
and theses

® TeX: Typesetting language with macro capability — credit to Donald Knuth
® | aTeX: Macro package built upon TeX — credit to Leslie Lamport

® classes: Descriptions of a type of document, using LaTeX, e.g. the UTM
thesis
® styles: Alters the default behavior of LaTeX in some way

® | yX: Visual LaTeX to do its typesetting — credit to Matthias Ettrich

® LyX s the LaTeX front-end
® |yXis almost WYSIWYG (what you see is what you get)

UTM Thesis 8/62
0O0000e000



LaTeX/LyX UTMthesis template

® This UTMthesis template satisfies UTM Thesis Manual 2018
® Some features

® Auto-generates front pages, table of contents, references, list of
tables/figures, and declarations
® Easy referencing and figure/table/chapter numbering

® Always check for the newest class file on Github
https://github.com/utmthesis/utmthesis

UTM Thesis 9/62
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Thesis generation flow using LyX

® | yX is what you use to do your actual writing (GUI front-end, easier adoption)

® | yX converts your document to a series of text commands for LaTeX, generating
a file with the extension *.tex

® | aTeX uses the commands in the *. tex file to produce printable output
® Pdf through File > Export > Export [PDF (pdflatex)]
® This is the normal generated output
® QOther options are available

® For native LaTeX through File > Export > LaTeX (pdflatex)
e HTML through File > Export > HTML

UTM Thesis 10/62
0000000 @0



LaTeX and LyX Flow

¢ As LyX front-end is based on LaTeX back-end, both can co-exist
(diagram by Mohamed Sultan)

- No need for coding
- Takes less time

LaTeX Paper in
template AL LaTeX format
- — N\
Writing in
O Hew-C3
LaTeX Paper in
template LaTeX format
ﬁ—» Writing in LaTeX —>| |]I
~ _/

N
- Requires coding
- Takes more time
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Online access to LaTeX/LyX

® Web-based, no local installations are required
® For LaTeX user, you may check online template on Overleaf

® Can be accessed from https://www.overleaf.com/latex/templates/
universiti-teknologi-malaysia-thesis-template/vhhykxgsxcym

® |n LaTeX (text based), not LyX (visual)

® Can be integrated with Grammarly using TextArea add-ons

® Use LyX on RollApp https://www.rollapp.com/app/lyx
® Need subscription for saving to cloud storage

Set-up 12/62
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Local Installation

® | ocal installation is the usual choice for many
® Download and install either MikTeX or TeXlive

® MikTeX can be accessed from https://miktex.org/

e Minimal MikTeX will be installed
* Alternatively, you can install full MikTeX from ProTeXt
https://www.tug.org/protext/

® Alternative to MikTeX, you may install TeXlive from
https://tug.org/texlive/

¢ Full installation will take 7 GB for complete TeXlive
® Download and install LyX
® LyX can be downloaded here https://www.lyx.org/

® Packages will be updated over the Internet when installing LyX and when
running UTM template (see next slide) for the first time

Set-up 13/62
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Downloading the Template

® Download UTM thesis template from
https://github.com/utmthesis/utmthesis or from the link on the UTM SPS
website
® Files required to run the template (better to download all files)
® utmthesis.cls — class file version 6.4
® utmthesis.lyx
[ ]
[ ]

utmthesis.layout — LyX layout
*.bst — BibTeX style file of your choice

¢ | share the minimal template for you to try here https://drive.google.
com/file/d/1P£1C8xShfXnxsEoLhNb4SS5fbrjYCAdp/view?usp=sharing

® | will be using this to demo the template

Set-up 14/62
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Testing the template

® Open lyx-thesis.lyx

® To generate thesis PDF
® File > Export > PDF (pdflatex) to generate PDF in the folder OR
e Click 60 generate a PDF quick-view

A PDF should be generated

In case of unsuccessful PDF generation

® Open utmthesis.layout using a text editor
® Check line 13
® Change to Format 60 (ver. 2.2) or 66 (ver. 2.3)

Set-up 15/62
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Learning LyX on YouTube

® Many tutorials are available on YouTube on LyX (albeit the earlier versions)
® Some tutorials on using LyX 1.*

® Video 2/5 https://www.youtube.com/watch?v=Wq9ti7GGHrs
® Video 3/5 https://wuw.youtube.com/watch?v=050kEyYQ-0g
® Video 4/5 https://www.youtube. com/watch?v=sJpfyydhAzo
® Videos 1/5 (installation) and 5/5 (specific template) can be skipped

® References in LyX https://www.youtube.com/watch?v=EGnY486sbDI

Set-up 16/62
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LyX UTMthesis writing flow

® |nsert

® Thesis information (author name, degree, faculty, etc)

® Include preambles (abstract, abstrak (abstract in Bahasa Melayu),
dedication, acknowledgement, etc.)

® Write mainmatters (main chapters)

® Insert the bibliography

® Appendices if any

® Select sectioning from the Environment drop box \St‘andard—'l
® Chapter
® Section

® Subsection etc.

® Refer to the notes provided in the template for further clarification

Flow 17/62
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Thesis and author’s information

Some are OPTIONAL — delete when not in use.

Degree, Specialization, and Intakeyear must be written properly — refer to your

student card/offer letter
We support up to FIVE supervisors — do not ask us why
® |f you have more then five supervisor, you need to seriously rethink your life

choices (*_*")

Use Title Case

LyX will make to uppercase when necessary

nsert N it Tools Help

280

AQE AR ERE O
D EEPELwY 2 1 W

REYSOe

<1(a): Title:> Introducing U’

I Thesis Typesetting Using LyX
<2: Author:> M. N. Marsono
<3: Degree:> Doctor of Philosophy
<4: Specialization:> Electrical Engineering
<b5: IntakeYear:> 2018
<6: School:> School of Electrical Engineering
<7: Faculty:> Faculty of Engineering
<8: Thesis Date:> September 2018
<9: Award:> 5
<10(a): 1st Supervisor:> My Main Supervisor
<10(b): 2nd Supervisor:> My Co-Supervisor

Flow
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Preamble pages

® Acknowledgement
® Dedication
® Abstract
® Abstrak (abstract in Bahasa Melayu)
® Please check with the Dewan Bahasa website http://prpm.dbp.gov.my/
for special terms
® Do not rely on Google Translate

0B 2 @ @ SHEa FE X s 1 &
yxthesistemplate % | Ly tutoriakalls %

<17: DEDICATION>
To coffee...

<18: ACKNOWLEDGEMENT>
1 dedicate this template to those who have spent countless hours to make this possible. I just put a simple instruction on
using LyX to typeset UTM Thesis.

<19: ABSTRACT (ENGLISH)>
A 1-page abstract is a movie (thesis) trailer. Avoid summarizing your Introduction chapter. Focus on the problem
statement, hypothesis/objective, research approach, quantitative validation summary, and implication of your findings. For

<20: ABSTRAK (MALAY)>
The Malay abstract is written as the sentence structure of the English abstract. All specific terms must be checked with
Dewan Bahasa and Pustaka (URL http://prpm.dbp.gov.my/).

Flow Environment  Re
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Abbreviations and symbols '

® |ist of Abbreviations
® |ist of Symbols
® Must be alphabetically sorted - manually

[List of Abbreviations

* Note of use: you must declare/call the abbreviation at least once.

* Else, an empty hyphen (-) will appear
<24: List of Abbreviations>

by Gl 5 System

Abbreviation WWW| Description World Wide Web|

List of Symbols|
<25: List of Symbols>

Name (aammal Symbai [~ Descrintion Whatever!

® To call an abbreviation or symbol, Insert > New Inset > Abbre

Chapter 1
Introduction

This template conforms with the UTM 2018 new requirement [#utm:thesis:manual] . Students who wish to learn more on

| [#lyx:download] . You do not need to know deep on LaTeX [#latex:wikibook] to use this LyX template. This is an added text.

"This feature was contributed by Dr Loo Hui Ru

UTM Th
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Main pages

® Main Matters: Parts, Chapters, and Sections

Chapter (e.g., 2)

Section (e.g., 2.1)

Subsection (e.g., 2.1.1)

Subsubsection (e.g., 2.1.1.1) —iff necessary

® Do not to go beyond this

® Restructure your thought
® There always options to restructure your chapters/sections

® |f unable to do this, quit!

Flow 21/62
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UTMthesis document class

Document classes are another major part of the WYSWYM (what you see is
what you meant) philosophy

It tells LyX how to typeset the document according to the document class, so you
do not need to know how

UTMthesis class is a book-type derived class, hence print on both sides by
default

® You can set set for oneside printing
This is the endorsed version by SPS

Some discrepancies in the manual (e.g., if the “Figure” in figure caption should
be bold etc.,) have been verified by SPS

Environment 22/62
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LyX is WYSIWYM, almost WYSIWYG

WYSIWYM means what you see is what you meant
The class file defines how the document should be typeset
The hardest thing for new users is on how LyX handles white spaces
A return (new line) means a new paragraph

® As many times as you hit Return, you will only get one blank line
A space means writing another word

® As many times as you hit Space, you will only get one white space
® On a blank line, LyX will not let you type even one space

The Tab key will not move you forward one tab stop; in fact there are no tab
stops!

There is no ruler at the top of the page to let you set tabs or margins
Fine-tuning white spaces in LyX can be done (only when necessary)

® Protected Break, which you get by typing Ctrl+Return
® Protected Space, which you get by typing Ctrl+Space

Environment
O@000000
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LyX environments

o Different parts of a document have different purposes; we call these parts
environments

® Certain types of documents have special environments (an abstract and a title for
journal, but not letter)

® An environment may require a certain font style, font size, indenting, line
spacing, and more.

® The Environment choice box is located on the left end of the toolbar

Standard v

Environment 24/62
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Basic features

® Undo - LyX has multiple levels of undo and redo. Currently limited to 100 steps
Cut/Paste/Copy — Like MS Word

® Even figures, but we do not suggest this as the figure will be in bitmap
format

Find/Replace
Character Formatting
Toolbar (tons of them) — Just need to get used to them

Environment 25/62
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Paragraph alignment

® Edit > Paragraph Settings dialog or click 1=
® Justified — default
® |eft
® Right
® Center
® For vertical alignment default is raggedbottom

UTM Thesis Set-up Flow Environment  Referencing Math Floats Use notes Conclusion
000000000 00000 00000 O000e000 000000000 0000 000000000000 0000000 O

26/62



Using different character styles

e Citrl+B will bold the text selection
® Citrl+l or Ctrl+U will not work in LyX

® |talic: Emphasized style (toolbar button AOZ)

® Noun style (toolbar button @)
® Can also be accessed from menu Edit > Text Style
® Don’t overuse character styles!

Environment 27/62
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Lists and sublists

® Enumerate

® |temized

® List (not native to LaTeX)
® Description

Can be made nested

* Plan/elaborate the outline
— A plot for your thesis writing
- Target: logical story for the document
- Results
* Stand-alone tables/graphs
* Describe each, then number crunch
* Use Appendices for detailed items

* Get feedback from the supervisor

+ If you are writing in a language other than your mother language, consider getting specialized editing help

Environment R onclusion 28/62
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Footnotes and margin notes

® [Acceptable] Footnotes can be added using the toolbar button or the menu

Insert > Footnote
® [Only for textbook] Margin notes should not be used

Environment 29/62
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Labels and cross-references

® The use of label and cross-reference
® Dynamic numbering of

® <reference>: prints the float number, this is the default

® (<reference>): prints the float number within two parentheses, e.g. for
Equation

® <page>: prints the page number

® on page <page>: prints the text "on page" and the page number
(suggested)

® <reference> on page <page>: prints the float number, the text "on page",
and the page number

® | suggest using the last method, “on page <page>" will be added when necessary

Referencing 30/62
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Bibliographies

® |f you make a statement, back it up with your own data or a reference

® All references cited in the text must be listed
® UTM supports either the numbering or author-year format
® Try to avoid inclusion of references as footnotes

® We recommend dynamic (and smarter way) — Use BibTeX
BibTeX is text based
® Some visualization tool such as JabRef can be used

If you worked with EndNote for MS Word before, your references list database
can be exported to BibTeX format

Referencing
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BibTeX samples

@article{CitekeyArticle,
author = "P. J. Cohen",
title = "The independence of the continuum hypothesis",
journal = "Proceedings of the National Academy of Sciences",
year = 1963,
volume = "50",
number = "6",
pages = "1143--1148",
}
@book{CitekeyBook,
author = "Leonard Susskind and George Hrabovsky",
title = "Classical mechanics: the theoretical minimum",
publisher = "Penguin Random House",
address = "New York, NY",
year = 2014
¥
Referencing

008000000
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BibTgX styles

® UTM supports either numbering (mostly science and engineering) or author-year
(social sciences) format
® Note that the latest UTM thesis manual allows any standard styles, provided that
it is used consistently throughout the thesis
® For numbering, use utmthesis-numbering.bst (or any other numbering BibTeX
styles such as IEEEtran.bst)
® Document > Settings > Bibliography > Citation Style > Basic (BibTeX)
® Click on BibTeX Generated Bibliography to change the BibTeX style Style >
Browse and select utmthesis-numbering.bst

® For author-year, use utmthesis-authordate.bst (or any other numbering BibTeX
styles such as APA)

® Document > Settings > Bibliography > Citation Style > NatBib (BibTeX)
® Click on BibTeX Generated Bibliography to change the BibTeX style Style >
Browse and select utmthesis-authordate.bst

Referencing 33/62
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Where to get BibTeX items?

e Usually obtained from
® Publishers
® Google Scholar
® Mendeley (citations manager)
® Usually, we don’'t manually define BibTeX from scatch
e Usually require manual edit as some fields may be inaccurate or missing
® Read https://wuw.bibtex.com/e/entry-types/ for more details

e e a google.com AR neo =
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https://www.bibtex.com/e/entry-types/

S EE.,

Inserting bibliography

® At the end of the document (after the last chapter), insert Bibliography
® Can be accessed through menu Insert > List/TOC » Bib(la)TeX Bibliography

BibTeX Generated Bibliography

® Set reference BibTeX file (*.bib) and BibTeX style file (*.bst)

BibTeX Bibliography

Databases
reference

style Rescan |

utmthesis-numbering [ [ Browse... |

Content: [all cited references >
() Add bibliography to TOC

oK

UTM Thesis Set-up  Flow Environment  Referencing Math  Floats Use notes  Conclusion 35/62
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Inserting cit

UTM Thesis Set-up Flow
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BibTgX Author-Year style

® For author-year, use utmthesis-authordate.bst (or any other numbering BibTeX
styles such as APA)

® Document > Settings © Bibliography > Citation Style - NatBib (BibTeX)

® Click on BibTeX Generated Bibliography to change the BibTeX style Style >
Browse and select utmthesis-authordate.bst

LyxX: BibTeX Bibliography o
Databases
crationstye reference Add..
Default (rumerical )
* Natbib Natbibstyl: | Authoryear =
Jursbit
Biblography Syle
style Rescan
utmthesis-authordate - Browse...
Content: all cited references
Add bibliography to TOC
| Use Class Default Save as Document Defaults
Restore. oK aoply | Cancel oK Cancel
UTM Thesis Environment  Referencing Math Conclusion
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List of Publications

® After the list of references
® Should follow BibTeX style (convention) used in References

List of Publications

« Categorize according to publication types.

+ For co-authored publications, group them as “Other Publications”
<25: List_of_Publications>

Journal with Impact Factor
1. Paper1
2. Paper 2
1. Paper3
Non-Indexed Journal

1. Paper 4

nment  Referencing
""" ) 00000000 e
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Typesetting Math

® Three types
® Numbered equations

¢ Single- or multi-line equations are possible
® Use of Eqnarray is encouraged

® |nline formula

® Use toolbar button Z or from menu Insert > Math > Inline Formula
* Mainly limited to simple expression

Math 39/62
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Walkthrough of some Math features
e Exponents and Subscripts — e.g., x*2y, you will get x¥ and type a_1 to get a;
a
® Fractions — by typing \frac or using the icon b in the Math Panel

® Roots — using the Math Panel button\/ﬁ or the commands \sqrt or \root
® Operators with Limits — Sum (}°) and integral (') operators

® Math Symbols — includes Greek, Operators , Relations, Arrows. Also AMS
additional symbols

® Altering Spacing — using protected space

Math 40/62
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More on Math features

® Functions — function macros, such as sin, lim, etc.
® Accents — circumflex, tilde, breve, etc through command

® Brackets and Delimiters — Auto-sizing delimiter via icon [D]
® Arrays and Multi-line Equations — Matrices are entered using the Math Panel

ooog
oool
oool
ooo

000l

matrix button
® Cases — Insert > Math > Cases Environment or the command cases

Math 41/62
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Theorems

® | yX supports theorem, definition, etc.
® Go to Document > Settings > Modules

Document Settings

search Available: selected:
Document Class Section Boxes = Theo
Sweave
Local Layout TODO Notes Delete
Fonts Theorems
Text Layout Theorems (AMS)
Page Layout Theorems (AMS, Numbered by Typ
Page Margins Theorems (AMS, Numbered by Typ
Language Theorems (AMS Bxen
Colors Theorems
Numbering & TOC Theorems Nu
Bibliography Theorems (Numbered by Ci
Indexes Theorems (Numbered by semem
PDF Properties nu o
Math Options
Float Placement Numbers theorems and the like by chapter (i., the counter s reset at each chapter
Listings start). Use this module only with document classes that provide a chapter
Bullets environment.
Branches Category: theorems.
Formats Modules required: Theorems or Theorems (AMS).
LaTeX Preamble Modules excluded: Theorems (Numbered by Section).
Use Class Defaults Save as Document Defaults
Close
UTM Thesis Set-up Flow Environment  Referencing Math Floats Use notes Conclusion 42/62

000000000 00000 00000 00000000 000000000 0O00® 000000000000 0000000 O



Managing floats

® Figures and tables float in the text

* A float doesn’t have a fixed location

® |t can float forward or backward to wherever it fits best to get a high quality
layout

® Caption as part of a float

® Float Placement

® Here if possible: try to place the float at the position where it is inserted
(default in UTMthesis)

® Top of page: try to place the float at the top of the current page

® Bottom of page: try to place the float at the bottom of the current page

® Page of floats: try to place the float at an own page

® You can insert a figure float inside another figure float to create subfigures
® Insert > Float > Figure and again, Insert > Float > Figure

Floats 43/62
®00000000000



Graphics and images

® A good thesis needs good diagrams/graphs/illustrations
® Spend some time doing in properly
® A good picture tells a thousand words
* Place the cursor and click on the toolbar icon ® or select Insert > Graphics from
the menu
® Use scalable images such as SVG, EPS, PDF
* Normally one can’t convert a bitmap image into a scalable one, only vice
versa
® You can copy and paste as well (just like MS Word) but will result in bipmap
image
® Not good enough

® |f you drew diagrams using Microsoft Word, you may copy-and-paste it to
Visio or PowerPoint — then export as scalable images

Floats 44/62
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More on graphics and images

¢ Set dynamic width of figures/tables

Graphics | Coordinates and Clipping | LaTex and LyX options

File: (T Browse.
Output size

& set width 30 Text Width % B

Set height:
Rotate Graphics ‘
|
Angle (degrees). o origin: Default B ‘
Restore ek | Aeply cancel
|
UTM Thesis Set-up Flow Environment  Referencing Math Floats Use notes Conclusion

000000000 00000 00000 00000000 000000000 0000 008000000000 0000000 O

45/62



More on graphics and images

e Citations should not be included in LoF, LoT
e Short float caption without citations
® Click on figure caption, Insert > Short Title

| .l

Short Title [Figure caption short that appear only in LoF. Notice that I remove citation.[Figure caption  that
‘appear in text, with citation [#ramakrishna:1997]

Figure 6:

UTM The Set-up Flo Environment ing Math Floats L

) O00®@00000000 ¢
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Tables

® |f you need to show exact values (instead of trend for graphs), use tables instead.

EEH

® |nsert a table using either the toolbar button === or the menu Insert > Table
® Use with cross-referencing

® Use ctrl+space so that “Table” and “Table number” are concatenated as
one, i.e., will not be in separate lines

* Use with cross-referencing, such as Table.Ref: table:1

Table 1: Table caption

a|b|c|d

float: Table

table:1

Floats 47/62
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Table resize?

® Add graphicx package Document > Setting > LaTeX Preamble

\usepackage{graphicx}
Document class,
Modules

Local Layout
Fonts

Text Layout
Page Layout
Page Margins
Language
Colors
Numbering & TOC
Bibliography
Indexes

PDF Properties
Math Options
Float Placement
Listings

Bullets
Branches
Formats

LaTex Preamble

Use Class Defaults Save as Document Defaults

Close

2This tutorial on writing algorithm is done by Mr Mohammed Sultan Ahmed Mohammed
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Table resize (cont’d)

® Using LaTeX command (Ctrl+L), add the following command inside table float
before the table: \resizebox{\textwidth}{!}{

® Also using LaTeX command, close the bracket directly after the table: }

float: Table

Table 1: Example
\resizebox{\textwidth}{!}{
| Table Table Table Table Table Table | Table Table Table Table Table Table | Table Table Table Table Table Table
Table Table Table Table Table Table | Table Table Table Table Table Table | Table Table Table Table Table Table
Table Table Table Table Table Table | Table Table Table Table Table Table | Table Table Table Table Table Table

¢ Take note that table resize is to justify the size of a table after you have
set column width

® Too much scaling will make table font too small compared to the main
text
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Algorithms?

® Use algorithm and algorithmic packages

® Download the latest version of LyX Algorithm-Style Layout from
http://bgu.perso.libertysurf.fr/

® Copy algorithm.inc file to LyX layouts folder

® Layouts folder in Windows:
<path-to-LyX-installation>\Resources\layouts
® |ayouts folder in Ubuntu: /usr/share/lyx/layouts

® Copy algolyx.sty file to your working directory
® Add Input algorithm.inc to your LyX .layout file

SThis tutorial on writing algorithm is done by Mr Mohammed Sultan Ahmed Mohammed
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Algorithms

PlainText v Tbwidthcs v Lai3coll v s

® [nsert an algorithm float Insert > Float > Algorithm
® Change the text layout style inside the algorithm float to either Algorithm or

Algorithm (num) using the upper left-hand drop-down menu
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Algorithms

® Write your algorithm

float: Algorithm Algorithm 1 Calculate y = "

Algorithm 1: Calculate y = x" Require: 0
Require: x > 0 Ensure: y = 2"
Ensure: y = x
Fyel
* Xe=x
* N=n
while N # 0
if N is even
* X=XxX 7
;N?{’/{ZN} - else if {N is odd} then
glself (L yeyx X
L NeN
le end if
le: end while

® You have to use reserved keywords
if endif
for/forall endfor
while endwhile
repeat until
loop endloop

® Use (*) symbol in front of unreserved keywords

UTM T M

Floats
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File listings

® Insert > File > plain text to insert ext in verbatim mode
® |nsert > File > external document to insert PDF or XFIG figures
® |nsert > File > Child document
® You can split chapters as individual LyX files and called using include

command — faster compilation and better writing overview

Fle: ot srowse. |

Include Type: | Include. - Edit

e Other options are input, verbatim, program listing
® Verbatim in typewriter font
® Program listing can be configured language-aware
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Program listings

® |nsert > File > Child document

® You may change the type to program listing and configure it as you need

breaklines=true

captionpos=b

frame=tb

language=Python
commentstyle={\normalfont\textit}
keywordstyle={\textbf}

® Refer to Listings Latex package.
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Turn on the spelling checker

Sloppily-written thesis spells disaster

If the examiners feel that you could care less with your thesis, they will do likewise

Tools > Preferences > Language Setting > Spellchecker > Spellchecker engine
® Turn on Spellcheck to check continuously

Having a spelicheck does not fix sentence structure or grammar

Do use additional tools (Online grammar check or any other tools)

® To improve your manuscript quality
® To reduce the chances of your supervisor having a headache while reading

your thesis
S0 | SUMMARIZED
MY COMMENTS IN
THE BACK PA 7

WERE, | MADE
COMFHENTS ON

THE PAPER
YOU WROTE,

§ -
—

wwu.phdcomics.com

Use notes 55/62
®000000



Track changes between reviews

® Revision is a daunting process
® Help your supervisor to visualize changes been made

® Document > Change tracking > Track changes
® |f you need to show the changes in pdf, select Document > Change tracking >

Show changes in output

CHAPTER 1

INTRODUCTION

i Malaysia (UTM) 2018

Chapter 1
Introduction
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Using specialized packages

® UTMthesis uses the following packages

® acronym ® hyperref ® pdfpages
® algorithm ® ifplatform ® setspace
® caption ® newtxmath ® tocloft

® emptypage ® newtxtext ® tocvsec2
® enumitem ® nowidow

® geometry ® parskip

® Do not re-declare these packages in Document 1> Setting > LaTex Preamble

® |f you need to include advanced features and/or specialized packages,
potentially some packages may generate errors due to conflict with used
packages in utmthesis.cls

* Add a package at a time when necessary
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Fine typesetting

® You may need to do post-writing customization
® Orphan and widow lines
® Only perform fine typesetting (page break, vertical skip, etc.) before

finalizing the document
® Forced page break may be required

¢ Insert > Formatting > Clear Page (open any)
¢ Insert > Formatting > Clear Double Page (open right)

® Float placements

® Some float may be too far from the referencing text, or

® On a page on its own

® Right-click on the float

® Settings > Advanced placement options > Here if possible
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One-side or double-side printing

e UTM allow either single or double-sided printing for submission of thesis for oral
examination purposes (UTM Thesis Guideline, 2018) Section 2.3 on page 13

® By default, the template is for double-side printing

® To change to a single-sided document Document > Settings > Document Class,
type oneside in Custom Class Options
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Font type

® You can also choose different font types (UTM Thesis Guideline, 2018) Section
2.4 on page 14-15.

® Document > Settings > Fonts > Default family then select either Roman
(default) or Sans Serif

® You may also define font type packages in LaTeX preamble Document
Settings > LaTeX Preamble

LyX: Document Settings °

Searct
\date{15 Novenber 2018}

Document Class

child Documents \renewconmand{\textendash}{--}

Modules \renewcommand{\textemdash}{---}

Local Layout

Fonts \usepackage[scaled]{helvet}

Text Layout \renewcommand\ fanilydefault{\sfdefault}

Page Layout
Page Margins \usepackage[T1]{fontenc}

Language
Colors
Numbering &TOC
Bibliography
Indexes

POF Properties

Format:

ormats
LaTeX Preamble

Use Class Defaults Save as Document Defaults.

close

® Go to http://www.tug.dk/FontCatalogue/sansseriffonts.html for many
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Known issues

Some reported bugs (system-specific issues)

® Spacing between a section title and the first paragraph thereafter (MikTeX on
Windows)

® Define LaTeX preamble Document > Settings > LaTeX Preamble

\usepackage{titlesec}
\titlespacing*{\section} {Opt}{2\baselineskip}{\baselineskip}
\titlespacing*{\subsection} {Opt}{2\baselineskip}{\baselineskip}

® Use of the babel package messed up with the preamble pages
® Use of the notoccite package messed up the ToC, LoT, and LoF
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Last words

® We could not cover all grounds under-the-sun, as we know only the requirement
in EE and EEE

® | aTeX/LyX are not a silver bullet to make thesis writing automated

® You most probably need to read further on beyond-basic LaTeX and LyX
functions

® We (my students, other volunteers and I) receive a lot of questions or requests to
solve some issues

® Sometimes, due to multiple constrains, we are unable to help more that
what was expected
® Or we could not know more that the one asking (the question)

® We all volunteer in this endeavor believing that knowledge is to be passed to
others

Conclusion 62/62
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