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Chapter 1 

Introduction to CHEMCAD 

Welcome to CHEMCAD Version 6.0, a powerful and effective software tool for 
chemical process simulation. Whether you’re a new or experienced CHEMCAD user, 
you’ll appreciate the program’s user‐friendly, feature‐rich interface. Creating 
flowsheets and running simulations is fast and easy with CHEMCAD, and the 
program is highly customizable to fit your needs and the way you work. 

This manual will help you get up and running with CHEMCAD, from 
installation and licensing to tutorials that walk you through real‐world examples. 

Overview of CHEMCAD and Its Uses 
Today’s chemical processing industry (CPI) faces numerous challenges: rising fuel 
and feedstock costs, reduced engineering staff, shorter product life cycles, increased 
global competition, and increased regulation. These challenges require that CPI 
companies seek out and use the best tools to increase productivity and improve 
engineering decisions. 

CHEMCAD is a powerful and flexible chemical process simulation environment, 
built around three key values of innovation, integration, and open architecture. 
These values create important advantages for CHEMCAD users: 

• The latest chemical engineering techniques at your fingertips 

• All functionality united in a single software environment 

• Seamless connection to the chemical engineering computing environment, with 
links to tools such as MS Excel and Word and interfaces such as COM, DCOM, 
OPC, CAPE‐OPEN, and XML 
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CHEMCAD combines a state‐of‐the‐art graphical user interface (GUI), an 
extensive chemical component database, a large library of thermodynamic data, and 
a library of the most common unit operations to give users the ability to provide 
significant and measurable returns on their investment. In addition, the program is 
customizable to allow custom chemicals, thermodynamics, unit operations, 
calculations, and reporting—all ingredients for a powerful user experience. 

CHEMCAD is capable of modeling continuous, batch, and semi‐batch processes, 
and it can simulate both steady‐state and dynamic systems. This program is used 
extensively around the world for the design, operation, and maintenance of chemical 
processes in a wide variety of industries, including oil and gas exploration, 
production, and refining; gas processing; commodity and specialty chemicals; 
pharmaceuticals; biofuels; and process equipment manufacturing. 

Within all of these industries, chemical engineers work every day with 
CHEMCAD to address a variety of challenges: 

• Initial design of new processes 

• Optimization or de‐bottlenecking of existing processes 

• Performance monitoring of processes 

• Design and rating of process equipment such as vessels, columns, heat 
exchangers, piping, valves, and instrumentation 

• Evaluation of safety relief devices 

• Heat exchanger sizing 

• Pressure and flow balancing of complex piping networks 

• Reconciliation of plant data 

• Economic comparisons of process alternatives 

• Advanced process control (APC), including model predictive control (MPC), 
real‐time optimization (RTO), and operator training systems (OTS) 

• Scale‐up of processes from lab‐scale to pilot‐scale, and from pilot‐scale to full‐
scale 

• Binary interaction parameter (BIP) regression from process or lab data 

• Batch reaction rate regression from process or lab data 

No matter how complex your process, CHEMCAD is capable of delivering the 
results you need to stay competitive in an increasingly fast and fluid global market. 
Easy to learn and highly customizable, CHEMCAD can put future‐proof solutions 
within easy reach of your engineering staff. 
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CHEMCAD Products and Features 
The CHEMCAD suite consists of several modules that serve specific purposes. 
Depending on your particular needs, you may have purchased some or all of these 
modules. The following are brief descriptions of the various CHEMCAD modules 
and their most common uses. 

CC-STEADY STATE 
The main CHEMCAD product, known as CC‐STEADY STATE, enables you to 
design new processes, rate existing processes, and optimize processes in steady state. 

CC-DYNAMICS 
The module known as CC‐DYNAMICS makes it possible to design and rate existing 
processes using a dynamic simulation. This module is fully integrated with 
CHEMCAD to make switching between steady state and dynamics easy and 
intuitive. Using CC‐DYNAMICS, you can easily simulate everything from simple 
vessel accumulation to complex control systems on columns. This module also 
provides tools for simulation of continuous stirred‐tank reactors (CSTRs), including 
complex reaction rate and pressure calculation. 

CC-BATCH 
The CC‐BATCH product enables you to design, rate, or optimize a batch distillation 
column. CC‐BATCH includes a scheduling interface to allow an “operation step” 
approach to simulation of batch columns. 

CC-THERM 
The CC‐THERM product lets you design a single heat exchanger, or vet a vendor’s 
heat exchanger design. It is also ideal for customers who want to rate existing 
exchangers in new service, or to perform calculations on hypothetical situations. CC‐
THERM can simulate shell‐and‐tube, air‐cooled, plate‐and‐frame, and double‐pipe 
exchangers. Full integration with CHEMCAD makes it possible to calculate exit 
conditions from exchanger geometry for high‐fidelity simulations. 

CC-SAFETY NET 
The CC‐SAFETY NET product provides the capability to design or rate piping 
networks and safety relief devices and systems, in both steady‐state and dynamic 
systems. The steady‐state features of CC‐SAFETY NET are included with CC‐
STEADY STATE. This product enables users to make simultaneous flow‐ and 
pressure‐balanced simulations—even in reverse‐flow situations—for single‐ or 
multi‐phase flow. 

CC-FLASH 
The CC‐FLASH module provides physical property and phase equilibrium data, as 
well as property prediction and regression. CC‐FLASH is a subset of CC‐STEADY 
STATE, and is meant for customers who do not need full flowsheet simulation tools. 
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CHEMCAD Features by Module 
The following matrix lists the features associated with each component of the 
CHEMCAD suite. For a more detailed explanation, or to inquire about a particular 
component or feature, please contact Chemstations or your CHEMCAD distributor 
(see complete contact information at www.chemstations.net/contact.htm). 
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VB/COM/OPC/Data Map       

Sensitivity/optimization       

Sizing (line/valve/orifice/vessel)       

Run steady state       

Run dynamics       

Run recycles       

Costing       

Reconciliation       

Sizing columns       

Sizing heat exchangers       

Economics       

Reports (incl. Excel)       

DIERS       

CO2 solid       

Hydrates       

Depress       

TOC/COD       

Pure regression       

BIP regression       

Electrolyte regression       

Rate regression       

Units calculator       

Execute parser       

Environmental report       

Simple calculator       

Spec sheet       
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UnitOps by Module 
The availability of certain unit operations, or UnitOps, in CHEMCAD simulations is 
a function of which modules you have licensed. The following matrix lists all 
available UnitOps and the CHEMCAD modules associated with them. 
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Baghouse filter       

Batch column       

Batch reactor       

Calculator       

Centrifuge       

Component separator       

Compressor       

Control valve       

Controller       

Crusher/grinder       

Crystallizer       

Cyclone       

Divider       

Dynamic vessel       

Electrostatic precipitator       

Equilibrium reactor       

Excel unit       

Expander       

Fired heater       

Flash       

Gibbs reactor       

Heat exchanger       

Hydrocyclone       

Kinetic reactor       

Liquid/liquid extractor       

LLV flash*       

LNGH exchanger       
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Loop       

Mixer       

Node       

Phase generator*       

PID controller       

Pipe simulator       

Polymer reactor       

Pump       

Ramp controller       

Recorder*       

Run subflowsheet META unit       

SCDS distillation column       

Screen       

Sedimentator       

Shortcut column       

Solids dryer       

Solids washer       

Stoichiometric reactor       

Stream reference       

Tank       

Time delay       

Time switch       

Tower distillation column       

Tower plus distillation column       

User-added module       

Vacuum filter       

Valve       

Venturi scrubber       

Vessel*       

* These UnitOps will be phased out eventually. 
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Chapter 2 

Getting Started with CHEMCAD 

Now that you have CHEMCAD in hand, you probably want to get started right 
away. Let’s get directly to the point, with step‐by‐step instructions for installing and 
licensing the program. 

Installing the Software 
Start by ensuring that your PC meets the minimum system requirements, as listed 
below. It’s also a good idea to find out before you begin whether your copy of 
CHEMCAD will rely on a network license; if it will, make sure to ask your network 

administrator for all the 
information that you’ll need 
when installation is complete and 
it’s time to set up licensing. 

Once you’ve established that 
your computer is ready for 
installation, insert the 
CHEMCAD 6.0 disc into an 
available CD media drive and 
watch for the CHEMCAD splash 
screen to appear. 

 

 

CHEMCAD System Requirements 
Processor speed: 500 MHz or higher 

Operating system: Windows 2000, XP, or Vista 
RAM: 256 MB 
Video card: 128 MB or higher video memory 

Display resolution: 1024 x 768 or higher 
Hard disk space: 500 MB (750 MB during 
installation) 

Productivity software: Some features require 
Microsoft Office® 
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Note: If you insert the disc and close the CD media drive door, but nothing happens 
within one minute, then your system is not configured to launch the CD content 
automatically. To launch the installation program manually, go to My Computer, 
double‐click the icon for your computer’s CD media drive, and then double‐click the 
file called Setup.exe. 

Click Install CHEMCAD to launch the InstallShield Wizard. InstallShield 
inspects your computer for software components that CHEMCAD will need, and 
prompts you to install any needed components with a screen similar to Figure 2‐01. 

 
Figure 2-01: InstallShield Wizard screen listing software components to be installed 

Click Install to continue. Follow the prompts on all other screens until you see 
the CHEMCAD Suite – InstallShield Wizard screen, shown in Figure 2‐02. 

Note: Depending on how many software components InstallShield identifies, there 
may be quite a few screens, and the procedure could take several minutes. Once 
these components are installed on your computer, however, you will not need to 
reinstall them with future CHEMCAD updates. 
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Figure 2-02: The CHEMCAD Suite – InstallShield Wizard screen 

Click Next to begin the installation process. The License Agreement screen 
appears, listing the CHEMCAD standard license. Once you’ve read and understood 
the terms of the license, you’ll need to click the I accept the terms of the license 
agreement button before you can click Next again to proceed. Note that you have the 
option to print a copy of the license agreement from this screen. 

 
Figure 2-03: The Standard License screen 

The Destination Folder screen appears next, displaying the name of the folder 
into which the CHEMCAD files will be installed by default. Normally, this 
destination is C:\Program Files\Chemstations\CHEMCAD, and it is recommended 
that you use this location unless you have a specific need to install the program 
elsewhere. Click the Change button if you want to change the file destination, or 
click Next to accept the suggested destination and proceed. 

The Setup Type screen now appears, offering a choice between complete and 
custom installation. Each type of installation is described on the screen. Either accept 
the default setting of Complete or click Custom to select specific components to 
install, then click Next to proceed. 
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The Ready to Install the Program screen now appears. Note that on this screen, 
and in fact on any screen in the installation process, you can click Back to return to a 
previous screen and verify or change your installation settings. If you are satisfied 
with your settings as they are, click Next to start the installation. 

The Installing CHEMCAD Suite screen appears, showing the progress of your 
installation with a green status bar. 

 
Figure 2-04: Status bar showing the progress of CHEMCAD installation 

When installation is complete, you’ll see one final screen, which states that the 
InstallShield Wizard has completed installation of the CHEMCAD Suite. Click 
Finish to close the installation program and open CHEMCAD 6. 

Licensing CHEMCAD 
Before you can use CHEMCAD, you’ll need to set up a licensing scheme of some 
type. Depending on your particular licensing agreement, you will use one of several 
types of licenses to run CHEMCAD. 

Types of CHEMCAD Licenses 
The various types of CHEMCAD licenses are designed to fit different users’ 
software, hardware, and networking needs. Most licenses require the use of a 
hardware device, commonly known as a dongle, to run the program. 

The dongle simply plugs into either a USB port or a parallel port on the 
computer, and must be plugged in any time the program runs. If you work on a 
network with other CHEMCAD users, your license may rely on a dongle plugged 
into a network server elsewhere in your organization, rather than one plugged 
directly into your computer. 
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You or your organization will use one of four types of dongles: 

• SuperPro single‐user dongle (parallel or USB connection) 

• SuperPro Net dongle (parallel or USB connection) 

• Sentinel Scribe single‐user dongle (parallel connection)  

• NetSentinel network dongle (parallel connection) 

In some instances, software licensing is accomplished without the use of a 
hardware device: 

• License Manager software, which runs over a local‐ or wide‐access 
network 

• System Authorization, a method that authorizes a single‐user machine for 
a limited time (used for software evaluation) 

License Settings 
To run CHEMCAD for the first time, make sure that your dongle (if applicable) is 
plugged in properly, and then start the program. From the Windows Start menu, 
select All Programs > Chemstations > CHEMCAD. 

The program opens, displaying a CHEMCAD splash screen. After a few 
moments, that screen is replaced by the License Settings screen. 

 
Figure 2-05: The License Settings screen with default settings 

The checked boxes on the left side of this screen indicate the types of licensing 
hardware and software that CHEMCAD will search for when you click OK. Note 
that network licensing methods are not checked; this saves time for many users, 
because searching for a network dongle can be time‐consuming. 
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Note: If you are using one of the network licensing methods (NetSentinel, SuperPro 
Net, or License Manager), you’ll need to check the appropriate box before clicking 
OK. You can also click the other boxes to clear their check marks and speed up 
CHEMCAD’s search for your license. 

On the right side of the screen, the Network device product checkout area lets 
network users choose whether or not to request licenses for specific CHEMCAD 
modules. For each listed product, you can elect to secure a license Always, As 
needed, or Never. 

The default setting for all of these slider controls is As needed, which secures a 
license only when you begin to use a specific CHEMCAD feature controlled by a 
certain product. This setting is ideal in most situations, as it leaves unneeded licenses 
available for other users. To change any module’s checkout setting, simply click to 
the left or right of the current setting to move the slider.  

In most cases, you won’t need to make any changes on the License Settings 
screen, although you may want to clear the Always show this screen at startup check 
box, to avoid seeing this screen each time you start CHEMCAD. 

Note: If you’ve turned off this check box, you can still open the License Settings 
dialog box at any time. Either select Tools > Options > License Settings from within 
an open simulation, or select License > License Settings with no simulation open.  

When you’ve made any changes needed, click OK. Once CHEMCAD has located 
your valid license, you’ll see the Licenses in Use screen, which lists all licensed 
products along with the type of license device or software validating each product. 
Click OK to close this screen and access the main CHEMCAD window. 

Updating a License 
CHEMCAD dongles require re‐programming on a regular basis, either once a year 
or more often depending on your licensing agreement. This is a security measure to 
reduce the likelihood that your dongle will be stolen and misused. 

The dongle that you use is programmed to work only through the licensed time 
period, and when that time has elapsed, the dongle must be updated before you can 
continue using CHEMCAD. 

Updating a dongle is a relatively simple procedure. Before your license 
expiration, you or your software administrator should receive an e‐mail from 
Chemstations, with what’s known as a configuration file included as an attachment. 
You should save this file to your Windows desktop as soon as you receive it. 
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Note: If you’ve updated the same dongle in the past, the new configuration file 
should have the exact same file name as the previous one. If, while saving the file to 
your desktop, you see a Windows message about an existing file with the same 
name, you should overwrite the old file (which in any case cannot be used again), 
replacing it with the new one. 

It’s important to ensure that your configuration file matches your dongle. The 
configuration file should be a .DNG file whose name includes a four‐ or five‐digit 
code; this code must match the number stamped onto your dongle. If the numbers 
don’t match, contact your software administrator or Chemstations support to resolve 
the issue. 

The update e‐mail also specifies the date on which you’ll need to update your 
dongle. Before that date arrives, follow this procedure to perform the update: 

1. Start the CHEMCAD program; you should see the License Settings dialog 
box appear automatically. If necessary, you can open this dialog box using 
either Tools > Options > License Settings (with a simulation open) or 
License > License Settings (with no simulation open). 

2. Within the License Settings dialog box, click the tab with the same name as 
the type of hardware dongle that you use: Sentinel Scribe, NetSentinel, 
SuperPro, or SuperPro Net. 

3. On the tab you’ve selected, find the Re‐program button—Re‐program 
SentinelSuperPro, for example. Click this button to begin the re‐
programming procedure. 

 
Figure 2-06: Re-programming a SuperPro dongle from the License Settings dialog box 

4. When the Browse for Folder dialog box appears, navigate to the location 
where you saved the .DNG configuration file. Normally, this is the Windows 
desktop; if you saved your configuration file there, click Desktop to tell 
CHEMCAD where to look for the file, then click OK. 
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Figure 2-07: Selecting the location where the configuration file resides 

5. CHEMCAD re‐programs the dongle and then displays a “success” pop‐up 
window. 

 
Figure 2-08: Successful re-programming of a CHEMCAD dongle 

6. Click OK to close the pop‐up window. If the Licenses in Use screen appears, 
click OK to close it. 

You should now be able to open CHEMCAD and proceed normally. 

Getting Help with CHEMCAD 
If you find that you have questions that are not addressed in this User Guide, you 
can turn to several resources for CHEMCAD help. 

Online Help 
At any time while running CHEMCAD in an active window, you can press the [F1] 
key to bring up the CHEMCAD Help screen that’s most appropriate to the task you 
are currently performing or the dialog box currently displayed. 

In some situations, pressing [F1] will bring up the main CHEMCAD 6 Help 
window instead of a particular help screen. From there, you can click the Contents, 
Index, or Search tab in the upper left corner of the CHEMCAD 6 Help window, and 
use these tools to find the information you need. 

You can also go directly to the main CHEMCAD 6 Help window by selecting 
Help > Help Topics from the CHEMCAD main menu. Regardless of how you open 
CHEMCAD Help, it always opens in a separate window that does not interfere with 
the operation of the CHEMCAD program. 
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CHEMCAD Coach 
The CHEMCAD Coach pane is a tool that you can open within CHEMCAD to view 
concise instructions for common procedures. To see a list of available topics, select 
Help > CHEMCAD Coach. Then click on any link in the CHEMCAD Coach window 
to view the instructions for a specific task. 

Procedure Demos 
Animated demonstrations of common tasks are available to help you get started 
using the CHEMCAD program. Topics covered include the various steps involved in 
creating a basic simulation; procedures for simulations involving batch reactors, heat 
exchanger sizing, and piping; control valve rating and sizing; creating an Excel Data 
Map; and updating a licensing dongle. 

The demo files are installed along with CHEMCAD. To access these demos, 
select Start > All Programs > Chemstations > Demos, and then browse the list of 
available topics. Click the button for the demo you’d like to view and then click Play 
to run the demo. 

The Chemstations Web Site 
To find the most recent updates of the CHEMCAD software, manuals, and various 
training tools, go to www.chemstations.net. There you’ll find the following items 
available for download: 

• The latest release of CHEMCAD 

• A list of updates implemented in the most recent release 

• The latest version of CHEMCAD 6.0 Help 

• CHEMCAD 6.0 Interactive Demos 

• Programming guides for interfacing with CHEMCAD 

Contacting Chemstations Technical Support 
If you are unable to solve a problem or find the answer to a question using this 
manual or the other tools listed here, you can contact Chemstations’ technical 
support staff for assistance. 

Our technical support engineers 
are available via e‐mail, or by phone 
Monday through Friday, 7:00 AM 
through 6:00 PM Central Standard 
Time. 

Outside of the United States, please see www.chemstations.com for regional 
contact information. 

Phone: 713.978.7700 

Toll-free (U.S. and Canada): 800.243.6223 

FAX: 713.978.7727 

E-mail: support@chemstations.com 
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Chapter 3 

The CHEMCAD Interface 

With the release of Version 6.0, the CHEMCAD interface has undergone quite a 
transformation. For this reason, even long‐time users of CHEMCAD will benefit 
from a review of the program’s screen layout and the location of important features. 

This chapter takes you on a tour of the CHEMCAD screen, including the menus 
and toolbars, the main areas of the screen, and the flowsheet drawing tools. It also 
shows you some ways that you can customize the screen layout so that it best suits 
your own way of working. 

The CHEMCAD Window 
When you launch the CHEMCAD program for the first time, you’ll see a screen with 
a large white area in the middle and various panes, or specialized areas, at the edges 
of the screen. 

 

Workspace 
 
CHEMCAD 
Explorer pane 
 
Palette pane 
 
 
Messages pane 
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The Workspace 
The area in the middle of the screen is known as the workspace. This is the main focus 
of the CHEMCAD window, the place where you’ll build and edit flowsheets, view 
graphs, and run and tweak process simulations. 

When you first launch CHEMCAD, the workspace is solid white. When you start 
to build a flowsheet or open an existing simulation, the flowsheet displays in the 
workspace. 

The workspace uses tabs to enable you to switch between your open simulation 
and any open Excel Data Maps and/or data plots. At the bottom of the workspace 
area, you’ll see one or more tabs whenever a simulation is open. Each tab includes a 
button marked with an X; to close any tab, first click the tab and then click the X 
button. 

 
Figure 3-01: The bottom of the workspace area, showing several tabs and their X buttons 

Note that any time you’ve closed a simulation and haven’t yet opened another 
one, the workspace displays as a blank gray space. 

The CHEMCAD Explorer Pane 
Along the left edge of the CHEMCAD window, you’ll see an area with a title bar at 
the top that reads CHEMCAD Explorer. At the bottom of the CHEMCAD Explorer 
pane are three tabs called Recent Files, Simulation, and Visual Basic. To view the 
contents of a tab, simply click its name. 

 
Figure 3-02: CHEMCAD Explorer tabs 

The CHEMCAD Explorer tabs are presented in what’s known as a tree format, 
with items organized into a multi‐level hierarchy. The default view shows only top‐
level items, but you can expand each item to view second‐level items, third‐level 
items, and so forth. 

At the left of each top‐level item is a small box with a plus sign. To expand an 
item, click the plus sign. Two things happen simultaneously when you click: the tree 
expands to show that item’s contents, and the plus sign becomes a minus sign. You 
can hide (or collapse) the lower‐level items again by clicking the minus sign, which 
then turns back into a plus sign. Figure 3‐03 shows an example of a CHEMCAD 
Explorer item in collapsed and expanded view. 
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Figure 3-03: Clicking the plus sign to expand an item (left); the resulting view (right) 

Expanding and collapsing items in the CHEMCAD Explorer tabs is one way that 
you can make the best use of your screen space when working in CHEMCAD. 

The Recent Files Tab 
The Recent Files tab is selected by default when you first launch CHEMCAD. This 
tab lists all of the simulation files that you have opened lately, starting with the most 
recent. When you first install CHEMCAD, the list is empty, but with every 
simulation that you open—new files or existing ones such as built‐in examples—the 
list will grow, providing convenient access to files that you use frequently. 

To open a simulation from the Recent Files list, simply double‐click on the file 
name in the list. 

The Simulation Tab 
The Simulation tab displays by default any time a simulation is open. It provides a 
series of shortcuts to common commands and settings, including: 

• Components: Includes one‐click access to component, electrolyte, and solids 
selection, as well as distillation curves 

• Thermodynamics: Provides quick access to thermodynamic settings and 
transport properties 

• Flowsheet: Allows quick editing of UnitOp and stream data 

• Data Maps: Enables you to create or set execution rules for a Data Map 
without using the menu 
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• Groups: Provides an easy way to categorize UnitOps, streams, and 
components  

• Layers: Allows selected parts of the flowsheet to be displayed or hidden for 
viewing and printing 

• Templates: Stores and organizes stream and UnitOp specifications that you 
can “clone” for re‐use 

Expand any of these items to see and use specific features, which are described in 
further detail in the appropriate chapters of this user guide. 

The Visual Basic Tab 
If you use Visual Basic to customize CHEMCAD, this tab provides quick and easy 
access to your Visual Basic code. You can expand the Reactions, Properties, or 
UnitOps item to view available subroutines for that category. Clicking the name of a 
subroutine opens a Visual Basic editor in a separate window. 

The Palette Pane 
Along the right side of the CHEMCAD window is a pane titled Palette, which is a 
repository for the various unit operation icons and other tools needed to draw 
flowsheets. 

Selecting a Palette 
These UnitOp icons and tools are grouped into palettes according to function or 
equipment type. The default palette is called All UnitOps, and it includes every 
available UnitOp icon and drawing tool. To select a different palette, simply click its 
title bar. The selected palette expands in place, as shown in Figure 3‐04. 

 
Figure 3-04: The expanded Piping and Flow palette 
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Customizing Palettes 
At the top of the Palette pane is a field called Search for UnitOp(s). Type a search 
term here and then click Go! to locate all of the UnitOp icons associated with that 
term. The results from the search appear in a new palette at the bottom of the Palette 
pane. Figure 3‐05 shows the search results for the word vessel. 

 
Figure 3-05: Search results showing all vessel UnitOps 

Performing a UnitOp search creates what is known as a user‐added palette. This 
type of palette is designated with a special icon at the left end of the palette heading. 

The palette containing your search results remains available until you close 
CHEMCAD. You can make your user‐added palette available permanently by right‐
clicking the new palette’s title bar and selecting Save.  

 
Figure 3-06: Saving search results for future use 
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You can do the following with user‐added palettes: 

• Rename any user‐added palette by right‐clicking its title bar and selecting 
Rename. In the resulting dialog box, type the name you want and then click 
OK. 

• Delete a user‐added palette at any time by right‐clicking and selecting 
Remove. 

• Add individual UnitOps or tools to an existing user‐added palette. Simply 
right‐click the icon for the item you want to add, select Insert into Palette, 
and then click the name of the user‐added palette. 

• Remove an item from a user‐added palette by right‐clicking the icon and 
selecting Remove from Palette. 

• Create a user‐added palette without a search. Right‐click the first icon that 
you’d like to include on a new palette and select Insert into Palette > New 
Palette. Type a name in the resulting dialog box and click OK. Then add as 
many other icons as you’d like using the method described just above. 

You cannot change the name or icon selection for a built‐in palette, as you can 
with a user‐added palette. You can, however, make a copy of a built‐in palette, 
rename the copy, and then add and delete icons until the palette has just what you 
want. 

To copy any palette (whether built‐in or user‐added), simply right‐click the 
palette heading and select Save Copy As. Type a name for the new palette and click 
OK. 

The Messages Pane 
The Messages pane is located at the bottom edge of the CHEMCAD workspace. At 
the bottom of this pane are three tabs: Errors and Warnings, Run Trace, and Notes. 

The Errors and Warnings Tab 
This tab displays a running list of error and warning messages that have been 
generated while the current simulation file has been open. The oldest messages 
display at the top of the list. When there are too many cumulative messages to 
display in the pane, the most recent messages display and the older messages scroll 
off the top edge of the pane. If needed, you can use the vertical scroll bar on the right 
side of the pane to scroll up and review earlier messages. 

The Run Trace Tab 
This tab displays diagnostic messages from each UnitOp each time a simulation is 
run. This information is helpful in troubleshooting a simulation that is not working 
properly. 

The text on the Run Trace tab is not saved with the simulation, but refreshes with 
each run and clears when you close the simulation. 
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The Notes Tab 
This tab provides a handy place to store additional information, in text form, about 
the simulation. You can use it to list any details about the simulation, such as its 
origin and any assumptions that are being made. 

Any notes that you add or change are saved as part of the simulation. To delete 
text from a note, simply click and drag to select the text and then press [DELETE] on 
your keyboard. 

The Main Menu 
The main CHEMCAD menu is located just under the title bar at the top of the 
program window. Some items on the main menu are common to nearly all Windows 
programs—namely File, Edit, Format, and Help—while other menu items such as 
Thermophysical and Sizing are more specific to chemical process simulation. 

To use a menu command, click the relevant main menu item and then click the 
command in the drop‐down list that appears. 

To execute menu commands without using the mouse, you can hold down the 
[ALT] key on your keyboard as you press the letter key that corresponds to the 
underlined letter in the desired menu item, for example [ALT‐F] for the File menu. 
You can then use the up and down arrow keys to select an item on the menu and 
press [ENTER] to execute the selected command. 

The Toolbar 
The CHEMCAD toolbar provides buttons that are common to most Windows 
applications, such as New, Open, Save, and Print, along with buttons that are 
specific to chemical process simulation. 

To discover the use of a particular button, simply point your mouse cursor at the 
button and watch for the tooltip to appear, as shown in Figure 3‐07. 

 
Figure 3-07: Viewing a button’s tooltip 

Toolbar buttons provide quick, one‐click access to frequently‐used commands 
that are also available via the CHEMCAD menus. 

Customizing the CHEMCAD Screen 
When you first install CHEMCAD, the screen is laid out with the CHEMCAD 
Explorer pane on the left, the Palette pane on the right, and the Messages pane below 
the workspace. 
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If having all of these items visible leaves you less workspace than you would 
prefer, or if the location of one or more panes is less than optimal for the way that 
you work, you can hide or move panes to customize your CHEMCAD screen. 

Viewing and Hiding Screen Elements 
You can view or hide any of the CHEMCAD screen’s panes, as well as groups of 
toolbar buttons, to make optimal use of your screen space. 

To toggle a pane on or off, select the View menu and then choose CHEMCAD 
Explorer, Palette, or Messages. Items with a check mark are currently displayed, 
while items with no check mark are currently hidden. You can also choose to view or 
hide the status bar at the bottom of the CHEMCAD window. 

To selectively view or hide groups of toolbar buttons, select View > Toolbars. In 
the Toolbars dialog box, each group of buttons is listed under a descriptive name; 
initially, all of these groups have check marks, indicating that they are currently 
displayed. To hide any group of buttons, click to remove the check mark and then 
click Close to return to the main CHEMCAD window. 

Resizing and Moving Items 
Now that you have determined which panes and toolbar button groups to display, 
you can further customize your CHEMCAD window to determine exactly where 
each of these items will appear. 

Resizing a Pane 
The simplest way to alter the appearance of a pane is to resize it. You can make the 
CHEMCAD Explorer and Palette panes wider or narrower, or make the Messages 
pane shorter or taller, by moving the inside edge, or wall, of the pane toward or 
away from the edge of the main window. 

To resize a pane, start by positioning your mouse cursor at the inside wall of the 
pane—that is, the right edge of the CHEMCAD Explorer pane, the left edge of the 
Palette pane, or the top edge of the Messages pane. When the cursor is in the correct 
position for resizing, the normal pointer will be replaced with a two‐headed arrow 
as shown in Figure 3‐08. 

 
Figure 3-08: The two-headed arrow cursor used for resizing panes 
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When you see the two‐headed arrow, click and drag in the direction you want to 
move the pane wall. A thick gray line shows a preview of the new pane size; when 
you release the mouse button, the resized pane appears. 

Moving a Pane 
In addition to resizing, you can also move any of the panes in the CHEMCAD 
window, either to a different edge of the screen or to the middle of the screen. You 
can also move groups of buttons from their default positions on the toolbar. 

Initially, all of the panes and button groups are docked, meaning that they are 
“snapped into” an edge of the screen or the toolbar area. When you undock an item, 
you can put it in the location of your choosing, away from the screen edge. 

To undock a pane, click and drag the pane’s title bar, that is, the blue bar at the 
top of the pane that shows the pane name. To undock a button group, you’ll need to 
click and drag the row of four dots running along the left edge of the leftmost button 
in the group. 

Note: In the case of the Messages pane, the title bar runs along the left edge of the 
pane, and the name is not visible when the pane is docked. 

If you drag the pane or button group into the workspace area, you’ll see a gray 
box representing the position the item will occupy when you release the mouse 
button. If you don’t like the new position, you can click the item’s title bar and drag 
it elsewhere, including its original position. 

You can also dock a pane to a different edge of the screen, or move button 
groups around within the toolbar area, instead of undocking these items. 

Pinning and Unpinning Panes 
In addition to moving and resizing the various panes, there’s another way that you 
can customize your CHEMCAD screen: pinning and unpinning the CHEMCAD 
Explorer and Palette panes. 

These two panes can take up a fair amount of horizontal screen space, and 
making them very narrow isn’t an ideal way to work. Pinning and unpinning 
provide a way to view full‐width CHEMCAD Explorer and Palette panes when you 
need these tools, while also freeing up space when you aren’t using them. 

Whenever either of these panes is docked at an edge of the screen, it is in one of 
two states: 

• Pinned, meaning that the pane is always visible 

• Unpinned, meaning that the pane is mostly hidden from view, and appears only 
on demand 

By default, all CHEMCAD panes are initially pinned in place. You can choose to 
unpin a pane if you prefer to have some extra space on the screen. To unpin a pane, 
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find the tiny pushpin icon in the pane’s title bar, next to the X icon that enables you 
to close the pane. If the pane is stationary, you’ll see that the pin is upright with its 
point down. 

 
Figure 3-09: The icon indicating a pinned, or stationary, pane 

If you click the pin icon, the pane suddenly disappears from view—but it isn’t 
gone. Instead, a small gray tab bearing the name of the palette appears at the edge of 
the screen where the pane is docked. To see the pane reappear, you only have to roll 
your mouse over that tab. When the pane appears, you’ll notice that the pushpin 
icon is now pointed to the side. Use the tools on the CHEMCAD Explorer or Palette 
normally; then, when you no longer need the pane, just move the mouse pointer 
elsewhere. The pane will automatically hide itself until the next time you roll the 
mouse over the tab. 

 
Figure 3-10: An unpinned pane in use; note the sideways pin icon 

To re‐pin an unpinned pane, point to the tab to make the pane appear and then 
click the pin icon. The pin turns so that it is once again upright, and the pane is once 
again a permanent fixture on the CHEMCAD screen. 

Other Useful Interface Hints 
The following are helpful items that can help to make your CHEMCAD experience 
easier and more efficient. 

Undo and Redo 
As with most Windows‐based programs, CHEMCAD allows you to “back out” of 
actions you have just taken while working with a file. You can use the Undo 
command to negate the last change you made; simply select Edit > Undo, or use the 
key combination [CTRL‐Z]. 

You can use the Undo command to retract up to the last 99 actions that you 
performed since the last time you opened the current simulation file. 

Visible Grid 
You can turn on a workspace grid to use as a guide while creating your flowsheet. 
Select View > Grid Visible to toggle this feature on or off. 
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Other grid options include View > Snap to Grid, which helps with alignment of 
objects on the flowsheet, and View > Change Grid Size, which enables you to 
customize the horizontal and vertical spacing of grid lines. 

Adjusting Your View of the Workspace 
The View > Zoom Options menu offers a whole series of options for moving and 
resizing your view of the CHEMCAD workspace. 

• Select In to view the workspace from closer in, or Out to view from farther away. 

• Select either In at a Point or Out at a Point, and then click a point on the 
workspace, to zoom in or out with that point as a focus. 

• Select Zoom Rectangle, and then click and drag on the workspace, to designate a 
specific area that you want to view. 

• Select Zoom Percentage to choose a specific display size for the workspace. 

• Select Zoom to Fit to view at the largest size that still permits all of the existing 
flowsheet elements to remain in the visible workspace. 

If your computer mouse is equipped with a scroll wheel between the left and 
right mouse buttons, you can zoom in and out on the CHEMCAD workspace with a 
touch of your finger. To zoom in, roll the wheel up—that is, push your fingertip 
away, toward the top edge of the mouse. To zoom out, roll the wheel down toward 
the bottom of your mouse, pulling your fingertip toward your palm. 

Note: When you zoom in and out using the scroll wheel, the focal point for the zoom 
is the location of the mouse pointer. 

The CHEMCAD Coach Pane 
The CHEMCAD Coach pane is not displayed by default, but you can access it at any 
time by selecting Help > CHEMCAD Coach. The purpose of CHEMCAD Coach is to 
provide concise instructions for common procedures. If you’ve learned how to 
perform a common procedure in CHEMCAD but have forgotten the exact menu 
command to use, CHEMCAD Coach can help jog your memory and put you on the 
right track. 

You can drag the CHEMCAD Coach window to any location on the screen, 
simply by clicking and dragging the title bar at the top of the window. 

If you have finished using the CHEMCAD Coach tool and want to close it, just 
click the Close button (the red X) in the upper right corner of the CHEMCAD Coach 
window. Note that if the main CHEMCAD window was maximized before you 
opened the CHEMCAD Coach tool, you may need to maximize the CHEMCAD 
window again to restore it to full‐screen size. 
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Chapter 4 

Working with Simulation Files 

All of the work that you do with CHEMCAD is stored in simulation files. With the 
advent of CHEMCAD 6, each discrete simulation is packaged into a single file that is 
portable and easy to handle. All the details of the simulation—from UnitOp 
specifications to stream composition to thermodynamics—are included in this file. 
This chapter describes the various ways that you can access and manage CHEMCAD 
simulation files. 

About CHEMCAD Simulation Files 
Simulations created in CHEMCAD 6 use the file extension .CC6, which distinguishes 
them from other files on your computer, including simulation files created using 
earlier versions of CHEMCAD. 

One of the most notable differences between .CC6 files and predecessors such as 
.CCX files is their portability. A .CC6 simulation file is as easy to work with, 
transport, and share as an MS Word document or an Excel spreadsheet. Whereas 
CHEMCAD simulations once required extra steps before they could be e‐mailed or 
moved, simulations created with CHEMCAD 6 can be handled as stand‐alone files. 
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Figure 4-01: Stand-alone CHEMCAD 6 files in the My Simulations directory 

User Components in CHEMCAD 
Another departure from previous versions of CHEMCAD is that simulations 
are now self‐contained with respect to the data needed to run them. All custom 
components that you create are stored in a database so that you can use them in 
many different simulations. User components are also stored within the simulations 
that use them, so you no longer have to worry about losing user components when 
moving a simulation from place to place. 

Each time you open a simulation, CHEMCAD compares any user components in 
the simulation with the copies of those same components in the database. If the two 
copies do not match, you will be offered a choice: you can keep using the local copy 
stored in the simulation, or use the updated copy from the database. 

Your copy of CHEMCAD can now have multiple user databases, and even share 
them on networks with other users. To learn more about user components and best 
practices for managing and securing user component databases, see Chapter 10, 
Customizing CHEMCAD. 

Example Files 
Especially if you’re new to CHEMCAD, it’s a good idea to open and practice 
working with some example files before creating your own simulations. For this 
purpose, we’ve created numerous examples of simulations for typical chemical 
processes. You can open, view, and edit any example file, and even save a copy in 
another location to jump‐start a simulation of your own. 

The CHEMCAD example files are automatically copied to your computer with a 
complete CHEMCAD installation. The examples are organized by process type and 
located in the \My Documents\My Simulations\Examples directory. 
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Opening an Existing Simulation 
Select File > Open to bring up the Open dialog box. Navigate to the folder where the 
simulation is located, select the appropriate .CC6 file, and click Open. 

If you use CHEMCAD on a network and share files with other users, it’s possible 
that you could try to open a simulation that is already open for editing by another 
user. If you should attempt to open a simulation that is unavailable for editing, a 
message box will appear. You can choose to save the simulation with a new name 
and/or location, open a read‐only copy of the simulation, or cancel the open 
operation. 

 
Figure 4-02: Notification that a simulation is already in use 

If you should have trouble locating a particular simulation, you can search your 
hard drive or network for all files with a .CC6 file extension.  

Creating a New Simulation 
When you first open CHEMCAD, you’ll see a blank simulation window and 
[Untitled] in the title bar. 

You can begin building your simulation right away, but it’s recommended that 
you save and name the simulation before you proceed very far. The longer you wait 
to save the simulation, the more you risk losing your work if an unforeseen 
computer or network problem should occur. 

If you already have a simulation file open and want to start a new simulation, 
first save your work if applicable. Then select File > New or click the New toolbar 
button, to close the current file and bring up a new blank simulation screen. Note 
that if you have unsaved changes in your existing file, CHEMCAD will ask you to 
save or discard your changes before opening the new simulation. 
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Saving a Simulation 
To save all changes in a simulation that you have already named, select File > Save 
or click the Save button on the toolbar. 

Note: In some cases, such as the built‐in CHEMCAD example files, existing files may 
be set as read‐only to prevent accidental overwriting. You can save a copy of a read‐
only file using a different file name and/or file location. 

To save a new simulation that you haven’t yet named, select File > Save As. The 
Save As dialog box appears, with CHEMCAD 6 (*.cc6) as the default file type. Leave 
the file type as it is, give the file a unique name, and if necessary navigate to a new 
file location. Click Save to close the dialog box and return to the saved simulation. 

 
Figure 4-03: Giving a new simulation a unique name 

Note: Unlike previous versions of CHEMCAD, the changes you make to a simulation 
are not saved until you use the Save or Save As command. This offers you greater 
flexibility in choosing which changes to save or discard. 

Saving and storing all of your simulations in the same directory helps prevent 
the lost time and frustration that can result when files are scattered in different 
locations. It is recommended that you store your simulations in the My Simulations 
folder, which is created automatically within the My Documents folder at 
installation. 

Saving Different Cases for the Same Simulation 
In certain situations, you may need to create a group of simulations that are nearly 
identical to one another; previous versions of CHEMCAD referred to such groups of 
similar simulations as cases. In CHEMCAD 6, each simulation is a free‐standing file, 
but you can still easily “clone” simulations and make minor changes for comparison 
cases. 
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To do this, simply create a simulation, save it, and then select File > Save As to 
rename the next case. Make the needed changes for that case, save it, and continue in 
that vein to create as many clones of your original simulation as needed, with 
whatever differences you require. 

E-mailing a Simulation 
With CHEMCAD 6, e‐mailing a simulation is a simple matter of adding a file 
attachment. Just open your preferred e ‐mail program, create a new message, choose 
your recipients and add your text, then use the program’s command for attaching a 
file. Navigate to the folder where the simulation is located, select the appropriate 
.CC6 file, and add the file as an attachment. 

 
Figure 4-04: Adding a .CC6 file as an attachment in MS Outlook 

Before you e‐mail a simulation, you should ensure that you have saved any 
recent changes. Also, it’s a good idea to check the size of the file before adding the 
attachment, as simulation files can in some cases be quite large. 

Working with CHEMCAD Files from Previous Versions 
You can use CHEMCAD 6 to open simulations that were originally created with 
CHEMCAD 5. When you do this, CHEMCAD creates a copy of the original 
simulation, and makes that copy compatible with all CHEMCAD 6 functionality. The 
flowsheet and simulation data in the copy are not altered in any way, and the 
original file is left intact. 
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To bring an existing simulation up to date with CHEMCAD 6, select File > Open, 
select the simulation, and click Open. A message will appear, notifying you that the 
simulation will be copied.  

 
Figure 4-05: Converting a CHEMCAD 5 file to the .CC6 format 

Click Save to bring up the Save As dialog box, where you can either keep or 
change the file’s name and select a location for the CHEMCAD 6 copy. Click Save to 
create and open the new file. 
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Chapter 5 

Building and Using a Basic Simulation 

Although the types of simulations you can create using CHEMCAD are many and 
varied, the basic procedure for creating a simulation can be broken down into the 
following common steps: 

1. Start a new simulation. 

2. Select engineering units for the simulation. 

3. Create a flowsheet with the appropriate streams and unit operations. 

4. Select chemical components for the process. 

5. Select K‐value and enthalpy options for the process. 

6. Define the feed streams used in the process. 

7. Enter specifications for the unit operations. 

8. Run the simulation. 

9. Review the results of the simulation. 

Starting a New Simulation 
Launch CHEMCAD and then select File > Save As. In the Save As dialog box, 
specify a name and location for the simulation file. 

When you first install CHEMCAD, the default location for saving new 
simulations is a folder called My Simulations, located within your computer’s My 
Documents folder. You can save your new simulation to that folder, or to any 
accessible directory on your computer or network. As you’ll notice in the Save As 
dialog box, the file extension for CHEMCAD simulation files is .CC6. 
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Selecting Engineering Units 
To specify engineering units for this simulation, select Format > Engineering Units. 
This brings up the Engineering Unit Selection dialog box, where you can select the 
units to be used for everything from time and temperature to surface tension. The 
majority of the options in this dialog box are located on the Units selection tab, but 
you can click a second tab called Options and references for more options. 

The buttons along the bottom of the Units selection tab enable you to set all of 
the units to English, alternative SI, SI, or metric. If your desired units do not fit neatly 
into one of these categories, you can choose the closest one and then manually select 
different units for any items you like. 

If you do find yourself customizing your list of units, you can save your 
selections as a set, or profile, that you can quickly duplicate for future simulations. To 
do this, first set all of the units the way you want them, then type a name for this 
profile and click the Save Profile button. 

You may not notice anything happening when you click Save Profile, but you 
can verify that your new profile has been saved by clicking the Load Profile button. 
This is the button that you will use for future simulations, to apply your custom 
units profile with a single click. You should see a Select Item screen that shows the 
name you gave the profile. If you click the profile name and then click OK, you’ll 
load your custom units profile. 

Back on the Engineering Unit Selection dialog box, click OK to apply your 
engineering unit selections and continue creating your simulation. 

Drawing the Flowsheet 
To create the flowsheet for your simulation, you’ll need to add the appropriate unit 
operation icons to your workspace and connect those UnitOps to one another with 
streams. This connected group of streams and UnitOps forms the basis for the 
simulation. 

The tools for drawing a flowsheet are located in the Palette pane, which by 
default displays on the right margin of the CHEMCAD window. The Palette pane is 
divided into UnitOp categories, or you can view all of the available UnitOp icons at 
once using the All UnitOps view. 

Adding UnitOps 
To place a UnitOp icon on your flowsheet, follow these steps: 

1. On the All UnitOps palette, find the appropriate UnitOp icon for the 
equipment you want to represent. When you point to the icon with the 
mouse, the box around the icon lights up. Click the icon to select the UnitOp. 

2. Move your mouse cursor to the workspace area, noting that the pointer 
displays an outline of the UnitOp icon you’ve selected. Point to the location 
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on the workspace where you want to place the selected UnitOp, and then 
click and release the left mouse button. The icon for the selected UnitOp 
appears where you clicked. 

3. Right‐click to deselect the UnitOp drawing tool and return to a normal 
pointer. You can now click in the workspace area without drawing duplicate 
UnitOps. 

Selecting a Default Icon for a UnitOp 
For certain UnitOps, you can select a default icon to customize the way that type of 
equipment looks on your flowsheet. 

Note: Icons that are already in place on the flowsheet will not be affected when you 
select a new default icon. 

You can see which icons offer this feature by moving your cursor over the All 
UnitOps palette, noting the boxes that light up around the icons. A UnitOp that 
offers a choice of default icons will have a black triangle in the lower right corner 
when you point to its box. 

 
Figure 5-01: Black triangle showing that the Divider UnitOp offers a choice of icons 

To select a new default icon for a UnitOp, click the black triangle to see a pop‐up 
selection box with all available icons. Click the icon you want to use; that icon 
replaces the previously displayed icon on the palette. You can change the default 
icon for a UnitOp as often as you like. 

 
Figure 5-02: Selecting a new default Divider UnitOp icon 
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Manipulating UnitOp Icons 
After drawing a UnitOp icon on a flowsheet, you can move, resize, or delete the icon 
as needed. 

1. Verify that the mouse pointer currently displayed is a normal arrow. If the 
pointer displays as a UnitOp icon outline, right‐click to turn off UnitOp 
drawing. 

2. Click the UnitOp icon so that its four sizing handles (black boxes at each 
corner) appear. 

3. Manipulate the UnitOp icon as needed: 

• To move the UnitOp, click the icon and drag to its new location. 

• To resize the UnitOp, click any sizing handle and drag inward or 
outward to achieve the desired size. 

• To delete the UnitOp, right‐click and select Delete, or simply press the 
[DELETE] key on your keyboard. 

Drawing and Connecting a Stream 
Before you can add a stream to a flowsheet, you must already have drawn the 
UnitOps that the stream will connect. Follow these steps to add a stream: 

1. Click the Stream tool in the upper right corner of the All UnitOps palette. 

2. Move the cursor onto the workspace, noting that the pointer now appears as 
a small plus sign. Find the icon for the UnitOp where the stream will start, 
and point at the icon so that the blue inlet dots and red outlet dots are visible. 
If this UnitOp offers more than one outlet location, decide which one you will 
use. 

3. Point at the red outlet dot so that the pointer turns into a small black arrow. 
Click and release the left mouse button to start drawing the stream. 

4. Move the cursor toward the UnitOp where the stream will end. As you 
approach the UnitOp icon, the inlet and outlet dots on that icon will become 
visible. If more than one inlet location is available, decide which one you will 
use. 

5. When you reach the blue inlet dot, click the mouse again to complete the 
stream. 

After you draw a stream, the Stream tool remains active so that you can draw 
another stream right away if desired. To turn off stream drawing, simply click on 
any blank area of the workspace; this returns your pointer to the normal white 
arrow, which you can use to select and manipulate items on the flowsheet.  
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Choosing a Stream Route 
If you draw a stream by clicking only at the UnitOp outlet and inlet, CHEMCAD 
chooses the shortest and most direct path for the stream. In some situations—when a 
UnitOp is in the direct path of the stream, for example—you will need to choose a 
deliberate route for your stream. 

To do this, click the mouse as you move from outlet to inlet, wherever you want 
the stream to make a turn. Each time you click, the stream freezes in place, and from 
there you can make a 90° turn to either the left or the right. You can add as many 
detours as you like to a stream before bringing it into a UnitOp inlet. 

 
Figure 5-03: Stream 2 with automatic routing (above) and deliberate routing (below) 

Rerouting a Stream 
Even after you’ve completed your flowsheet and added detailed information about 
your streams, you can still reroute a stream if needed. To do this, click the stream to 
select it, then right‐click and select Reroute stream. The old stream disappears, 
replaced by the beginning of a new stream originating at the same outlet. 

You can now click to create 90° turns, the same way you would with a new 
stream, to route the stream exactly where you want it. Your last click must complete 
the stream at the same inlet you used before. After a stream is rerouted, it retains all 
of the stream detail that you had previously entered. 
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Other Drawing Tools 
In addition to the Stream tool and the various UnitOp icons, the Palette pane offers a 
text tool, as well as tools for drawing rectangles, ellipses, lines, multi‐part lines, and 
polygons. 

The Text Tool 
To place text on a flowsheet, select the Text tool (which displays a large letter T) on 
the All UnitOps palette. When you move your cursor over the workspace, you’ll 
now see that your pointer has become a vertical line. Click the mouse to place a 
blinking cursor on the flowsheet. 

Start typing the text that you want to add. You will see the text appear wherever 
you clicked the mouse. When you finish, click anywhere in the workspace to turn off 
the Text tool. 

You can now click and drag your new block of text around the workspace. You 
can also select Format > Color or Format > Font to access various standard text and 
object formatting tools. 

Simple Drawing Tools: Rectangle, Ellipse, and Line 
You can draw various shapes as needed on a flowsheet. The simplest of these shapes 
to draw are rectangles, ellipses, and lines. 

To add any of these shapes to a flowsheet, simply click the corresponding tool in 
the All UnitOps palette. Then, then click and drag in the workspace to draw the 
shape, releasing the mouse button when you have achieved the desired size and 
shape. 

Note that to make a perfect square or circle, you can hold down the [SHIFT] key 
as you draw with the Rectangle or Ellipse tool, respectively. 

Complex Drawing Tools: Multi-line and Polygon 
In addition to these straightforward, click‐and‐drag shapes, you can also create more 
complex shapes and lines on a flowsheet. 

To create any open figure with an irregular shape, select the Multi‐line tool in 
the All UnitOps palette. Move your cursor to the workspace and click in the area 
where you want to start drawing. Then move the cursor and click again to create the 
shape’s first line. Keep clicking and moving the mouse until you’ve created the 
shape you want, and then double‐click to complete the shape and turn off the Multi‐
line tool. 

To create an irregular closed polygon, select the Polygon tool and then move 
your cursor to the workspace. Click where you want to start drawing, and then click 
a second time to create the first side of your polygon. After the second click, you’ll 
begin to see the open area being created. Continue moving the cursor and clicking 
until you are ready to place your last point, and then double‐click to complete the 
shape and turn off the Polygon tool. 



 Building and Using a Basic Simulation 

CHEMCAD Version 6 User Guide  41 

Note that you can hold down the [SHIFT] key while using the Polygon tool to 
create a right triangle. 

Selecting Chemical Components 
You can select chemical components for your simulation at any point while creating 
the flowsheet, or you can wait until you’ve drawn the entire flowsheet before adding 
components. Before you can run the simulation, you will need to list every 
component involved in your chemical process so that CHEMCAD can work with 
those components’ properties. 

These chemical components are pulled from CHEMCAD’s component database, a 
master list of thousands of chemicals with their associated properties. When you’re 
ready to list components for your simulation, select Thermophysical > Select 
Components to open the Select Components dialog box. 

 
Figure 5-04: The Select Components dialog box 

The Available Components column lists the contents of the CHEMCAD 
component database, while the Selected Components column lists the components 
currently included in this simulation. For a new simulation, the Selected 
Components list is empty at first. 

Every chemical that will be part of the process, whether it’s a feed stream, 
product, or utility, must be listed on this simulation’s component list. 

Finding a Component 
Because of the large number of components in the CHEMCAD component database, 
scrolling up and down the list of available components can be time‐consuming. To 
find a specific component quickly, use the Search box at the bottom of the Select 
Components dialog box. 

Type the name of the chemical you want to find in the Search box. With each 
letter that you type, CHEMCAD suggests possible matches in the Available 
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Components list. In the following example, typing the letters wa in the Search field 
has highlighted the Water component. 

 
Figure 5-05: Using the Search box to locate the Water component 

The Search field accepts both text and numeric entries. By default, CHEMCAD 
will search for your entry among all chemical names, chemical formulas, 
CHEMCAD database IDs, and CAS numbers. If you would prefer not to search this 
broadly, click the Options button. This brings up a dialog box that enables you to 
“opt out” of including any of these items in your searches. 

 
Figure 5-06: Selecting what to include in component searches 

Note: You can add your own custom components to the CHEMCAD component 
database. For more details about this feature, see Chapter 10 of this manual. 

Adding a Component 
Once you’ve located the component you want in the Available Components list, 
simply double‐click the component to add it to the Selected Components list for your 
simulation. 

You can also select multiple components in the Available Components list and 
then click the right arrow button, located between the two columns, to add the 
components to your simulation. To select multiple components, use Windows’ 
standard selection methods of holding down [SHIFT] to select contiguous items or 
holding down [CTRL] to select non‐contiguous items. 
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Figure 5-07: Adding multiple components using the right arrow button 

If you would like to duplicate the component list from an existing simulation, 
click Copy From Another Simulation. In the resulting Open dialog box, navigate to 
the desired simulation, select that simulation, and click Open. The Selected 
Components list is now populated with the components used in the simulation you 
selected; you can add or delete items to customize the list. 

Changing the Order of Selected Components 
When your Selected Components list for a simulation is particularly long, you may 
find it helpful to place certain components at either the top or the bottom of the list. 
You can add components in any order, and then move them around in the list as 
needed. 

To move a component to a new position in the Selected Components list, click 
the component to select it and then: 

• Click Top to move it to the first position on the list. 

• Click Up to move it up one position. 

• Click Down to move it down one position. 

• Click Bottom to move it to the last position on the list. 

Removing Items from the Selected Components List 
To remove a single component from the Selected Components list, click the 
component to select it and then click Delete in the bottom right area of the Select 
Components dialog box. 

To remove all components from the Selected Components list and begin again, 
click Clear, just to the right of Delete. If you have changed your mind about adding 
components at this time, you can simply click Cancel to back out of component 
selection. 
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Selecting K-value and Enthalpy Options 
The first time you complete the Component Selection dialog box, you’ll be taken to 
the Thermodynamics Wizard dialog box. At this point, you can either click Cancel to 
skip the wizard and enter thermodynamics manually, or enter parameters in the 
dialog box and click OK to see which methods the wizard suggests. 

Using the Thermodynamics Wizard 
Proper selection of thermodynamics is generally the most important step in a 
process simulation. A poor thermodynamics selection may lead to unrealistic 
simulation results. 

The Thermodynamics Wizard makes general suggestions, based on your 
component list and the specified ranges for temperature and pressure.  

Selecting Components to Ignore 
In the upper portion of the wizard screen, use the drop‐down boxes to indicate any 
components that the Thermodynamics Wizard should not consider. This may affect 
the results for model suggestion. For example, if you are using water as a coolant 
and your other components are alkanes, the Thermodynamics Wizard will choose 
UNIFAC. If you specify that water should be ignored, the wizard will ignore the 
water and select SRK. 

Specifying Process Conditions 
In the lower portion of the wizard screen, specify the approximate temperature and 
pressure ranges for this process. Entering accurate information in these fields will 
help the Thermodynamics Wizard return a more useful recommendation. 

In the BIP Data Threshold field, enter the minimum percentage of possible 
binary interaction parameters (BIPs) which must be present in a BIP activity 
coefficient model (NRTL, Wilson, etc). Without BIPs, activity coefficient models 
simplify to Raoult’s law. 

How the Thermodynamics Wizard Makes Suggestions 
CHEMCAD’s Thermodynamics Wizard follows a logic tree to choose a model. The 
logic tree assumes that all your components are mixed in a vessel, with conditions 
falling into the specified temperature and pressure ranges. 

• If all components are hydrocarbons, the wizard will likely suggest an 
equation of state. 

• If water is present, the wizard will likely select an activity coefficient method. 

• If water and hydrocarbons are present, the wizard will likely select UNIFAC. 

• If water and strong electrolytes (HCl, NaOH, etc.) are detected, the wizard 
will suggest electrolyte models. 
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 Temperature and pressure range will affect the selection of model. If pressure is 
high, CHEMCAD is more likely to suggest an equation of state. If pressure is 
atmospheric and temperature is below the normal boiling point of all components, 
CHEMCAD may choose a liquid activity model or ideal vapor pressure. 

Should the Thermodynamics Wizard be trusted to make design decisions? 
Use the wizard as a starting point for your decision. Proper selection of 
thermodynamics is the engineer’s responsibility. Your simulation may call for the 
use of a different thermodynamic model than what the Thermodynamics Wizard 
suggests. 

 Manually Selecting Thermodynamics Settings 
To set up thermodynamics for your simulation manually, follow these steps: 

1. Select Thermophysical > Thermodynamic Settings, or click the button by the 
same name on the toolbar. 

 
Figure 5-08: The Thermodynamic Settings button on the toolbar 

2. This opens the Thermodynamic Settings dialog box. Start by determining, 
based on your process knowledge, whether your system has two liquid 
phases or a single liquid phase. In the Global K Value Option field, select a 
method that can calculate the phase behavior relevant to your system. 

3. Based on the specific circumstances of your process, make any needed 
alterations to the options displayed on the K‐value Models tab. Note that the 
options appropriate to your selected K‐value method are displayed in black, 
while irrelevant options are displayed in gray. 

4. Click Enthalpy Models tab, select the most appropriate model in the Global 
Enthalpy Option field, and make any other changes to the options on this tab 
as needed for your process. 

5. Click the Transport Properties tab and verify that the settings there are 
appropriate for this simulation. Change any settings as needed and then click 
OK to close the Thermodynamic Settings dialog box. 

6. If you’ve made any changes, a message box appears: All streams should be 
reinitialized. Proceed with reinitialization? Click Yes to reinitialize all streams 
now, or No if you’d prefer to wait and reinitialize the streams later. 
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Defining Streams 
The streams that you have drawn on your flowsheet are still just lines with no data 
behind them, so the next step is to edit these streams, populating them with 
composition data and other properties. 

Note: In most situations, the streams you’ll need to define will be the feed streams in 
your process. Other types of streams, such as recycle cut streams, may also require 
definition. 

You can edit a single feed stream using either of these methods: 

• Double‐click the stream. 

• On the Simulation tab in the CHEMCAD Explorer, expand Flowsheet and 
then Streams, right‐click the stream in question, and select Edit Stream. 

You can edit all feed streams in the flowsheet at once using either of these 
methods: 

• Select Specifications > Feed Streams. 

• Click the Edit Feed Streams toolbar button, which displays a large red feed 
stream arrow. 

Whichever method you choose, you’ll see the Edit Streams dialog box, with 
either a single column of data or a column for each feed stream in the flowsheet. In 
this dialog box, specify properties for each feed stream listed. 

Thermodynamic Properties 
You must specify exactly two of the following three variables: 

• Temp F 

• Pres psia 

• Vapor Fraction 

CHEMCAD will calculate the third variable and enthalpy, based on the two 
variables you specify and the thermodynamics method you’ve selected. 

Stream Composition 
To define the stream composition, you’ll need to specify a composition unit and the 
amount of each component that is present in the stream. 

Select a unit from the Comp unit drop‐down list, and then based on that 
selection, populate the field for each component with the appropriate amount, 
percentage, or fraction. 

For stream compositions expressed as a percentage or fraction, you can enter 
values that do not total 100%. In this case, CHEMCAD will normalize the 
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composition to fractional values that total 1. To preview the normalized values that 
CHEMCAD assigns to the components, click Flash. 

Total Flow Properties 
If the component flow engineering unit used for a stream is dimensionless (i.e., mole 
fraction, weight fraction, or volume fraction), you must specify the following flow 
properties: 

• Total flow 

• Total flow unit 

If you enter your component amounts as fractions, then you must also enter a 
total flow rate. If you enter composition amounts using quantitative flow units, 
CHEMCAD calculates the total flow rate for you. 

Specifying Equipment Parameters 
Once you have specified the necessary stream properties for your simulation, the 
next step is to enter specifications for the UnitOps. You can edit the properties of a 
UnitOp using any of the following methods: 

• Double‐click the UnitOp icon on the flowsheet. 

• Click the UnitOp icon and then select Specifications > Edit UnitOps > Select 
UnitOps. 

• On the Simulation tab in the CHEMCAD Explorer, expand Flowsheet and 
then UnitOps, right‐click the UnitOp in question, and select Edit UnitOp 
Data. 

The dialog box that displays when you go to edit a UnitOp’s properties will 
depend on the type of UnitOp. The Stream Mixer UnitOp, for example, has only one 
specification that you can set, while the SCDS Column UnitOp has five tabbed pages 
of detailed settings. 

 
Figure 5-09: Two different UnitOps that require very different amounts of input 
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The detailed information about the specifications for each type of UnitOp is 
contained in the CHEMCAD Help system, which you can access from any 
CHEMCAD screen by pressing the [F1] key. 

These specification screens do, however, have certain rules in common: 

• Items with green text labels are required entries. 

• All other entries are optional. 

• Clicking OK saves your specification changes; clicking Cancel discards them. 

After you click OK, CHEMCAD checks your data for internal consistency and 
then returns errors or warnings as warranted. These items display in the Messages 
pane in the CHEMCAD window. 

Running the Simulation 
Now that you’ve drawn the flowsheet and added detail to the streams and UnitOps 
that make up the flowsheet, you can run the simulation. You can either select Run > 
Run > Run All or simply click the Run button on the toolbar. 

When you run a simulation, CHEMCAD calculates material and energy balances 
throughout the entire flowsheet and returns any errors or warnings discovered in 
the flowsheet. If the run completes successfully, a Run finished message appears at 
the far left of the status bar, at the very bottom of the CHEMCAD window. 

Note: For preliminary checks of individual UnitOps or groups of UnitOps, you can 
select Run > Run > Run Selected UnitOp(s). 

Reviewing the Results 
After a simulation has run, you can call up any number of individual text‐based 
reports or graphical plots, either for on‐screen viewing or for printing. Reports can 
provide data on any single stream or UnitOp, or any group of streams or UnitOps, in 
a steady‐state or dynamic simulation. You can also request a consolidated report that 
provides comprehensive data on the streams and UnitOps you select. 

Note: CHEMCAD reports, plotting, and plot printing are covered in detail in 
Chapter 8, Output and Reports.  
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Chapter 6 

Using CHEMCAD for High-fidelity Modeling 

Unit operation specifications in CHEMCAD vary greatly in detail, from vague and 
conceptual to extremely specific and realistic. Depending on the demands of your 
process and what you’re trying to achieve with your simulation, you may work with 
what we call low‐fidelity modeling, high‐fidelity modeling, or both. 

This chapter addresses CHEMCAD’s capacity for high‐fidelity modeling and 
how to achieve a high level of realism with your UnitOps. 

What is high-fidelity modeling? 
With low‐fidelity modeling, you specify what you want, or what you have observed, 
and CHEMCAD makes its calculations based on the assumption that you can 
achieve what you’ve specified. It’s common to specify observed properties such as 
temperature and/or pressure coming out of a UnitOp, or component purity coming 
out of a separation unit. Specifying temperature coming out of a heat exchanger is an 
example of low‐fidelity modeling.  

High‐fidelity modeling, on the other hand, requires that you enter numerous 
extensive variables. CHEMCAD calculates the resulting conditions based on these 
detailed entries. With high‐fidelity modeling, you’re often required to specify 
geometry‐related variables for a UnitOp so that CHEMCAD can calculate precise 
conditions at the equipment’s outlet. 

Here’s the key distinction between low‐fidelity and high‐fidelity modeling in 
CHEMCAD: 

• Low‐fidelity: You specify the desired results and CHEMCAD assumes that you 
can achieve those results with the equipment you have. 
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• High‐fidelity: You specify energy and equipment parameters and CHEMCAD 
calculates the actual results. 

Criteria for High-fidelity Modeling 
To take advantage of CHEMCAD’s high‐fidelity modeling capabilities, you must 
provide detailed specifications for your equipment. To do this, most UnitOps require 
that you select a calculation mode that allows for entry of high‐fidelity‐caliber detail. 

For example, if you have a pump that is set to the default mode of Specify outlet 
pressure, you’ll get a low‐fidelity result from this pump—that is, the simulation will 
use the outlet pressure that you specify, but without consideration for the size of the 
pump, the amount of fluid entering the pump, or inlet pressure. 

If you switch the pump to Specify performance curve, a high‐fidelity mode, you’ll 
need to enter data points from the pump’s performance curve, either for a single 
speed line or for multiple speed lines. Using this mode, CHEMCAD will calculate 
the change of pressure head based on the performance data and the inlet volumetric 
flow rate. This provides a realistic pressure increase for the actual pump that your 
process uses. 

Not every type of CHEMCAD UnitOp lends itself to high‐fidelity modeling. The 
following sections discuss various types of UnitOps that do offer high‐fidelity 
calculation modes, and provide some basic information about how to use those 
modes. 

Introduction to Equipment Sizing 
Equipment sizing in CHEMCAD is optional. It entails using the Sizing menu 
options, generally after running a simulation, to calculate approximate sizes for 
pipes, vessels, valves, orifices, and other equipment. 

 
Figure 6-01: The Sizing menu, showing heat exchanger sizing options 

Equipment sizing can complement low‐fidelity results, and often provides an 
excellent starting point for high‐fidelity modeling. You can use certain sizing results 
as input for high‐fidelity models of UnitOps in your simulation. Specifying 
geometric parameters for UnitOps can help you obtain more realistic results. 

Note that for low‐fidelity modeling, sizing does not change converged flowsheet 
results. Also, for some UnitOps, certain geometry parameters must be entered 
regardless of the selected calculation mode. 
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High-fidelity Modeling and Sizing for Common UnitOps 
High‐fidelity modeling does not apply to all CHEMCAD UnitOps. This section 
summarizes those UnitOps for which you can use high‐fidelity modeling, and 
compares that approach for each UnitOp type to low‐fidelity modeling. Where 
applicable, UnitOp sizing is also discussed as it relates to low‐fidelity versus high‐
fidelity modeling of these UnitOp types. 

Piping 
You can use either low‐ or high‐fidelity modeling for piping in your simulation. 
Pipeline sizing is done based on the composition of a selected stream. 

Low-fidelity 
For low‐fidelity modeling of piping, you are required to specify pipe diameter and 
length in most modes; design modes that calculate diameter are the obvious 
exception to this. The pressure drop through the pipe is calculated based on 
diameter, length, and flow rate through the pipe. 

Sizing 
To perform sizing calculations, select Sizing > Piping. Select one or more streams, 
then in the Pipe Sizing dialog box, select a sizing option and click OK for line sizing 
results. You can use these results, such as suggested pipe thickness and diameter, to 
specify geometry for a Pipe UnitOp, or simply review them for the information you 
need. 

 
Figure 6-02: Line sizing results from the Pipe Sizing dialog box 

High-fidelity 
In high‐fidelity piping models, Pipe UnitOps interact with Node UnitOps to balance 
pressure and flow rates hydraulically among connected pieces of flow‐based 
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equipment. Nodes must be placed on both sides of all Pipe UnitOps to be included 
in hydraulic balance; pressure and flow constraints are set at the nodes, not in the 
pipes. 

A high‐fidelity piping model can show changes in flow rate based on back 
pressure where two pipes mix, whereas a low‐fidelity model would simply assign 
the lower of two specified pressures to the outlet without consideration for back 
pressure. 

Pumps, Compressors, and Expanders 
You can create pump, compressor, and expander UnitOps using either low‐fidelity 
or high‐fidelity modeling. 

Low-fidelity 
For these equipment types, CHEMCAD calculates power usage and thermal effects 
on the fluid, based on specified output pressure or pressure increase. Other 
parameters, such as efficiency, are optional but do affect results. 

High-fidelity 
To produce a high‐fidelity model for these equipment types, you must select the 
operation mode in which you specify performance curves—that is, pressure change 
as a function of volumetric flow rate. This performance information is generally 
available from the equipment vendor. Based on the volumetric flow entering the 
UnitOp, CHEMCAD calculates outlet pressure. 

 As with piping, high‐fidelity modeling for pumps, compressors, and expanders 
can be used with nodes as part of a hydraulic flow balanced network. 

Vessels and Tanks 
You can add vessels and tanks to your simulations using high‐fidelity modeling, or 
perform limited approximation of these equipment types with low fidelity in steady 
state. Sizing is available for certain types of vessels. 

Low-fidelity 
With low‐fidelity modeling of a vessel or tank, a stream enters the Flash UnitOp and 
separates into vapor and liquid; CHEMCAD does not consider hold‐up or liquid 
level in the tank. If you want to take a steady‐state snapshot of the vessel, you can 
manually adjust the flow rate and/or thermal conditions to make volumetric flow 
rates match the volume of the vessel. 

Note: The Tank UnitOp is specifically intended for use with the Batch Column 
UnitOp. It does not represent a standard storage tank for general purposes. 
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Sizing 
To calculate sizing for a vessel, select a Flash UnitOp and then select Sizing > Vessel. 
Choose either LV Vessel (liquid‐vapor vessel) or LLV Vessel (liquid‐liquid‐vapor 
vessel), depending on your needs. In the resulting dialog boxes, enter the 
appropriate values for your vessel and click OK. 

 
Figure 6-03: Sizing a vessel in CHEMCAD 

The results that CHEMCAD returns include basic vessel geometry such as height 
and diameter. 

You can also perform vessel sizing on a converged distillation column to 
calculate geometry for a reflux drum or similar piece of equipment. 

High-fidelity 
You can perform high‐fidelity modeling only on batch reactors and dynamic vessels, 
and only with a CC‐DYNAMICS license (for dynamic vessels, a CC‐SAFETY NET 
license will suffice). If you specify the geometry of your vessel and use CHEMCAD’s 
dynamics mode, you can study what happens in the vessel over time as material is 
added or withdrawn. 

Unlike simple flash vessels, batch reactors and dynamic vessels do consider 
hold‐up, liquid level, and variable pressure over time. 

Valves 
Valve modeling in CHEMCAD can be either low‐fidelity or high‐fidelity. You can 
size a control valve based on any flowsheet stream. 

Low-fidelity 
The VALV UnitOp is used for low‐fidelity modeling of a valve. For this type of 
UnitOp, you specify outlet pressure or pressure decrease through the valve. 
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Sizing 
Select Sizing > Control Valve, then select a stream. In the Control Valve Sizing 
dialog box, specify the outlet pressure for the theoretical valve, and enter other 
specifications as appropriate. When you click OK, CHEMCAD returns information 
such as capacity coefficient (Cv) and valve size. 

 

High-fidelity 
The CVAL UnitOp is used for high‐fidelity valve modeling. Decide which values 
you will provide and which values CHEMCAD will calculate, and select the 
appropriate operating mode in the Control Valve dialog box. Provide the valve’s Cv 
value, and any other specifications as needed. 

Control valves can be used with nodes as part of a hydraulic flow balanced 
network. 

Columns 
Columns in CHEMCAD can be modeled as either low‐fidelity or high‐fidelity. You 
can perform sizing on any converged column. 

Low-fidelity 
For low‐fidelity modeling of columns, use the Tower, Tower Plus, or SCDS UnitOps. 
Specify ideal stages and the conditions at the reboiler and condenser, as applicable. 
A low‐fidelity column model does not consider mass transfer effects or column 
internals. 

Different column specifications can provide more realism without taking 
geometry into account. Specifying top purity is a very low‐fidelity model, while 
specifying reflux ratio or condenser duty can bring your results closer to reality.  

Sizing 
After running your simulation, click the UnitOp representing the distillation column 
and select Sizing > Distillation; choose either Trays or Packing, based on the type of 
column. 

The resulting dialog boxes prompt you to enter information about your trays or 
packing and the calculation methods you want to use for column sizing. You will 
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generally need to enter some geometry and hydraulic parameters to complete 
column sizing. 

 
Figure 6-04: Specifying high-level tray data for distillation column sizing 

 
Figure 6-05: Specifying detailed tray data 

Based on flowsheet values and your sizing input, CHEMCAD returns column 
geometry information such as height and diameter. It also provides hydraulic 
performance information such as predicted amount of flooding. 

Note: The results of column sizing calculations do not interactively change the results 
of the flowsheet simulation. 

High-fidelity 
To perform high‐fidelity modeling of a distillation column in steady state, use the 
SCDS UnitOp and select either of the mass‐transfer simulation models for the 
column. 
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You will need to specify geometry for the column and choose a calculation 
method for the selected mass‐transfer model. CHEMCAD calculates column 
performance based on your packing or tray specifications. 

For columns, mass‐transfer‐based modeling performs rigorous non‐equilibrium 
mixing of vapor and liquid, whereas low‐fidelity modeling assumes ideal mixing. 

To perform high‐fidelity modeling of a distillation column in dynamics, specify 
the geometry of the column and details about the control system. This dynamic 
distillation can consider column hold‐up and the effect of variables changing over 
time. 

Note: The Shortcut Column UnitOp is not a rigorous calculation model. Unless your 
system satisfies the constant molar underflow assumption, you should consider 
using a different type of distillation column. 

Heat Exchangers 
When specifying a heat exchanger in a simulation, you can use either low‐ or high‐
fidelity modeling as well as sizing, depending on the type of heat exchanger 
involved. 

Low-fidelity 
When creating a simulation, you can use a low‐fidelity approach by simply 
specifying the thermal conditions coming out of the exchanger. Specifying heat duty 
instead of merely an outlet temperature brings your results closer to reality, but this 
approach still doesn’t consider geometry. 

Sizing 
You can use the CC‐THERM module for rigorous calculation of heat transfer 
coefficient (U) based on heat exchanger geometry. In rating mode, CC‐THERM 
determines whether the user‐specified heat exchanger is capable of the flowsheet 
heat exchanger performance. In design mode, CC‐THERM calculates an exchanger 
design that is capable of the flowsheet performance. 

High-fidelity 
For some exchanger categories—specifically shell‐and‐tube and double‐pipe—you 
can use the rigorous CC‐THERM model to calculate heat exchanger performance. 
The flowsheet results are based on rigorously calculated U value and the specified 
exchanger geometry. You can also determine approximate fouling of a unit if actual 
outlet temperatures are known. 
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Figure 6-06: Heat exchanger summary report generated as an Excel worksheet 

Relief Devices 
For relief devices, sizing is not necessarily distinct from low‐fidelity modeling. To 
model dynamic relief of a vessel, you can instead use high‐fidelity modeling. 

Low-fidelity 
To model a steady‐state snapshot of a relief device, select Sizing > Relief Device, 
specify rating or design mode, and select the appropriate options for your relief 
scenario. When you click OK, CHEMCAD returns a relief device calculation 
summary. 

If you select the Rigorous integral analysis design method when sizing a relief 
device, you will obtain a more dynamic result. 

 
Figure 6-07: Selecting the rigorous integral analysis method for relief device design 
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High-fidelity 
You can perform high‐fidelity relief device modeling for the Batch Reactor and 
Dynamic Vessel UnitOps. You can specify the relief device nozzle area, as well as 
other specifications for your relief scenario. This enables you to study the dynamic 
relief of the vessel. 

Licensing Considerations for High-fidelity Modeling 
To use the heat exchanger sizing functionality, you must currently have a valid 
license for the CC‐THERM module of CHEMCAD. To use batch reactors, you’ll need 
a valid license for the CC‐DYNAMICS module. For dynamic vessels, a license for 
either CC‐DYNAMICS or CC‐SAFETY NET is required. 

If you don’t currently have access to the heat exchanger sizing or dynamics 
features and want to add any of these modules to your copy of CHEMCAD, contact 
the person within your organization who handles software licensing, or if 
appropriate, you can contact Chemstations or a CHEMCAD distributor directly. For 
a complete list of Chemstations contacts for all parts of the globe, see our web site 
(www.chemstations.net/contact.htm). 

License Settings 
If you’ve just added modules to your CHEMCAD license, you should return to the 
License Settings screen to change settings before proceeding. 

Select Tools > Options > License Settings (if a simulation is open) or License > 
License Settings (if no simulation is open) to bring up the License Settings screen. 
Move the slider for each newly‐installed module to As Needed and then click OK to 
apply your changes. 

You may see a Trace Messages window; if one appears, click OK to close it. The 
next screen that appears is the Licenses in Use screen, where you can review the list 
of CHEMCAD products for which you currently have licenses. Click OK to close this 
screen and return to the main CHEMCAD window. 
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Chapter 7 

Building and Using a Dynamic Simulation 

While steady‐state modeling can provide all of the information you need for many 
purposes, it’s often informative to look closely at the changes over time that affect 
your streams and equipment. CHEMCAD’s CC‐DYNAMICS module makes it 
possible to simulate a process over time. 

What do we mean by dynamics? 
We use the term dynamics to describe modeling a chemical process over a set period 
of time. During the course of a real‐world chemical process, factors such as utility 
temperature, feed composition, and liquid levels tend to change. Modeling the 
response of your process to these changes can help you understand and predict what 
might happen with your process over time. 

Given a flowsheet, a length of time to run, and the calculation interval to use, 
CHEMCAD can return detailed results that take into account these types of changes. 
The program can consider the material holdup within process equipment such as 
tanks, reactors, and pipes. It also enables you to model control systems such as PID 
controllers. 

Licensing Considerations 
To use the functionality described in this chapter, you must have a valid license for 
the CC‐DYNAMICS module of CHEMCAD. 

If you don’t currently have access to the dynamics features and want to add CC‐
DYNAMICS to your copy of CHEMCAD, contact the person within your 
organization who handles software licensing, or if appropriate, you can contact 
Chemstations or a CHEMCAD distributor directly. For a complete list of 
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Chemstations contacts and CHEMCAD distributors for all parts of the globe, see our 
web site (www.chemstations.com/contact.htm). 

License Settings 
If you’ve just added CC‐DYNAMICS to your CHEMCAD license, you’ll need to 
return to the License Settings screen to change a setting before you can run dynamic 
simulations. 

Select Tools > Options > License Settings (if a simulation is open) or License > 
License Settings (if no simulation is open) to bring up the License Settings screen. 
Move the slider for CC‐DYNAMICS to As Needed and then click OK to apply your 
change. 

You may see a Trace Messages window; if one appears, click OK to close it. The 
next screen that appears is the Licenses in Use screen, where you can review the 
CHEMCAD products (including CC‐DYNAMICS) for which you currently have 
licenses. Click OK to close this screen and return to the main CHEMCAD window. 

Additional Input for Dynamic Operation 
Before you create a dynamic simulation, you’ll need to gather the relevant 
information about your UnitOps and streams, as you would with any simulation. In 
addition, you need to be able to answer the following dynamics‐specific questions: 

• How long will the simulation run? 

• What will be the interval (delta time/step size) between calculations? 

• What is the change that you want to study over time? 

• If applicable, what is the initial composition and charge of any dynamic 
vessels or batch reactors? 

The basic steps for a dynamic simulation are largely the same as those for a 
steady‐state simulation, with a few vital differences: 

1. Create a new simulation. 

2. Select engineering units. 

3. Draw the flowsheet. 

4. Select components. 

5. Select thermodynamics options. 

6. Specify feed streams and initial stream conditions. 

7. Set specifications for UnitOps. 

8. Run the simulation in steady state to obtain time‐zero values. 

9. Switch the simulation to dynamics. 

10. Specify dynamics settings, such as run time and initial charge(s). 
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11. Run the simulation in dynamics. 

12. Review the results. 

13. Re‐run or extend the simulation as needed. 

14. Generate plots and reports as needed. 

Before you start working on a dynamic simulation, it’s important to have as 
much information about your process as possible, a clear idea of what you want to 
find out, and a strategy for producing the results you need. 

Strategies for Dynamic Simulations 
When you start planning a dynamic simulation, it’s vital that you know what 
question or questions you are trying to answer. To get useful, informative results, 
you should start with a simple question and then refine the simulation and run it 
again. 

For example, to discover how heat affects a vessel’s temperature over time, you 
might start by applying constant heat to the vessel for the duration of your dynamic 
simulation. You can then save a copy of that simulation, change it to use variable 
heat, and review the results to see how they differ from the original. Based on that 
second simulation, you can make another copy, and this time try variable heat with a 
control system to attempt to maintain a consistent temperature. Each of these 
dynamic simulations would bring you closer to what you actually want to discover. 
Each subsequent simulation requires more information from you to run and return 
the results you want. 

While there is no requirement that you approach dynamics problems this way, 
it’s a sound practice that will save you time and frustration in the long run. 

Setting Up Dynamic Operation 
Before you can run a dynamic simulation, you need to provide parameters such as 
run time and step size. First, however, you must activate CHEMCAD’s dynamics 
mode. 

Switching to Dynamics 
Follow these steps to switch a simulation from steady‐state to dynamic operation: 

1. Open the simulation and select Run > Convergence. This brings up the 
Convergence Parameters dialog box. 

2. In the lower right portion of the dialog box, click in the Steady 
State/Dynamics field and select Dynamics.  
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Figure 7-01: Switching to dynamics 

3. Click OK to save the changes and close the dialog box. 

After you switch to dynamics, you’ll notice that a few things have changed on 
the CHEMCAD screen: 

• The status bar at the bottom of the main CHEMCAD window changes. A few 
inches from the right edge of the screen, instead of the words Steady State, 
you’ll now see DTime and a time counter displaying the number of minutes 
your simulation has run. Before you run the simulation, the DTime setting 
displays 0:00 min. 

• The steady‐state Run All button on the toolbar is disabled, and the dynamics 
buttons are now activated. These buttons, shown in Figure 7‐02, are (left to 
right) Set Run Time, Reset to Initial State, Run Dynamic Simulation, Plot 
Dyn Streams, and Plot Dyn UnitOps. 

 
Figure 7-02: Toolbar buttons for dynamics 
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• You can now select Run > Dynamics to bring up the Dynamics Menu. This 
window provides convenient access to all dynamics settings and commands. 

 
Figure 7-03: The Dynamics Menu 

Setting the Run Time 
The next step is to set the run time for the simulation. First decide whether your run 
will require a single step or multiple steps. 

A step in this case refers to a time period during which CHEMCAD will capture 
data from the simulation at uniform intervals. For example, you might set up a 
single‐step dynamic run of 60 minutes, with a step size of one minute, for a total of 
60 data points for the run. If this is all that you need to do, your run can be 
accomplished in a single step. 

If, on the other hand, you need to run your process for 60 minutes capturing data 
at one‐minute intervals, and then switch to capturing data every 30 seconds for the 
next 20 minutes, you’ll need to use two steps. If you want to record data every five 
minutes for the first hour, every minute for the second hour, and every 30 seconds 
for the third hour, you’ll need to use three steps. 

The step size that you select will have an impact on the accuracy of the results 
and the speed of the calculation. Smaller time steps produce more precise results, but 
also require more time to make the run. Smaller isn’t always better, however, as 
extremely small time steps can lead to significant round‐off error. 
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Once you know how many steps you need to use and what your data‐capture 
interval will be for each step, follow these steps to set the run time parameters: 

1. Click Set Run Time on the Dynamics Menu, or click the Set Run Time 
button on the toolbar. This brings up the Dynamic Run Time Schedule dialog 
box. 

 
Figure 7-04: The General tab on the Dynamic Run Time Schedule dialog box 

2. On the General tab, set the number of operation steps you plan to use, or 
leave the default setting of 1. The maximum number of steps that you can 
specify is 10. 

Note: When you initially set up dynamics for a simulation, the Current time display 
field on this tab will be empty. After the simulation has run, this field displays the 
total time of a completed run or the current time of an interrupted run. 

3. Now click the Step 1 tab and specify the parameters for this portion of the 
dynamic run. Enter the total time for this dynamic step in the Run time field, 
and the interval in minutes in the Step size field. 

 
Figure 7-05: The Step 1 tab on the Dynamic Run Time Schedule dialog box 

4. If you have other steps to specify, click each tab in turn and enter the Run 
time and Step size information. 

5. When you have specified all steps, click OK to return to the main 
CHEMCAD window. 
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The Dynamic Run Time Schedule dialog box also allows for conditions other 
than time to determine the duration of a dynamic operation step. If you select 
Stream or Equipment instead of the default Time option, you can specify a stream 
or UnitOp parameter that will trigger the end of this step, if that parameter is 
reached before the step’s run time is up. 

Selecting Streams and UnitOps 
Now that you have specified how long your dynamic process will run, you need to 
tell CHEMCAD what stream and UnitOp data to record during the run. 

1. If the Dynamics Menu is not already open, select Run > Dynamics to open it, 
then click the Record Streams button. 

2. In the Record Streams dialog box, do one of the following: 

• Check the Select streams from flowsheet box, click OK, and then use the 
mouse to add streams to the Select Streams dialog box. 

• Type the names of streams you want to record in the ID boxes. 

 
Figure 7-06: The Record Streams dialog box 

3. When you have selected all the streams you want to record, click OK to 
return to the Dynamics Menu. 

4. Now click the Record UnitOps button. In the Record UnitOps dialog box, 
select UnitOps in the same way that you selected streams in step 2. 

5. Click OK to return to the Dynamics Menu. 
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Note: In both the Record Streams and Record UnitOps dialog boxes, you can use the 
RunTimePlot check boxes to include selected items in a real‐time plot. Selecting 
items for runtime plotting leads to another dialog box (either Dynamic Stream Plot 
Options or Dynamic Equipment Plot Options), where you can select plot specifics for 
each stream or UnitOp. It is recommended that you use runtime plotting in 
moderation, as too many streams and UnitOps can become visually confusing and 
slow down calculations considerably. 

Running a Dynamic Simulation 
Now that you have set the run time and recording parameters, you can run the 
simulation. When you run a dynamic simulation in CHEMCAD, a calculation of the 
entire flowsheet runs for each step in the time range that you select. 

In dynamics mode, you have three options for running a simulation: run from 
the simulation’s initial state, run from the simulation’s current state, or advance the 
simulation one time interval at a time manually. 

Note: At any point during a dynamic run, you can press the [ESC] key on your 
keyboard to stop the run after the current calculation. When you do this, you will see 
a Program interrupted message. Click OK to close the message box, and then either 
inspect your run results or select a run command to continue. 

Run from Initial State 
This option resets the flowsheet to its initial conditions and begins the dynamic 
simulation. When you run a simulation this way, all results from previous 
simulations are discarded. 

To use this option, use either the Run from Initial State button on the Dynamics 
Menu or the Run Dynamic Simulation button on the CHEMCAD toolbar. 

Run from Current State 
When you use this option, the dynamic run begins from the current conditions. 
Those conditions might be the initial state of the flowsheet, the end of a previous 
run, or the middle of an interrupted run. Selecting this option continues the 
simulation from the current state, i.e., from the last calculated result. 

You can use this option only when some calculations remain to be run. This 
means that unless you have interrupted the run using [ESC] or the step‐by‐step 
method described in the next section, you must schedule one or more additional 
steps using the Dynamic Run Time Schedule before continuing.  

Use the Run from Current State button on the Dynamics Menu to run the 
simulation starting from current conditions. 
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Run One Step at a Time 
If you want to get a detailed view of your dynamic run as it unfolds, you can choose 
to run one interval at a time. With this option, the dynamic run will stop after each 
discrete time step. To run the next time step, you will need to use the Run Dynamic 
Simulation toolbar button or the Run from Current State button on the Dynamics 
Menu. 

To use this frame‐by‐frame approach to dynamics, select Run > Convergence 
and then check the box called Run one time step for dynamic simulation. Click OK 
to confirm this change. To turn off this feature, return to the Convergence 
Parameters dialog box to clear this check box. 

 
Figure 7-07: Convergence Parameters setting to run one step at a time 

Other Dynamic Commands 
In addition to the options for dynamic run setup and dynamic commands, the 
Dynamics Menu offers two other items: Reset to Initial State and Save as Initial 
State.  

Reset to Initial State 
In a dynamic simulation, you can change stream and UnitOp specifications only 
when the dynamic time is set to zero. During or after a run, if you attempt to edit the 
specification dialog box for a UnitOp, you will find the OK button disabled and a 
message instructing you to restore the simulation to its initial state. 

 
Figure 7-08: A UnitOp specification dialog box during a dynamic run 
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To return the simulation to its initial state—also known as time zero—click the 
Reset to Initial State button on the Dynamics Menu, or use the Reset to Initial State 
button on the main CHEMCAD toolbar. 

Note: An advanced feature to allow specification editing at any time is available, but 
should be used with extreme caution to avoid confusion and unintended results. 
This feature is controlled by a check box on the Convergence Parameters dialog box. 

Save As Initial State 
The Save as Initial State command sets the current conditions of the dynamic run as 
the new initial state. It discards all parameters from the previous initial state, and 
makes it impossible to recover the previous initial state data. 

An example of a dynamic run can illustrate the usefulness of this command. 
Suppose that you run a simulation for five minutes and the temperature in a vessel 
increases from 50° C to 70° C. You decide that 70° C is a better starting point for this 
vessel, and you want to capture all of the other values that correspond to that 
temperature in this vessel. You can achieve this by saving the current conditions as 
the initial state. 

To do this, click the Save as Initial State button on the Dynamics Menu. You will 
see a message warning you that you will lose the original state conditions if you 
continue. If you are prepared to do this, click Yes. For our example, this would mean 
losing the first five minutes of your previous run, along with the 50° C starting 
temperature for the vessel. 

After you save a new initial state, the Run from Initial State and Reset to Initial 
State commands both reference your new initial state settings. 

Output from Dynamic Simulations 
The results from dynamic simulations are markedly different from those produced 
by steady‐state simulations, primarily in that they record data trends over time 
instead of a static snapshot of a fixed process. With dynamic simulations, 
comparisons of slightly different process specifications, and of the same process at 
different points during a run, can be very useful. 

For this reason, you may find that graphical reports provide the most useful 
information when you’re working with dynamic simulations. CHEMCAD provides 
a series of dynamics plotting options to meet this need; you can also generate 
various text‐based reports, and view calculated flowsheet values at any point during 
a dynamic run or after a run is complete. 

Reviewing the Flowsheet Specifications 
A snapshot of flowsheet values from a dynamic run doesn’t provide as much value 
as it would for a steady‐state run, but it can come in handy in many situations. 
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After running a dynamic simulation, you can view the data behind any 
flowsheet stream or UnitOp to see the effects of the run calculations. Double‐click 
any stream or UnitOp on the flowsheet to review its end‐of‐run values. 

You can also stop to review flowsheet data in the middle of a run, either by using 
the Run one time step for dynamic simulation option or by pressing [ESC] to pause 
a run. Once the run has stopped, you can double‐click any stream or UnitOp to 
review its current values. 

Plotting Dynamic Results 
You can plot the results of dynamic simulations using either the Plot menu or the 
dynamics buttons on the main CHEMCAD toolbar. 

Dynamic plots display selected values over time. The following dynamic plots 
are available: 

• Batch Reactor/DVSL History: This plot displays selected values for a batch 
reactor or dynamic vessel, including composition of the vessel contents over 
time. The dialog box used to generate this plot is user‐friendly and focuses on 
the most commonly used variables for these types of equipment. 

• Dynamic Column History: This plot displays selected values for a dynamic 
column, including composition of trays, distillate, and bottoms. 

• Dynamic Stream History: This plot displays selected stream properties from 
any recorded stream. You can also generate this report using the Plot Dyn 
Streams toolbar button. 

• Dynamic UnitOp History: This plot displays selected UnitOp parameters 
from any recorded UnitOp. You can also generate this report using the Plot 
Dyn UnitOps toolbar button. 

Note: For the Dynamic Stream History and Dynamic UnitOp History plots, be sure 
to record the streams and UnitOps that you want to study. You can only request 
these plots for recorded streams or UnitOps.  

Text-based Dynamic Reports 
Based on the graphical results of your dynamic simulation run, you may decide to 
make changes to your process, run parameters, or both, and then re‐run the 
simulation. When you have fine‐tuned your simulation and obtained satisfactory 
results, you can view those results in text form as well as graphical form, for a more 
detailed look at exact values.  

To access text‐based dynamic reports, select Report > Dynamics and then select 
one of the following reports: 

• Dynamic Column History: This report provides dynamic column results for 
a selected column. The Print Report Options dialog box offers the most 
relevant items for dynamic column reporting.  
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• Dynamic Stream History: This report provides stream histories for a specific 
stream that you select, based on the interval that you specify and including 
the compositions, components, and stream properties that you select.  

• Dynamic UnitOp History: This report provides detailed information about a 
dynamic UnitOp in the simulation, based on the interval that you specify and 
including the UnitOp parameters that you select. 

Note: For the Dynamic Stream History and Dynamic UnitOp History reports, be sure 
to record the streams and UnitOps that you want to study. You can only request 
these reports for recorded streams or UnitOps. 
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Chapter 8 

Output and Reports 

One of CHEMCAD’s greatest strengths is its capacity to provide detailed, 
customized information about equipment, streams, and processes. You can create 
custom reports from simulations, spec sheets for UnitOps, and databoxes for process 
flow diagrams, and you can plot or print any of these items in the most appropriate 
format. 

Text Reports 
CHEMCAD can produce a wide array of customizable text‐based simulation reports, 
based on stream data, UnitOp data, flowsheet data, or dynamics. If you prefer, you 
can produce one consolidated report incorporating all of the available text report 
data.  

Report Setup 
Before you run, view, or print reports, you should check the settings that determine 
which programs CHEMCAD will use to display and print your reports. 

For individual text reports, you can choose to use either WordPad or Excel. By 
default, CHEMCAD uses WordPad. To switch to Excel, select Tools > Options > 
Report Viewer Settings and then check the box called Use Microsoft Excel instead of 
WordPad. Click OK to return to the main CHEMCAD workspace. 

For the consolidated report, you can use either Word or Excel. To choose a 
program to display and print this report, select Report > Consolidated Report, then 
click Report Format at the top of the Consolidated Report menu. This brings up the 
Report Format dialog box. Choose whether you want your consolidated report 
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results to appear in a Word document or an Excel workbook file, and then click OK 
to apply your change. 

Stream-based Reports 
A number of CHEMCAD reports are available to analyze stream data from a 
simulation. To access any of the following reports, select the appropriate item from 
the Report menu. The results will display in either WordPad or Excel, depending on 
how you’ve configured CHEMCAD to handle text reports. 

Note: By default, these reports will use the engineering units you selected when 
building this simulation. You can, however, use different flow rate units when 
running reports. To change flow rate units for reporting, select Report > Set Flow 
Units. In the View Flow Rate Unit dialog box, select the units you want to use and 
then click OK. The next time you run stream composition or property reports, the 
units that you’ve selected here will be the default setting; you can change the flow 
rate units again as needed. 

Stream Groups 
For stream composition and property reports, you can create custom stream groups 
within a simulation to streamline your report requests. 

For example, if you have a process that involves ten different feed streams, and 
you frequently run reports on this group of streams, you can set up a group 
consisting of just those streams. Then, whenever you want to obtain composition or 
property data for those streams, you’re just a few clicks away anytime the simulation 
is open. 

The quickest way to set up any group is to use the CHEMCAD Explorer. Follow 
these steps to create a stream group: 

1. In the CHEMCAD Explorer pane, find the top‐level item called Groups. Click 
the plus sign next to Groups to expand this item. 

 
Figure 8-01: Expanding the Groups item in CHEMCAD Explorer 

2. Now right‐click the Streams item under Groups and select New. 
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Figure 8-02: Creating a new stream group 

3. In the New Group dialog box, replace the default name (such as Group 1) 
with a descriptive name for your group, then click OK. 

 
Figure 8-03: Naming the new stream group 

4. In the Edit Stream Group dialog box, select the streams for this group, either 
by typing in the stream numbers (one per line) or by clicking on streams in 
the flowsheet. Click OK to close the dialog box. 

5. As soon as you finish creating the group, its name appears under Streams in 
the CHEMCAD Explorer. From here, you can right‐click the group name and 
select any of the following: 

• View/Edit: Open the Edit Stream Group dialog box, where you can add 
or delete stream numbers to include in the group. 

• Rename: Open the Rename Group dialog box, where you can type a new 
name for the stream group. 

• Copy: Open the Copy Group dialog box, where you can type a new 
group name to make an exact copy of the stream group. After you click 
OK, you can then edit the new copy of the group to fit your needs. 

• Delete: Remove this stream group from the simulation. If you’re sure 
about deleting the group, click Yes in the dialog box that appears. 

• Composition: Run an instant stream composition report for the streams 
in the group. 
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• Properties: Run an instant stream properties report for the streams in the 
group. 

 
Figure 8-04: Right-click menu options for custom stream group 

Note: The commands to create, edit, and remove stream groups are also offered on 
the Report menu, under both Stream Compositions and Stream Properties. 

Stream Compositions 
You can run a stream composition report based on all streams, or you can specify 
which streams to include. To run a stream composition report, select Report > 
Stream Compositions and then select from the following options: 

• Select Streams: Choose the streams you want to include in the Select Streams 
dialog box, either by typing in the stream numbers (one per line) or by 
clicking on streams in the flowsheet. Click OK to close the dialog box and 
display the report. 

• All Streams: This report displays all stream composition data for the entire 
flowsheet. 

• Feed Streams: This report displays stream composition data only for streams 
issuing from a Feed icon on the flowsheet. 

• Product Streams: This report displays stream composition data only for 
streams terminating in a Product icon on the flowsheet. 
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• Unit Streams: This report displays all inlet and outlet stream composition 
data for a specified UnitOp on the flowsheet. If no UnitOp icon is selected 
when you run the report, you’ll see the Select UnitOps dialog box; type the 
UnitOp ID or click the UnitOp on the flowsheet and then click OK to display 
the data. If you select a UnitOp icon before running the report, the data will 
display without further input. 

You can quickly display stream composition for a single stream at any time, 
simply by right‐clicking the stream in the flowsheet and selecting View 
Composition. 

Stream Properties 
Before running reports on stream properties, you’ll need to specify which properties 
to include. To do this, select Report > Stream Properties > Select Properties. This 
opens the View Property Options dialog box, where you can review which 
properties are currently selected. 

If you want to add any properties, check the appropriate boxes; to remove 
properties, click on checked boxes to clear them. If applicable, click the Crude/Solids 
tab, and make any changes to the properties on that tab. Click OK to return to the 
main CHEMCAD window. 

To run a stream properties report for the properties you’ve specified, select 
Report > Stream Properties and then select from the following options: 

• Select Streams: Choose the streams you want to include in the Select Streams 
dialog box, either by typing in the stream numbers (one per line) or by 
clicking on streams in the flowsheet. Click OK to close the dialog box and 
display the report. 

• All Streams: This report displays all stream property data for the entire 
flowsheet. 

• Feed Streams: This report displays stream property data only for streams 
issuing from a Feed icon on the flowsheet. 

• Product Streams: This report displays stream property data only for streams 
terminating in a Product icon on the flowsheet. 

• Unit Streams: This report displays all inlet and outlet stream property data 
for a specified UnitOp on the flowsheet. If no UnitOp icon is selected when 
you run the report, you’ll see the Select UnitOps dialog box; type the UnitOp 
ID or click the UnitOp on the flowsheet and then click OK to display the 
data. If you select a UnitOp icon before running the report, the data will 
display without further input. 

You can quickly display stream properties for a single stream at any time, simply 
by right‐clicking the stream in the flowsheet and selecting View Properties. 
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Particle Size Distribution 
For a particle size distribution report, select Report > Particle Size Distribution. In 
the Select Streams dialog box, choose one or more streams for which a particle size 
distribution exists (one per line), either by typing in stream numbers (one per line) or 
by clicking on streams in the flowsheet. Click OK to display the report. 

Pseudocomponent Curves 
For a text report on pseudocomponent curves (also known as distillation curves), 
select Report > Pseudocomponent Curves. Select one or more streams containing 
hydrocarbons, either by typing in stream numbers (one per line) or by clicking on 
streams in the flowsheet. Click OK to display the report. 

UnitOp-based Reports 
CHEMCAD can also run reports to analyze UnitOp data. To access these reports, 
select the appropriate item from the Report menu. The results will display in either 
WordPad or Excel, depending on how you’ve configured CHEMCAD to handle text 
reports. 

UnitOp Groups 
For the UnitOps report, you can create custom UnitOp groups within a simulation. 
Much like their stream‐based counterparts, UnitOp groups can save you time and 
effort when requesting reports; in addition, you can use these groups when running 
your simulation, to isolate and run only selected UnitOps for diagnostic or other 
reasons. 

Note: Because of this other functionality of UnitOp groups, the order in which you 
list UnitOp IDs when setting up these groups is important. 

The quickest way to set up any group is to use the CHEMCAD Explorer. Follow 
these steps to create a UnitOp group: 

1. In the CHEMCAD Explorer pane, under Groups, right‐click the UnitOps 
item and select New. 

2. In the New Group dialog box, replace the default name (such as Group 1) 
with a descriptive name for your UnitOp group and then click OK. 

 
Figure 8-05: Naming the new UnitOp group 

3. In the Edit UnitOp Sequence Group dialog box, select the UnitOps for this 
group, either by typing in the UnitOp IDs (one per line) or by clicking on 
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UnitOp icons in the flowsheet. Add UnitOps in the order they run in the 
simulation. Click OK to close the dialog box. 

As soon as you finish creating the group, its name appears under UnitOps in the 
CHEMCAD Explorer. From here, you can right‐click the group name and select any 
of the following: 

• View/Edit: Open the Edit UnitOp Sequence Group dialog box, where you 
can add or delete Unit Ops or reorder the existing list. 

• Rename: Open the Rename Group dialog box, where you can type a new 
name for the group. 

• Copy: Open the Copy Group dialog box, where you can type a new group 
name to make an exact copy of the UnitOp group. After you click OK, you 
can then edit the new copy of the group to fit your needs. 

• Delete: Remove this UnitOp group from the simulation. If you’re sure about 
deleting the group, click Yes in the dialog box that appears. 

• Run: Run the simulation only for those UnitOps included in this group. 

• View: Display a summary report of the UnitOps included in this group. 

• Specifications: Bring up the UnitOp specification dialog boxes for each item 
in the UnitOp group, starting with the first UnitOp listed. 

Note: The commands to add, edit, and remove UnitOp groups are also offered on the 
Report menu under UnitOps. 

Select UnitOps 
To run a report that covers just the Unit Ops you specify, select Report > UnitOps > 
Select UnitOps. In the Select UnitOps dialog box, specify the UnitOps you want to 
include in the report, either by typing in the UnitOp ID s(one per line) or by clicking 
on UnitOps in the flowsheet. Click OK to close the dialog box and display the report. 

If you select a UnitOp icon before running the report, the data will display 
without further input. 

Spec Sheet 
This command exports detailed information about a UnitOp into a preformatted 
Excel worksheet. This report is useful for tasks such as soliciting a manufacturing 
quote for a piece of equipment. 

• To create a spec sheet for all UnitOps on the flowsheet, select Report > Spec 
Sheet > All Units. 

• To create a spec sheet only for specific UnitOps, select Report > Spec Sheet > 
Select Unit. Choose the UnitOps you want to include in the Select UnitOps 
dialog box, either by typing in the UnitOp IDs (one per line) or by clicking on 
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UnitOp icons in the flowsheet. Click OK to close the dialog box and display 
the spec sheet. 

• For a single UnitOp spec sheet, you can select the UnitOp icon before 
running the report; Excel will open and the data will display without further 
input. 

Note: For spec sheets that include multiple UnitOps, CHEMCAD creates a separate 
worksheet for each UnitOp’s data within the Excel file that CHEMCAD creates. 

Distillation 
To run a distillation report, select Report > Distillation and then select one of the 
following: 

• Tower Profiles: Generates a report detailing temperature, pressure, and flow 
rate for a distillation column 

• Tray Compositions: Creates a report that shows the vapor flow rate, liquid 
flow rate, and K‐value of each component on each stage of a distillation 
column 

• Tray Properties: Reports on currently selected stream properties for each 
stage of a distillation column 

• Tower Mass Transfer: For an SCDS distillation column that uses a mass 
transfer model, provides mass transfer coefficients, height of transfer units, 
and estimated height of theoretical plates (HETP) 

• Dynamic Column History: Provides data from a single dynamic run of a 
column (described in detail in Chapter 7, Building and Using a Dynamic 
Simulation) 

• Column Diagnosis: For columns that have not successfully converged, 
provides recommendations for changing column settings to achieve 
convergence 

Flowsheet-based Reports 
In addition to reports that focus on particular UnitOps and streams, CHEMCAD 
offers text reports that provide information about the simulation as a whole. To 
access any of these reports, select the appropriate item from the Report menu. 

Topology 
This report provides a listing of all UnitOps in the flowsheet, as well as all stream 
origins and destinations. 

Thermodynamics 
This report lists all components used in the simulation and provides vital 
information about the thermodynamics methods used. 
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Mass and Energy Balances 
In addition to mass and energy balances, this report gives the order in which 
UnitOps are calculated, calculation modes used, and information about recycle 
loops, cut streams, and convergence. 

Dynamics Reports 
The Report menu provides access to the Batch Results and Dynamics commands, 
which provide reports about non‐steady‐stream processes. 

Batch Results 
This report summarizes the results of a batch distillation column simulation at the 
end of each operating step. 

Dynamics 
You can access three different reports by selecting Report > Dynamics: Dynamic 
Column History, Dynamic Stream History, and Dynamic UnitOp History. These 
reports are described in detail in Chapter 7, Building and Using a Dynamic Simulation. 

Consolidated Report 
You can run any combination of the text‐based reports described above as a single 
operation, by selecting Report > Consolidated Report. This brings up the 
Consolidated Report menu. 

 
Figure 8-06: The Consolidated Report menu 

From this menu, you can specify streams, UnitOps, and stream properties to 
include; choose flow, composition, and distillation options; and select settings for 
heat curves and batch and dynamic options. 

To optimize your consolidated simulation report, begin at Select Streams and 
click each button in turn, customizing each dialog box with your own settings and 
clicking OK to apply your changes. When you have worked your way down the 
menu and set all of the options to suit your reporting needs, click Calculate and 
Give Results. 
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Graphical Reports 
In addition to text‐based reports, CHEMCAD offers a wide variety of graphical plots 
that you can view onscreen or print for review. 

Thermophysical Data Graphs 
CHEMCAD offers a number of graphical reports that relate specifically to the 
selected components and thermodynamics options. To access any of these plots, 
select the appropriate item from the Plot menu. 

TPXY 
This selection generates vapor‐liquid equilibrium curves between any two 
components, with an optional third component. You can include TPXY, TXY, activity 
coefficient, and fugacity coefficient curves. 

Binary LLE 
This selection generates liquid‐liquid equilibrium curves between any two 
components. 

Binodal Plot 
This selection generates a ternary phase diagram showing the distribution of three 
selected components in two liquid phases, including tie lines and plait point. 

Binodal/Residue Curves 
This selection creates a plot that combines the curves from a binodal plot and a 
residue curve plot. This is useful when working with heterogeneous azeotropic 
distillation. 

Residue Curves 
This selection generates and plots a graphical display of distillation zones, 
azeotropes, and residue curves associated with a user‐specified ternary mixture. 

Flowsheet-based Graphs 
To view graphical reports that reflect your overall simulation, select one of the 
following from the Plot menu: 

• Stream Properties: Plots one selected stream property for a selected stream in 
the flowsheet 

• Phase Envelopes: Plots a phase envelope for a given stream, highlighting the 
critical point of the mixture; can include plots at vapor fractions other than 0 
(bubble point curve) and 1 (dewpoint curve) 

• Composite Curves: Plots composite heat curves for the entire flowsheet, as 
well as optional heat curves for individual UnitOps 
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• Pseudocomponent Curves: Displays a plot of one or more distillation curves 
for a stream 

UnitOp-based Plots 
CHEMCAD offers several plots that display data for a single UnitOp. To access any 
of these plots, select Plot > UnitOp Plots and then select one of the following 
options. 

Tower Profiles 
This selection plots compositions, temperature, and flow profiles for distillation 
columns. 

Heat Curves 
This selection plots heating and cooling curves for a selected heat exchanger. 

Plug Flow Reactor Profile 
This selection plots the temperature or composition profiles along the axial length of 
a kinetic plug flow reactor. 

Pipe Profile 
This selection plots fluid properties for pipe UnitOps along the axial length of the 
pipe. This plot requires that the pipe contain multiple segments. 

Controller Convergence 
For controllers that have not converged, this plot enables you to diagnose the 
controller behavior that is preventing convergence. The plot shows how the 
controller error function changes with iteration. 

Dynamic Plots 
CHEMCAD offers a series of plots for use with dynamic operations. Select Plot > 
Dynamic Plots to access any of six graphical dynamics reports. 

These plots are described in detail in Chapter 7, Building and Using a Dynamic 
Simulation. 

User-specified File 
If you have customized CHEMCAD using VBA, C++, or other programming 
languages, you can save plot data into a text file and use this feature to display that 
data as a curve. 

Select Plot > User Specified File to bring up a message box that provides 
instructions on how to format the text file. Click OK to continue to an Open dialog 
box, where you can select the text file you want to use. When you click Open, the 
curve is plotted and displayed. 
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Printing CHEMCAD Reports 
You can print any text report that you produce using CHEMCAD, from within the 
program that you have selected to view the report. 

The specific printing options differ somewhat from one program to another, but 
you can bring up the main Print dialog box in Word, WordPad, or Excel by selecting 
File > Print. Each of these programs also offers a Print button on the toolbar for your 
convenience. 

For graphical reports, you can print directly from CHEMCAD. With a plot 
displayed, select File > Print, or click the Print button on the toolbar. Plots are set up 
to print in landscape (horizontal) orientation, as this is the best fit for the horizontal 
plot layout. 

Process Flow Diagrams 
CHEMCAD provides easy‐to‐use tools for creating printed process flow diagrams. 
You can add various types of databoxes to accompany your flowsheet, and then 
selectively view and print groups of items, including databoxes. 

Flowsheet Databoxes 
CHEMCAD offers four types of databoxes: 

• Stream Box: Lists the streams that you select in a single table, along with the 
stream properties that you choose to include 

• UnitOp Box: Generates a separate databox for each selected UnitOp 

• TP Box: Generates separate summary databoxes for selected streams 

• Excel Range Box: References a range of cells from an Excel worksheet 

Stream Boxes 
To create a stream databox, start by selecting Format > Add Stream Box. From the 
Select Streams dialog box, follow these steps: 

1. Determine which streams to include in the databox, using one of three 
methods: 

• Check the All streams box to include all streams on your flowsheet, then 
click OK. 

• Type the numbers of the streams you want to include into the boxes 
provided, then click OK. 

• Check the Select streams from flowsheet box, click OK, and then choose the 
streams you want to include by clicking the actual stream lines with your 
primary mouse button. Stream numbers that you select will appear in the 
Select Streams dialog box; to toggle a selected stream off, just click it 
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again. When you’ve selected all the streams you want, click OK to 
continue. 

2. Any of these selection methods will bring you to the Databox Property 
Options dialog box. Here, you can select which stream properties you want 
to include on the stream databox. You can keep the default settings, or turn 
any check box on or off to customize your databox. 

Note: The selections you make here will be the default selections the next time you 
create a stream databox for this simulation. 

In addition to the main General tab, note the Crude/Solid tab, which you can 
click to select crude oil stream properties or solid stream properties. When 
you’ve selected the stream properties you want, click OK to continue. 

3. In the Databox Settings dialog box, you can choose the font style and size for 
your databox text, as well as whether to include horizontal lines or horizontal 
section dividers in the databox. Click OK to place the databox on your 
workspace. 

As with flowsheet elements, you can move, stretch, or resize a databox using 
your mouse. 

UnitOp Boxes 
The procedure for creating UnitOp databoxes is similar to that used to create stream 
databoxes, with the chief difference being that there is no selection of UnitOp 
properties. 

Begin by selecting Format > Add UnitOp Box, and then either enter UnitOp IDs 
or check the box to select UnitOps from the flowsheet. Note that you don’t have the 
option of automatically including all UnitOps, as you did with streams. 

When you complete your selections and click OK, the Databox Settings dialog 
box appears, with the same formatting options that are available for stream 
databoxes. Change any settings you want here, and then click OK to place the 
requested databoxes on your workspace. 

Unlike a stream databox, which displays data for multiple items in a single box, a 
UnitOp databox displays data only for a single UnitOp. If you selected three 
UnitOps in the UnitOp IDs dialog box, you’ll see three separate databoxes appear 
when you click OK. If you see only one databox at first, try moving that box to 
another part of the screen to see if the others are hidden behind it. 

TP Boxes 
CHEMCAD can create databoxes, called TP boxes, which display any combination of 
temperature, pressure, and flow rate for all streams or selected streams on a 
flowsheet. 
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To add TP databoxes, select Format > Add TP Box. In the TP Box Settings dialog 
box, first select an option at the top, to determine whether to add TP boxes for all 
streams or only for the streams you select. 

In the Display column, select items from the drop‐down list in each field to 
determine which stream properties to display and in what order. Use No selection 
as appropriate if you want to display fewer than four properties. 

In the Number format column, make a selection in each field to determine how 
numbers will display in the TP boxes. In the Digits column, type the number of 
digits to display after the decimal point. You can also change the font style and size 
for the TP box text, and choose whether to display stream IDs and engineering units. 

The Preview box displays a dynamic sample of how the items you’ve selected 
will appear in the TP boxes. Note that the preview area does not reflect changes you 
make to the font size. 

When you finish making your selections in the TP Box Settings dialog box, click 
OK. If you’ve chosen to make TP boxes for all streams, the TP boxes will appear on 
the flowsheet right away. If you’ve opted to select the streams from the flowsheet, 
you’ll see a Select Streams dialog box; type the stream numbers (one per line) or click 
on the stream lines in the flowsheet to select streams, and then click OK to create the 
TP boxes. 

 
Figure 8-07: TP boxes added to a simple flowsheet 

Excel Range Boxes 
An Excel range box displays dynamic data from a specified cell range in a specified 
Excel worksheet. To create an Excel range box, follow these steps: 

1. Start by selecting Format > Add Excel Range. This brings up the Excel 
Databox Settings dialog box. 

2. Click Browse to navigate to the folder where the Excel workbook resides, 
then highlight the name of the workbook you want and click Open. 
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3. In the Worksheet name field, type the name of the relevant worksheet within 
the workbook that you’ve indicated. 

4. In the center portion of the dialog box, specify the starting and ending 
column and row coordinates that you want to reference within the selected 
worksheet. 

5. In the lower portion of the dialog box, change any formatting settings as 
desired and then click OK to create the databox. 

An Excel range box is a dynamic link between CHEMCAD and the Excel 
worksheet. As data is updated and saved in the selected cell range, the range box can 
automatically update to reflect those changes. To view the most up‐to‐date data in 
your Excel range boxes at any time, select View > Refresh Data Boxes.  

Using the Layers Feature for Selective Viewing and Printing 
When you create a simulation in CHEMCAD, you can build your flowsheet across a 
huge workspace, zooming in and out as needed to work with specific areas of the 
flowsheet. You can also, as described above, add any number of databoxes to 
provide a quick visual reference for the data behind your flowsheet objects. You can 
add text labels, draw circles around items that you need to work on further—in 
short, there’s practically no end to the visual clutter that could end up on your 
process flow diagram. But all of these elements are useful to someone, and you 
certainly don’t want to spend your time repeatedly adding or removing visual 
elements before printing or sharing a PFD. 

CHEMCAD’s solution to visual‐element overload is a feature called Layers. A 
layer is a group of objects in a simulation file—any combination of databoxes, drawn 
shapes, text labels, streams, and UnitOps—that you can view or hide with a single 
click. You define exactly which objects belong to a layer, and then toggle each layer 
either on (visible) or off (hidden) using the CHEMCAD Explorer. 

Note: Turning off a layer does nothing beyond hiding the associated objects from 
view. Having a layer hidden—even if that layer includes streams and UnitOps—
does not in any way affect the way the simulation runs or any stream or UnitOp 
properties. 

Scenarios for Using Layers 
The following are examples of situations in which you can use layers to enhance 
your process flow diagrams: 

• Several different departments need to review your process flow diagram, but 
each department wants to see different data highlighted in databoxes. You 
can create one set of TP boxes listing only flow rates, for example, and then 
assign them all to a layer; then hide that layer and create a new set of TP 
boxes listing temperature and pressure only. Assign these databoxes to their 
own layer, hide it, and continue with stream boxes, UnitOp boxes, or 
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whatever other items you need. Create as many different layers as you like, 
and each time you go to print the diagram, view only the layers that you 
want to print. 

• You need to e‐mail a simulation to different recipients who want to view 
different databoxes. Create sets of databoxes assigned to multiple layers, and 
then view just the layers that you want your first recipient to see upon 
opening the file. Save and close the simulation before attaching it to an e‐mail 
message. Open the simulation again for the next recipient, select the layers 
you want that person to see, save the file, and attach it to another e‐mail 
message.  

• You have a very large flowsheet that encompasses a number of discrete 
processes. You can create separate layers for various portions of the overall 
flowsheet, and view only the portions you’re working with at a given time. 
You can also hide unneeded portions of the flowsheet for printing. 

• If you are troubleshooting a process, or for whatever reason need to “mark 
up” a process flow diagram, you can draw shapes such as ellipses or 
rectangles around certain UnitOps or groups of UnitOps, using text or bright 
colors to draw extra attention. Then assign all of these mark‐up items to a 
single layer so that you can choose to view either the marked‐up version or 
the “clean” version of the flowsheet at any time. 

Creating a New layer 
By default, all objects are assigned to a master layer, which is always visible. Before 
you can assign objects to another layer, you must first create a new layer to use. The 
most convenient way to create a layer is within the CHEMCAD Explorer pane. 

In the CHEMCAD Explorer, find the top‐level item called Layers, right‐click it, 
and select New. 

 
Figure 8-08: Creating a new layer 

In the New Layer dialog box, replace the default layer name with a descriptive 
name of your own and then click OK. 
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Figure 8-09: Naming the new layer 

The new layer now appears under the Layers item in CHEMCAD Explorer. If 
necessary, click the plus sign next to Layers to view the layer name. You can add as 
many layers as you like and view the complete list here. 

When a layer is first created, it is visible by default. A layer’s status as visible or 
hidden is indicated in CHEMCAD Explorer by the icon that displays next to its 
name. A visible layer shows a green check mark, while a hidden layer is gray in 
color. 

 
Figure 8-10: Visible and hidden layers as they appear in CHEMCAD Explorer 

Assigning Objects to a Layer 
Now that you have layers, you can assign items to them. Start by clicking an object 
to highlight it; this might be anything from a stream ID label to a UnitOp to a TP 
box. Whatever type of object it is, when you highlight it you’ll see the four black 
boxes that define its outer edges. With the object selected, right‐click the name of the 
desired layer in the CHEMCAD Explorer and choose Add Selected. 

To save time, you can add multiple objects to a layer at once. Just hold down the 
[SHIFT] key as you click each object in turn, then right‐click the layer name and 
choose Add Selected. 

Note: If you like, you can assign one or more objects to a layer at the same time you 
create the layer. To do this, simply click the desired object (use the [SHIFT]‐click 
method for multiple objects), then right‐click Layers, select New, and assign the 
layer a name. The selected objects are automatically assigned to the new layer. 
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Hiding and Viewing Layers 
As soon as you’ve added at least one object to a layer, you can test the layer by 
hiding it and watching what happens. To hide a layer, simply click the green check‐
marked icon next to that layer’s name; the icon should change to gray and all items 
assigned to the layer should disappear from view. 

At any time, you can hide or view each layer in your simulation independently. 
The icons next to the layer names in the CHEMCAD Explorer provide a constant 
reminder of which layers, if any, are currently hidden from view. 

Each time you open a simulation file, CHEMCAD displays or hides its layers 
according to the way they were set the last time you saved the simulation. 

Note: It is possible for an object to be assigned to more than one layer. If an object is 
assigned to two or more layers, however, it will be displayed unless all of its 
associated layers are hidden. 

Removing an Object from a Layer 
If you no longer want a specific object or group of objects to be assigned to a given 
layer, you can remove the assignment as easily as you created it. 

First ensure that the layer in question is visible. Then select all the objects that 
you want to remove from the layer, right‐click the layer name in CHEMCAD 
Explorer, and choose Remove Selected. Now when you hide the layer, the object or 
objects you removed should remain in view. 

Deleting an Entire Layer 
If for any reason you want to remove a layer from your list, simply right‐click the 
layer’s name in CHEMCAD Explorer and select Delete. The layer disappears from 
the list, and if the layer was hidden when you deleted it, the items assigned to it now 
reappear. 

Printing a Process Flow Diagram 
When you use the Print command on the main CHEMCAD screen, the result is a 
verbatim reproduction of your visible workspace. 

If you’re zoomed close in to one portion of your flowsheet when you print, you’ll 
get a close‐up printout that does not include the rest of the flowsheet. If you’ve 
hidden all of your databoxes to keep them out of your way while you fix a problem, 
those databoxes will not appear on the printout. If the Palette pane is covering up the 
product streams coming from one of your UnitOps, those product streams won’t be 
on the printout either. 

For this reason, the first thing you should do when you’re ready to print a 
process flow diagram is to decide what needs to be included on the printout. If you 
need the entire flowsheet to appear on the printed diagram, select View > Zoom 
Options > Zoom to Fit, or zoom manually if you prefer. You may want to hide or 
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unpin one or more panes as well, to give yourself more workspace while you 
prepare to print. 

Next, consider whether your process flow diagram should display a job box, 
UnitOp or stream databoxes, text notes, or other items in addition to the flowsheet 
itself. If you have already created the needed items, make sure that they are 
currently visible and placed where you want them. 

When all of the items you want to print are visible, check once more to ensure 
that everything falls within the CHEMCAD workspace. Then select File > Print, or 
click the Print button on the toolbar. This brings up the Print Setup dialog box, 
where you can select printing options or simply click OK to print the process flow 
diagram. 
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Chapter 9 

Customizing CHEMCAD 

As you become more familiar with the way that CHEMCAD works and the various 
options and tools that are available, you may find yourself wishing that you could 
make your own additions—either for specialized items or for those you use 
frequently. You can in fact customize CHEMCAD in several ways that save you time 
by streamlining and simplifying your workflow. These include: 

• Creating stream and UnitOp templates 

• Adding custom components to CHEMCAD’s component database 

• Making your own symbols and adding them to the UnitOps palette 

• Building custom UnitOps 

• Creating custom dialog boxes for UnitOp settings  

• Defining custom thermophysical rules 

This chapter discusses all of these types of customization, starting with the 
simplest procedures and then moving on to more complex customizations that 
require some programming experience. 

Flowsheet Templates 
One of the most effective ways to save time when creating CHEMCAD simulations 
is to make use of stream and UnitOp templates. A template is simply a set of 
characteristics, which you assign a name and save for later use. When you set up 
stream or UnitOp specifications that you know you’ll need to recreate in the future, 
you can create a template of that stream or UnitOp. You can then duplicate that item 
within the same simulation—or in any other simulation—with just a few mouse 
clicks. 
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Creating a Template 
To create a stream template, first create the stream you want to clone and give it all 
of the characteristics you want to include in the template. 

Then find this stream on the CHEMCAD Explorer’s Simulation tab. Expand the 
Flowsheet item, then expand the Stream item, and finally double‐click the 
applicable stream ID. This brings up an item called Save. Double‐click the word 
Save to bring up the Enter Template Name dialog box, then type a name for your 
new stream template and click OK. The new stream name is now listed beneath the 
Save item. 

To create a UnitOp template, select the appropriate UnitOp ID in CHEMCAD 
Explorer, and then follow the same procedure used to create a stream template. 

Viewing a Template’s Properties 
To see what specifications an existing template includes, look it up in the 
CHEMCAD Explorer. Expand the Templates item, then expand the UnitOps item, 
and finally expand the name of the relevant UnitOp type. For example, if you’re 
looking up a template that you created for a type of pump that you frequently use, 
expand the Pump item in the CHEMCAD Explorer. 

When you find your template, simply click the template name to open its 
specifications dialog box. 

Applying a Template 
To apply a stream template, first expand the CHEMCAD Explorer item for the 
stream in question, either by clicking the plus sign to its left or by double‐clicking the 
stream name. 

When the stream item is expanded, you’ll see the Save item below it, followed by 
the names of all the stream templates that you have created. Double‐click the name 
of the template you want to use, then click OK to confirm that you want to apply 
this stream template. 

Renaming or Deleting a Template 
To rename a template, simply find it under Templates in CHEMCAD Explorer, 
right‐click the template name, and select Rename. Type the new name and click OK. 
This changes the template name throughout CHEMCAD Explorer. 

The procedure for deleting a template is similar to renaming a template. Again, 
find the template you want under Templates, right‐click its name, and select Delete. 
Click OK to confirm that you want to delete this template. The template name 
disappears from CHEMCAD Explorer, but streams or UnitOps that were specified 
using the template are not affected in any way. 
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Note: Any stream or UnitOp template that you create is available for use with all 
other simulations on the same installation of CHEMCAD, until and unless you 
delete the template. 

Creating Custom Components 
The CHEMCAD component database places detailed information about thousands 
of chemicals at your fingertips. If for any reason you find that you need to use a 
chemical component that does not match any item currently in the CHEMCAD 
database, you can create your own component for use with your simulations. 

You can create a single component, define a range of pseudocomponents, or 
import a component’s physical properties from an external source. These procedures 
have similar aims, but differ significantly from one another. 

Adding a Single Component 
Creating a pure component in the CHEMCAD component database is a two‐part 
task. You must first create the component and then regress data into the component. 

Creating the Component 
To create a new custom component, you can use any of five different estimation 
methods: 

• Create a hydrocarbon pseudocomponent. This is treated like a pure 
component in that certain aspects of how it behaves or reacts are known. 

• Use the Joback/Lyderson method. With this method you indicate basic 
characteristics, and select molecular groups (known as Joback groups, called 
Group Assignments in CHEMCAD) from a list, to indicate how many of each 
molecular group are present in the component. 

• Use the UNIFAC method. This method is identical to Joback/Lyderson, 
except that the group list is more specialized toward organic components. 

• Create a combustion solid. This method is used to simulate solid 
components for which an elemental analysis and heating value are known, 
e.g., coal. 

• Create an electrolyte component. This method creates a component that you 
can subsequently use in an electrolyte simulation. 

The procedure for creating a pure component is as follows: 

1. Select Thermophysical > Component Database > Create New Component. 
This brings up the New Component dialog box. 
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Figure 9-01: The New Component dialog box 

2. Give the new component a descriptive name; it is strongly recommended that 
you make this name unique. All other characteristics here are optional, except 
for normal boiling point, which is required for the pseudocomponent 
method. 

3. Select a Correlation option to indicate which of the above methods you will 
use, and click OK to continue. 

4. In the resulting dialog box, select the appropriate options for your new 
component and specify as many characteristics as you like, as accurately as 
possible. Click OK to continue. 

5. In the Select Destination Database dialog box, you will see no databases listed 
if this is your first time to add a component. If this is the case, click New to 
bring up the Manage Component Databases dialog box. 

6. Normally, you’ll need to click Add New, which brings up the Save As dialog 
box. Navigate to the location you want for your custom component database, 
give the database a name, and click Save. If you want to add a database that 
someone else has created (generally in a network location), you can click Use 
Existing, which brings up an Open dialog box; navigate to that database’s 
location, highlight the database, and click Open. 

7. The Manage Component Databases dialog box now lists the database that 
you created or selected. Click OK to continue. 

8. In the Select Destination Database dialog box, the new database you have just 
named is now listed; highlight it and click OK. 

9. The View/Edit Component Data menu now appears. Click any item on the 
menu to access a dialog box with options for defining your new component. 
After defining as many characteristics as possible, click Exit to close the 
menu. 
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The new component is now available to add to your current simulation and all 
future simulations. To return at any time to make changes to a user‐defined 
component, do one of the following: 

• Select Thermophysical > Component Database > View/Edit Component to 
bring up the Select Single Component dialog box, which lists all available 
components. Highlight the component you want in the list and click OK to 
bring up the View/Edit Component Data menu. 

• Click Component List on the toolbar to bring up the list of components in the 
current simulation. Double‐click the component you want in the list to bring 
up the View/Edit Component Data menu. 

Regressing Data into the Component 
Data regression is the process of fitting experimental data points to a polynomial 
equation form, so that the individual error of each data point is minimized. 

Data regression is only relevant to temperature‐dependent properties such as 
heat capacity, density, and vapor pressure. CHEMCAD uses these polynomial 
equation fits to calculate the properties of a component at any given temperature. 

To regress data into a component that you have created, follow these steps: 

1. Select Thermophysical > Component Database > Component Property 
Regression. This brings up the Regress Component Properties menu. 

 
Figure 9-02: The Regress Component Properties menu 

2. Click the menu item that corresponds to the type of regression data you want 
to enter. 

3. In the Select Single Component dialog box, select the user‐added component 
that you want to regress and click OK. 

4. In the resulting dialog box, enter the required parameters (listed in green 
text) and any other parameters as appropriate, then click OK. 
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5. In the resulting dialog box, enter your experimental data points in the cells 
provided. You can enter a value in the Weight_factor column to weight the 
regression toward one or more data points. Click OK to continue. 

Note: You can paste a contiguous range of cells from an Excel worksheet into the 
cells in this dialog box. 

6. The regression data is displayed in a tabular format for review. When you are 
ready to view the regression curve, close the WordPad or Excel window. 

7. The regression results now display in graphical format. Review the plot and 
decide whether the regression adequately represents your experimental data. 
In the Apply Component Changes dialog box, either choose an option and 
click Save or abandon your regression changes by clicking Don’t Save. 

8. Repeat this procedure as needed to regress other properties for your 
component, and then click Exit to close the Regress Component Properties 
menu. 

Pseudocomponent Range 
Using a pseudocomponent curve—another term for the distillation curve portion of an 
assay—you can cut a hydrocarbon stream into pseudocomponents, or fractions. A 
pseudocomponent represents a group of components that boil within a narrow 
temperature range. Pseudocomponent ranges are used in CHEMCAD to model 
hydrocarbons. 

When you define a pseudocomponent range for a stream, CHEMCAD creates 
entries in the component database for each hydrocarbon cut, and assigns these 
components’ compositions to the stream. 

Note: Before you define a pseudocomponent range, make sure that you have 
specified in your component list, as appropriate, water and any light ends that exist 
in the assay. 

1. Select Thermophysical > Pseudocomponent Curves. 

2. In the Dist Curve Characterization dialog box, enter stream number(s) and 
click OK. 

3. In the Hydrocarbon Correlation dialog box, select the appropriate 
correlations for your curve, or use the default selections and click OK. 

4. This brings up the Curve Temperature Cut Ranges dialog box. For each cut 
range that you want to define, provide a beginning and ending temperature, 
and enter the number of points that you want to define as discrete 
pseudocomponents within that range. Click OK to continue. 
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5. In the Bulk Properties dialog box, specify a distillation curve type and enter a 
total flow rate and bulk gravity for the stream. You can make other entries 
here as needed, but only these three items are required. Click OK to continue. 

6. In the resulting dialog box, enter the distillation curve from your assay, 
specifying the volume percentage and boiling temperature for at least five 
data points. Click OK to continue. 

7. The next dialog box is optional. Enter a gravity curve from your assay, 
specifying the volume percentage and gravity for at least five data points. 
Click OK to continue. 

8. The next dialog box is also optional. If you have light ends and water defined 
in your assay, enter volume percentage data here for all relevant components. 
Click OK to continue. 

9. This brings up the Edit Distillation Curves menu, shown in Figure 9‐03. 

 
Figure 9-03: The Edit Distillation Curves menu 

10. Click Save and Exit. This brings up a tabular listing of pseudocomponent 
properties. You can review and print these results if you like, or simply close 
the document displaying them to return to the CHEMCAD workspace. 

11. To see the list of pseudocomponents that you have created, edit the 
properties for the stream you selected. The pseudocomponents will be listed 
after pure components, with names that begin with NBP. 

Importing a Neutral File 
You can also add a component to the database by importing its physical properties 
from an external data source. This procedure is known as neutral file import. 

For detailed information about importing and using a neutral file, see the 
CHEMCAD Help system. 
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Creating a Custom Symbol 
You can create a custom symbol in CHEMCAD, for use with either a built‐in UnitOp 
or a user‐defined UnitOp. The tool used to create symbols is called the CHEMCAD 
Symbol Editor. 

You can launch the Symbol Editor in either of two ways: 

• Within CHEMCAD, select Edit > Edit UnitOp Symbols. 

• From Windows, select Start > All Programs > Chemstations > Utilities > 
Symbol Editor. 

Once the editor is open, you’ll see a gridded workspace and a small, free‐floating 
tool palette. 

 
Figure 9-04: The Symbol Editor’s workspace and palette 

You can build a symbol from the ground up, but the best way to learn to use this 
tool is to edit an existing CHEMCAD UnitOp symbol. To do that, follow these steps: 

1. Select File > Open from the Symbol Editor menu. In the Open dialog box, 
select a file from Symbols directory and click Open. The selected symbol 
opens in the Symbol Editor workspace, as shown in Figure 9‐05. 
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Figure 9-05: The pump_1.sym file open in the Symbol Editor workspace 

2. Select File > Save As and save the file in a different directory, using a 
distinctive name to avoid confusion with the original symbol. 

3. Use the tools available in Symbol Editor to change the symbol as needed: 

• To remove or alter any existing part of the symbol, select Structure > 
Ungroup to break the symbol into its individual components. 

• To add graphical components to the symbol, use the drawing tools on the 
tool palette, such as Rectangle and Ellipse. 

• To add a text label to the symbol, use the Text tool. 

• To add an inlet or outlet, click the appropriate item on the tool palette 
and then click to place the inlet or outlet on the symbol. 

• To back out of a change that you’ve made, select Edit > Undo or press 
[CTRL‐Z]. 

4. When you’re ready to save the symbol, make sure that you have deleted any 
unwanted items on the workspace. Select Edit > Select All or press [CTRL‐A], 
and then select Structure > Group. 

5. Select File > Save to save the changes to your new symbol. 

To create a totally new symbol, simply start from a blank workspace, name the 
file, and use the various drawing tools to create the desired combination of shapes 
and text. Add inlets and outlets as needed, then group the symbol’s components and 
save the file. 

Once you’ve created your new symbol, you need to associate it with a UnitOp 
type and then add it into the appropriate UnitOp subpalette. 

1. Within the Symbol Editor program, select File > Edit UnitOp Type. The 
Select Unit Operation Type dialog box appears. 
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Figure 9-06: The Select Unit Operation Type dialog box 

2. Select the appropriate UnitOp type and click OK. 

3. To assign the new symbol to a UnitOp palette, select File > Add to 
CHEMCAD Palette. 

4. Close and restart CHEMCAD to see your new symbol appear on the 
specified subpalette. 

Customized Costing Calculations 
CHEMCAD includes some very basic costing routines to help determine the capital 
cost of equipment. Using a simplified form of C known as the Parser language, you 
may modify these routines to better suit your needs. 

Costing calculations are defined by a programming language called Parser, the 
syntax for which is documented in the CHEMCAD Calculator/Parser Module guide, 
available on the Chemstations web site. 

Creating Custom UnitOps 
If you need a UnitOp that falls outside the range of options offered on the All 
UnitOps palette, you can create a custom UnitOp.  The goal of creating a custom 
UnitOp is to have a unit where you can enter your own equations to calculate heat 
and mass balances. Over the years, CHEMCAD users have created custom UnitOps 
for purposes as diverse as membrane separation units, fuel cells, specialized solids 
handling units, and crystallizers for the separation of xylenes. 

Four items on the All UnitOps palette are dedicated to user‐defined UnitOps. 
You can create a custom UnitOp using any of the following four ways: 

• Excel UnitOp: Created through a combination of the COM interface and the Data 
Map interface 

• Calculator: Created using an inline C program 

• User‐added module: Created using Visual Studio or another C++ compiler 

• VBA UnitOp: Created through the VBA Editor, which is part of CHEMCAD 

The basic procedures for creating custom Excel UnitOps are covered in Chapter 
10, Data Interfaces. Calculator UnitOps are defined by a programming language 
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called Parser, the syntax for which is documented in the CHEMCAD Calculator/Parser 
Module guide, available on the Chemstations web site. 

C++ user‐added modules are developed using Microsoft’s Visual C++ 
development tool, the same tools that were used in the creation of CHEMCAD’s own 
UnitOps. The procedures for creating C++ user‐added modules for use with 
CHEMCAD are detailed in the User‐added Modules Guide, which is also available on 
the Chemstations web site. 

VBA UnitOps are defined by VBA subroutines, and are described later in this 
chapter. 

The method you choose is an important first step toward creating a UnitOp, but 
the choice is almost entirely up to you. Calculator UnitOps can be quick and easy to 
set up, but they can’t do everything the other methods can. The Excel/Visual Basic 
approach is very powerful and uses the familiar Visual Basic language for 
development. A drawback to this method is that calculation can sometimes be slow 
due to the use of Microsoft Excel to do the calculations. The most powerful and 
fastest calculating method is the C++ user‐added module method, but if you are new 
to C++, it may be challenging to use. VBA UnitOps are as powerful as those created 
using C++, and are much easier to build. 

Whichever method you use to program the calculations of your UnitOp, you will 
likely need to create a dialog box to provide a user interface. A dialog box enables 
users to send information into your UnitOp, for example the number of stages for a 
distillation UnitOp. No matter what method you use to program your UnitOp, you 
will use the Dialog Editor program to create the user interface. 

Creating a Custom UnitOp Dialog Box 
CHEMCAD uses dialog boxes to set variables for all types of UnitOps. Using the 
Dialog Editor program, you can create a custom dialog box for use with any type of 
user‐added units. 

You can also edit an existing UnitOp’s specification dialog box—for example to 
add text notes, to translate from English to another language, or to limit the UnitOp’s 
functionality—although this is not commonly done. 

The Dialog Editor program enables you to create and modify dialog boxes, 
which are controlled by files with the .MY extension. These files, along with .MAP 
files and .LAB files, define dialog boxes for use in CHEMCAD.  

To use the Dialog Editor program, you’ll need a good understanding of 
Windows, along with a basic knowledge of Visual Programming concepts such as 
objects and properties. You should also have a firm understanding of simulation in 
CHEMCAD before venturing into Dialog Editor. 

The Dialog Editor program is separate from CHEMCAD. To launch it, select 
Start > All Programs > Chemstations > Utilities > Dialog Editor. 
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Figure 9-07: The Dialog Editor window showing an open dialog 

A detailed description of how to use the Dialog Editor is available on the 
Chemstations web site under Support > Manuals, as well as on the CHEMCAD 
installation CD‐ROM. 

Customizing Thermodynamics 
Occasionally, you may find that none of the thermodynamic models built into 
CHEMCAD serve your needs for a particular simulation. If this should happen, you 
can take one of two approaches to handling thermodynamics for the simulation: 
either create your own K‐value or enthalpy model or create your own mixing rule. 

Creating a Custom K-value or Enthalpy Model 
The K‐value for any component is a ratio that reflects the amount of that component 
present in vapor and liquid phases under given conditions. CHEMCAD uses K‐
values to calculate vapor‐liquid equilibrium in streams and in UnitOps. 

An enthalpy model calculates the heat content of a system under given 
conditions. Enthalpy models are used to calculate the heat balance in CHEMCAD 
simulations.  

If you have a K‐value or enthalpy method that you’d like to use, you can write 
C++ code to introduce your model into the CHEMCAD system. To build a custom K‐
value or enthalpy model using C++, navigate to the following directory to find and 
open the usradd.dsw workspace: 

C:\Program Files\Chemstations\CHEMCAD\User Added Modules\usradd 
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This workspace includes examples of UnitOps, K‐ values, enthalpy models, and 
mixing rules. 

A detailed description of how to create custom K‐values and enthalpy models is 
available on the Chemstations web site under Support > Manuals, as well as on the 
CHEMCAD installation CD‐ROM. 

When you’ve successfully added a custom K‐value method, you can select it on 
the K‐value Models tab of the Thermodynamic Settings dialog box, by using the 
Global K‐value Option setting called ADDK. 

 
Figure 9-08: Selecting the ADDK K-value option 

After adding a custom enthalpy model, you can select it on the Enthalpy Models 
tab of the Thermodynamic Settings dialog box, by using the Global Enthalpy Option 
setting called ADDH. 

 
Figure 9-09: Selecting the ADDH enthalpy model 
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Creating a Custom Mixing Rule 
A mixing rule determines how CHEMCAD calculates the properties of a mixer, 
based on the properties of its pure components. You can create custom mixing rules 
for any of the selections listed on the Transport Properties tab, either using VBA as 
described in the following section or using C++.  

To build custom mixing rules using C++, navigate to the following directory to 
find and open the usradd.dsw workspace: 

C:\Program Files\Chemstations\CHEMCAD\User Added Modules\usradd 

This workspace includes examples of UnitOps, K‐ values, enthalpy models, and 
various mixing rules. 

A detailed description of how to create mixing rules using C++ is available on the 
Chemstations web site under Support > Manuals, as well as on the CHEMCAD 
installation CD‐ROM. 

Visual Basic Applications (VBA) 
You can customize CHEMCAD using Visual Basic Applications, or VBA. The 
CHEMCAD Explorer’s Visual Basic tab provides access to the following types of 
customizable items: 

• Reactions 

• Properties 

• UnitOps 

If you have written code in VBA that you would like to make available in 
CHEMCAD, you can insert that code into one of the templates that CHEMCAD 
provides, or use any of these templates as a starting point and launch a VBA editor 
from within CHEMCAD.  

Defining a Reaction, Mixing Rule, or UnitOp 
To define a custom reaction, mixing rule, or UnitOp using VBA, follow these steps: 

1. Click the Visual Basic tab in CHEMCAD Explorer and expand the relevant 
item: Reactions, Properties, or UnitOps. 

2. Double‐click the relevant template item to open the VBA editor. 

3. Copy the existing subroutine and paste the code below the example in the 
code window. Rename the new subroutine copy. 

4. Edit the new subroutine as needed to achieve the result that you want. 

5. Return to CHEMCAD by either of two methods: 

• Use [ALT‐TAB] or the Windows taskbar, leaving the VBA editor window 
open. 
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• Click the View CHEMCAD button at the far left end of the VBA editor’s 
toolbar to close the editor window. 

Note: You can also use the [ALT–F11] key combination to toggle between CHEMCAD 
and the VBA editor. 

6. Save the current CHEMCAD simulation, then expand the relevant 
CHEMCAD Explorer item again to see your newly defined item in the list. 

Using a VBA-defined Reaction 
Once you have defined a new reaction, you can use it for a kinetic or batch reactor: 

1. Select the Batch Reactor or Kinetic Reactor tool and place a reactor icon on 
the flowsheet. Add and specify streams for this UnitOp as appropriate. 

2. Double‐click the icon to define reactor specifications. Make the following 
selection to use your VBA‐defined reaction. 

• Batch reactor: After specifying the reactor’s initial charge, you’ll see the 
Batch Reactor General Information dialog box. On the General tab, select 
the kinetic rate expression option called Define each reaction. 

• Kinetic reactor: On the General Specifications tab of the Kinetic Reactor 
dialog box, select the kinetic rate expression option called Define each 
reaction. 

3. For each reaction that you define, you’ll enter data into a Kinetic Data dialog 
box. Choose the Kinetic Rate Expression option called User – VBA. This 
brings up a drop‐down list to the right of the Kinetic Rate Expression field, 
where you can choose a user‐defined reaction. Select the appropriate option 
for each reaction that you define for this UnitOp, and then click OK to 
continue to the next reaction. 

 
Figure 9-10: Selecting a VBA-defined reaction in the Kinetic Data dialog box 
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4. When you have defined the last reaction, click OK to return to the main 
CHEMCAD window. 

Using a VBA-defined Mixing Rule 
Once you have defined a new mixing rule, you can include it in your CHEMCAD 
simulations: 

1. Select Thermophysical > Thermodynamic Settings. 

2. In the Thermodynamic Settings dialog box, drop down the list of options for 
the mixing rule that you used as a template for your new rule. Select your 
rule from the list. 

3. Click OK to return to the main CHEMCAD window. 

Using a VBA-defined UnitOp 
Once you have defined a new VBA UnitOp, you can include it in your CHEMCAD 
simulations: 

1. Select the Visual Basic UnitOp tool and place an icon on the flowsheet. Add 
streams into and out of the UnitOp as you normally would. 

2. Double‐click the icon to define the UnitOp’s specifications. 

3. In the Visual Basic UnitOp dialog box, drop down the Function list to see the 
available VBA UnitOps. Select the one you want to use and click OK. 

 
Figure 9-11: Selecting a VBA UnitOp 
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Chapter 10 

Data Interfaces 

CHEMCAD enables you to exchange data with other programs through a variety of 
methods. This saves time, effort, and the potential for keystroke error and data 
omissions. In some cases, these data interfaces can enable CHEMCAD to link 
directly into your plant information systems to run simulations without human 
intervention. 

The data interfaces that CHEMCAD uses are as follows: 

• The Excel Data Map interface, which can link any value in a CHEMCAD 
simulation to any cell in an Excel worksheet, or vice versa (note that running 
CHEMCAD simulations from Excel requires a COM interface, described 
below) 

• The Visual Basic Application interface, which enables you to build custom 
reactions, mixing rules, and UnitOps 

• The OPC interface, which permits any OPC Client application to access 
values in a CHEMCAD simulation 

• COM interfaces, which allow any COM‐enabled program (such as MATLAB) 
to access and control a CHEMCAD simulation 

Excel Data Mapping 
The Excel Data Mapping feature allows you to link, retrieve, and insert data from an 
Excel spreadsheet into a CHEMCAD simulation. It also lets you insert data from a 
CHEMCAD simulation into an Excel spreadsheet with just a few clicks. The 
integration of CHEMCAD and Excel is a powerful and easy‐to‐use tool that saves 
you time and work. 
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With Excel Data Mapping, you can quickly and easily get the most of 
CHEMCAD/Excel integration, even if you have no experience with Visual Basic or 
Excel programming. In fact, you can use and benefit from this feature even with very 
little knowledge of the Excel program. 

To use Excel Data Mapping, you must first create one or more Data Maps, and 
then set up rules for the execution of each Data Map in use. 

Creating an Excel Data Map 
The tool used to create and edit Data Maps in CHEMCAD is the Excel Data Map 
Editor. This tool displays within the CHEMCAD workspace, and resembles an Excel 
spreadsheet. It has all you need to link stream and UnitOp parameters to one or 
more Excel spreadsheets. On each Excel Data Map, you can link up to 500 
parameters in a single spreadsheet, and you can have up to ten Data Maps per 
simulation. 

To link your simulation to an Excel spreadsheet, first create the target Excel 
workbook, making a note of the file’s name, its location, and the name of the specific 
worksheet to which you want to link. Then follow these steps to create a new data 
map: 

1. On the CHEMCAD Explorer, expand the Data Maps item and then click 
New Data Map. A spreadsheet will open within the CHEMCAD workspace. 

 
Figure 10-01: The Excel Data Map Editor 

2. Click the Browse button and locate the target workbook. Select the workbook 
file and click Open. 

3. In the cell next to Excel Worksheet Name, type the name of the worksheet to 
which you want to link your simulation. 
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Note: If you need to verify the name of the worksheet, you can click the Open button 
to launch Excel and view the workbook. 

4. Click the cell below Map Rule to highlight that cell. Click again to see a drop‐
down list of mapping options: 

• To Worksheet Only enables you to send data from streams or UnitOps in 
CHEMCAD to the selected worksheet. 

• To CC Only enables you to send data from any cell on the worksheet to 
the selected stream or UnitOp parameter in your simulation. 

• For data reconciliation enables you to manipulate the data using CHEMCAD's
Data Reconciliation feature. 

 
Figure 10-02: Selecting a Map Rule option in the Excel Data Map Editor 

5. Click the cell below CC Obj Type to highlight that cell. Click again to see a 
drop‐down list of mapping options: 

• Stream enables you to link an Excel cell or cell range to a stream on the 
flowsheet. 

• UnitOp enables you to link an Excel cell or cell range to a UnitOp on the 
flowsheet. 

• Misc enables you to change dynamic flowsheet settings.  

6. Click the cell below CC Obj ID. Type the ID number of the stream or UnitOp 
to which you want to link. 

7. Click the cell below Par ID to highlight that cell. Click again to see a drop‐
down list of parameters for the selected UnitOp or stream. Scroll down and 
select an option from the list. 

Note: When you are importing cell data into CHEMCAD, the list of parameter 
options is limited, as many values in a CHEMCAD simulation are calculated based 
on other values. 
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8. If you chose a parameter that is related to a specific component (e.g., Comp 
Mole fraction, or any item marked with an arrow), you will need to specify the 
component. Click the cell below Component to highlight that cell, and click 
again to see a drop‐down list of available components. Select a component 
from the list. 

 
Figure 10-03: Component-specific parameters marked with arrows on the Par ID list 

9. Click the cell below WrkSht Cell/Range. Type the cell address or cell range 
to which you want to link. Cell addresses should be formatted with the 
column letter and row number, e.g., A1 or D17. Cell ranges should be 
formatted as two such addresses (representing the range’s first and last 
values) separated by a colon, e.g., A1:A12 or B5:E20. 

10. If you are performing a data   reconciliation,   you can  use   the  
Weight column to give certain items in the reconciliation more importance 
than others. 

11. Repeat the procedure until you have specified all of the cells or cell ranges 
that will link to your simulation. 

12. Save the Data Map by selecting File > Save As. Type a name for your Data 
Map and then click OK. The newly created Data Map now appears on the 
CHEMCAD Explorer under the Data Maps item. 

 
Figure 10-04: List of available Data Maps in CHEMCAD Explorer 
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13. To leave the Data Map open and return to your simulation, use the tabs at the 
bottom of the main CHEMCAD workspace. To close the Data Map, select 
File > Close. 

Data Map Execution Rules 
After configuring one or more Excel Data Maps for a simulation, you must set up 
execution rules to use them. You can configure up to ten Data Map files per 
simulation. 

To set up Data Map execution rules, follow these steps: 

1. On the CHEMCAD Explorer, expand the Data Maps item and then click 
Execution Rules. The Data Map Execution Rules dialog box appears. 

 
Figure 10-05: The dialog box for configuring execution rules 

2. Click the square button next to the first field in the Select Data Maps column 
to bring up the Select Data Map dialog box. 

 
Figure 10-06: Selecting a Data Map from the list 

3. Select the name of the Data Map for which you want to set rules, and click 
OK to return to the Data Map Execution Rules dialog box. Repeat this step 
for all other Data Maps whose rules you want to set up at this time. 
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4. In the Before Simulation Runs field next to each selected Data Map, click the 
drop‐down list to choose an action for that Data Map to perform before 
calculations begin: 

• Do Nothing performs no action before the simulation is run. You might 
use this option to disable a Data Map temporarily. 

• To Workbook sends the requested data to Excel before running the 
simulation. You might use this option when you want to pull data from 
inlet streams or UnitOp specifications. 

• To CHEMCAD sends the requested data in Excel to CHEMCAD before 
running the simulation. You might use this option when you want to feed 
data to inlet streams or UnitOps with data from the Excel worksheet. 

5. In the After Simulation Runs field next to each selected Data Map, click the 
drop‐down list to choose an action for that Data Map to perform after 
calculations are complete: 

• Do Nothing performs no action after your simulation has run. You might 
use this option to disable a Data Map temporarily. 

• To Workbook sends the requested data to Excel after running the 
simulation. You might use this option when you want to send data from 
streams or calculated parameters of UnitOps to the workbook in Excel. 

 
Figure 10-07: Three different Data Maps with rules set up 

6. When you have configured all of the Data Maps that you want to use, click 
OK to save your rules and close the Data Map Execution Rules dialog box. 

You can now run the simulation. If you open the Excel files that are linked to the 
simulation, you will be able to see the parameters of streams and UnitOps related to 
the Excel Data Map. You can also perform your own calculations in the workbook 
based on the data linked to CHEMCAD. 
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Creating Excel UnitOps 
You can build an Excel spreadsheet that functions as a UnitOp within CHEMCAD. 
This is useful for extremely simple UnitOps such as mixers and dividers, or for 
simple separations. 

1. Start by creating a custom dialog box for your new UnitOp, as described in 
Chapter 9, Customizing CHEMCAD. 

2. Next, create an Excel spreadsheet containing your desired calculations for the 
new UnitOp. 

3. Open a simulation, select the Excel UnitOp tool on the All UnitOps palette, 
and place a UnitOp icon on the workspace. 

4. Draw the appropriate streams into and out of the Excel UnitOp. 

5. Double‐click the UnitOp icon to open the Excel WorkBook Unit dialog box. 

6. On the File Paths tab, use the top Browse button to specify the location and 
file name of the custom dialog box that you created. Use the second Browse 
button to specify the location and file name of the Excel workbook. 

7. Now you need to specify how this spreadsheet will link to CHEMCAD. Click 
the Data Maps tab to link the spreadsheet using one or more Data Maps, or 
click the Excel Macros tab to link the spreadsheet using the COM interface. 

• On the Data Maps tab, specify the execution rules as described earlier in 
this chapter. 

• On the Excel Macros tab, specify the names of the Excel macros that you 
have programmed to use the COM interface, in the order that you want 
them to be calculated. 

8. Click OK to return to the main CHEMCAD window. 

Specification Sheets 
Using the interface with Microsoft Excel, CHEMCAD allows you to output 
simulation data to an Excel spreadsheet resembling a vendor specification sheet, as 
discussed in Chapter 8, Output and Reports. Customizing these spec sheets saves you 
time by outputting data in the format required by your company or vendor. 

To customize the spec sheet for a specific UnitOp type, edit the corresponding 
Excel spreadsheet in the following directory: 

C:\Program Files\Chemstations\CHEMCAD\Program\templates 

If the UnitOp type you want is not represented by the Excel files in this directory, 
you can copy the generic specsheet.xls file and use it as a template for a new UnitOp 
spreadsheet. 

Place the copy in the same directory, and make its file name the standard four‐
character abbreviation for the UnitOp type in question. For example, to create a spec 
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sheet template for the Flash UnitOp, you would need to name the file copy flas.xls. 
See the CHEMCAD Help information about your specific UnitOp if you need to look 
up this abbreviation. 

Before you continue, you will need to turn off the Read‐only attribute for the 
new spreadsheet file. The quickest way to do this is to right‐click the file within the 
Windows Explorer, select Properties, and then clear the Read‐only check box in the 
Properties dialog box.  

Once the copy is renamed and the Read‐only attribute is turned off, you can 
open the spreadsheet and edit it as needed. 

Using CHEMCAD as an OPC Server 
CHEMCAD is capable of setting up an OPC server which allows direct data transfer 
between any CHEMCAD simulation and any OPC client application. 

OPC stands for OLE for Process Control. OPC provides a standard method for 
different devices and applications to share data. Using OPC, you can share data 
between CHEMCAD simulations and SCADA systems, data historians, distributed 
control systems (DCS), and human‐machine interfaces (HMIs). 

In fact, the acronym OPC is now considered by many to mean Openness, 
Productivity, Connectivity, because this technology forms the basis for sharing and 
manipulating plant data. 

OPC‐enabled systems are classified as either OPC servers or OPC clients. OPC 
servers are either applications or devices that provide data. OPC clients are 
interfaces that use and manipulate this data. OPC clients can connect to multiple 
OPC servers at any time and read and write data to all of them. 

OPC Applications 
OPC can be applied as follows: 

• Inferential sensors: Sometimes called soft sensors, inferential sensors use one 
or more measured variables to estimate another variable. Using CHEMCAD 
simulations and data from your plant’s DCS, you can embed simulations to 
provide data such as concentrations, heat duty, and fouling factor, which 
would not normally be available. 

• Operator training: You can couple an operator HMI to a dynamic simulation 
to create a training simulator that can help train operators in a safe and 
effective way. 

OPC Compliance 
Chemstations is a Member of the OPC Foundation, an organization devoted to 
maintaining the OPC standards. CHEMCAD has been certified for, and interop 
tested for, OPC DA standard 2.05a. 
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Enabling CHEMCAD as an OPC Server 
To enable OPC within CHEMCAD, select Tools > Options > Misc. Settings, then 
check the Enable OPC Server box and click OK. When you do this, CHEMCAD 
registers an OPC server named CHEMCAD.SimulationServer.1 on your machine. 

Once you load a simulation, all of that simulation’s stream properties and 
UnitOp settings and variables are automatically published as tags to the OPC 
server’s namespace. 

Every value tag has a units tag associated with it, which shows the engineering 
units used to report the value. To change the engineering units, select Format > 
Engineering Units within a CHEMCAD simulation. 

When the OPC server feature is enabled, CHEMCAD automatically registers 
itself as an OPC server. If you want to unregister CHEMCAD and remove it from the 
list of OPC servers, you can select Start > Run and type the following command: 

{program directory}\CC6.Exe –unregister 

For example, if your program directory were C:\Program 
Files\Chemstations\CHEMCAD\Program (the default directory), you would type 
the following: 

C:\Program Files\Chemstations\CHEMCAD\Program\CC6.exe -
unregister 

Reading and Writing Values to CHEMCAD Using OPC 
You can use OPC to have values read from or written to a simulation, and to run the 
simulation. Both steady‐state and dynamic simulations can be run in this way. 

Values are updated to the OPC server whenever CHEMCAD completes a steady‐
state run or a dynamic time step. Values can also be read; in the case of a dynamic 
simulation, reading values between time steps will cause the program to extrapolate 
from the last converged results. 

Values can be written at any time. If CHEMCAD is in the process of executing a 
time step or a steady‐state simulation, the values are held in a buffer until the 
simulation is converged, at which time the values are written to CHEMCAD. 

When values are written to a CHEMCAD stream, the stream is immediately 
reflashed, and all OPC tags for that stream are updated. 

OPC Server Operations 
In addition to reading and writing process data to CHEMCAD, it is useful to be able 
to send commands to CHEMCAD, for example to tell CHEMCAD to start or stop 
running a simulation. 

This is done with a series of flags in the CHEMCAD group of the OPC server. To 
use any of these flags, write a 1 to flag. CHEMCAD will execute the desired 
command and return a value indicating success or failure. A return of 0 indicates 
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that the command has completed successfully, while a negative return indicates a 
problem of some kind. 

The available commands are as follows: 

• Refresh Server tells CHEMCAD to refresh all data sent to the OPC server. 

• Run Steady State runs a steady‐state simulation. When the simulation 
finishes, the flag will be reset either to 0 (run converged) or to a negative 
number indicating the number of errors that occurred during the run. To 
view the error message text, you must open the CHEMCAD interface 
directly. 

• Restore to initial state returns a dynamic simulation to time zero. A return of 
0 indicates success; a value of ‐1 indicates failure. 

• Run Dynamic starts a dynamic simulation. A return of 0 indicates success; a 
value of ‐1 indicates failure. 

• Run Dynamic One Step runs a single time step of a dynamic simulation. A 
return of 0 indicates success; a value of ‐1 indicates failure. 

• Set Initial State sets the current process conditions as the time‐zero 
conditions, overwriting the previous time‐zero conditions. A return of 0 
indicates success; a value of ‐1 indicates failure. 

• Stop Simulation stops a dynamic simulation. A return of 0 indicates success; 
a value of ‐1 indicates failure. 

CHEMCAD OPC Namespace 
An OPC namespace defines and organizes all the available commands and data. 
OPC namespaces are divided into groups, each of which contains items. Items are 
sometimes referred to as tags. 

Note: Most of the data items in a simulation have engineering units associated with 
them. In these cases, we usually define two separate tags, one containing the data 
value and the other containing the units string. All units strings are read only from 
OPC. The units strings are governed by the settings inside the simulation. 

The groups in CHEMCAD’s OPC namespace are organized as follows: 

• CHEMCAD.SimulationServer: This is the OPC server name. By convention, 
this name is followed by a version number, e.g., 
CHEMCAD.SimulationServer.1, to indicate the OPC Server version. This is 
the server name to which OPC clients will connect. 

• CHEMCAD Group: This group contains any information that is not 
dependent on a stream or UnitOp, and all commands used to run 
CHEMCAD. 
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• Streams Group: This group contains a series of subgroups, one for each 
stream on the flowsheet numbered by stream ID number. 

• UnitOperations Group: This group contains a series of subgroups, one for 
each unit operation on the flowsheet, numbered by UnitOp ID number. 

COM Interfaces 
Component Object Model (COM) is a Microsoft‐standard platform that enables 
programs to share content such as data and calculation routines. This interface 
makes it possible for other programs to control a CHEMCAD simulation. 

CHEMCAD acts as a COM server, so any program that can act as a COM client 
can be made to interface with CHEMCAD in this way. If you aren’t certain whether 
your application can act as a COM client, check with the software vendor. 

Note: Using the COM interface to CHEMCAD is a complicated procedure that 
requires some experience in programming. If your organization lacks in‐house 
expertise in programming, consider bringing in a third‐party resource to assist you 
with the procedure. 

The following section is a brief walk‐through of a simple COM interface between 
Excel and CHEMCAD. 

Connecting Excel and CHEMCAD: A Simple COM Interface 
While you can export or import data values using Excel Data Map, more 
complicated interactions—such as running a simulation from another program—
require the extra control afforded by the COM interface. 

The following is a simplified description of the procedure for connecting these 
two programs and enabling Excel to load a simulation, change a value, run the 
simulation again, read the same value, and then close the simulation. 

In this procedure, you’ll use Excel to do the following: 

• Open CHEMCAD 

• Read in values from CHEMCAD into an Excel workbook 

• Change a value in the simulation 

• Run the simulation 

• Read the revised values back into Excel 

Normally, using COM interfaces involves some programming. We have created 
an example called VBCLient.xls to help you overcome that hurdle; you don’t need to 
write any code at all to use this tool. Even if you need to write your own program, 
the code in the macros of VBClient will come in handy as a guide. 
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Using the VBClient Example 
Follow these steps to use the VBClient example: 

1. Open Excel and load the workbook called VBClient.xls. This workbook has 
three worksheets: 

• Command contains buttons for controlling a CHEMCAD simulation. 

• Streams displays all stream data in the simulation. This sheet can be used 
for both input and output of stream variables to the CHEMCAD 
simulation. 

• UnitOps displays all UnitOp‐related data for the simulation. This sheet 
can be used for both input and output of UnitOp variables to the 
CHEMCAD simulation. 

2. On the Command sheet, you will see a series of buttons to load CHEMCAD, 
load a simulation, read data from the simulation, write data back to the 
simulation, and run the simulation. Click Load CHEMCAD to start an 
instance of CHEMCAD. 

Click Load Simulation to load a simulation into CHEMCAD. 

Make a change to the data shown on the Streams and UnitOps sheets. 

Note: Some values are read‐only. For example, VBClient does not allow you to 
change a stream’s total flow rate directly; you must instead change the component 
flow rates to make a change to the total flow rate. 

3. Click Save Data to push your changes to the CHEMCAD simulation. 

4. Click Run All to run the simulation. 

5. Note the changes to the data on the Streams and UnitOps sheets. 

A Peek under the Hood 
Right‐click Load CHEMCAD, select Assign Macro, and then click Edit. The Visual 
Basic editor in Excel opens to display the code behind the button: 

Sub LoadCC5() 
 
 ' initialize global variables 
 selJobName = "" 
 selCaseName = "" 
 selUpdateStrUopData = False 
 selOK = False 
 
 Set CC5 = Nothing 
 
 ' load CHEMCAD 
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 Set CC6 = CreateObject("CHEMCAD.VBServer") 
 
 If CC6 Is Nothing Then 
  Dim msg As String 
  msg = "Can not load CHEMCAD." 
  MsgBox msg 
 
 End If 
End Sub 
 

The most important line in that whole subroutine is: 

 Set CC6 = CreateObject("CHEMCAD.VBServer") 

In that single line, Excel loads CHEMCAD into memory. 

Loading a simulation is accomplished with this simple line: 

 retFlag = CC6.LoadJob(casePath) 

Running a simulation can be as simple as this: 

 retFlag = CC6.SSRunAllUnits 

The document called COM Interface Reference.doc, available on the 
Chemstations web site, provides a full reference of the commands available through 
COM. 
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Chapter 11 

CHEMCAD Tutorials 

Although the simulations stored in your Examples directory are useful for many 
scenarios, the best way to learn to use CHEMCAD is to create and run simulations 
yourself. The tutorials in this chapter walk you through basic simulation building 
step by step, using a realistic example problem that will help prepare you for your 
own simulations. 

The first tutorial is for a simple steady‐state simulation, which is then used as the 
basis for the second tutorial, in which you’ll learn to use the CC‐THERM module to 
rate a heat exchanger. The third tutorial walks you through a batch distillation 
problem using CC‐BATCH, and the final tutorial covers various scenarios for piping 
systems. 
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CC-STEADY STATE Tutorial 
This tutorial creates a basic steady‐state simulation for a condensate stabilizer plant. 
In this plant, gas enters the system with the feed conditions shown in the following 
diagram: 

 
Figure 11-01: Condenser stabilizer problem diagram 

Your job is to determine new operating conditions for this existing plant, along 
with any necessary modifications. The design requirements are as follows: 

• The cricondentherm dewpoint of the product gas must be 20° F or less. A 
cricondentherm dewpoint is the highest temperature for two‐phase 
coexistence of a mixture. As long as the stream temperature stays above the 
cricondentherm dewpoint, the stream contents will not condense. 

• The stabilized condensate must have maximum propane content of 1%. 

Overview 
Running a flowsheet simulation in CHEMCAD is essentially a nine‐step procedure: 

1. Start a new simulation. 

2. Select engineering units. 

3. Create a flowsheet. 

4. Select components. 

5. Select thermodynamics options. 

6. Define the feed streams. 

7. Enter UnitOp parameters. 
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8. Run the simulation. 

9. Review the results and print as needed. 

The steps do not have to be performed in this order, nor do all of them have to be 
done for each flowsheet, but you should consider all steps for each problem. 

Starting a New Simulation 
Start by creating a new simulation and giving it a name. 

To do this, launch CHEMCAD and then Select File > Save to open the Save As 
dialog box. Navigate to the directory where you want to store the simulation (try My 
Simulations, located under My Documents) and give your simulation a name, 
leaving the type as CHEMCAD 6 (*.cc6). Then click Save to create the file and return 
to the main CHEMCAD window. 

Note: Instead of saving all changes instantly, CHEMCAD now saves your simulation 
only when you use the Save command. This provides you with greater flexibility 
and gives you more control over your simulations, but it also means that you should 
save your work frequently. This is a sound practice for working in any software 
application, as it can help you avoid losing work in the event of a power problem or 
computer glitch. 

Selecting Engineering Units 
Select Format > Engineering Units to open the Engineering Unit Selection dialog 
box. 

The English units option is the default and is currently highlighted. To change the 
engineering units system, you would click the Alt SI, SI, or Metric button; you could 
then change any of the individual units as well. For this tutorial, you will use English 
units, so click Cancel to exit this dialog box without making changes. 

Drawing the Flowsheet 
As described in Chapter 5, creating a flowsheet is a matter of placing UnitOp icons 
on the screen, connecting them with streams, and then adding various graphical 
objects to enhance the drawing. 

Placing UnitOps 
1. Start your flowsheet by adding an icon to represent the initial feed stream. In 

the All UnitOps palette, find the Feed icon, which is an arrow pointing to the 
right. Click the Feed icon, then click in the workspace where you want to 
place the feed stream. When the feed stream arrow appears, go ahead and 
turn off the Feed drawing tool by right‐clicking any blank area of the 
workspace. 
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Note: At any time after drawing a feed stream or any UnitOp icon, you can click the 
icon to display the black sizing handles at each corner. With the icon selected this 
way, you can click the icon and drag it to a new location, or click any sizing handle 
and drag it outward or inward to resize the icon. 

2. Now place the two heat exchangers on the flowsheet. On the All UnitOps 
palette, point to the Heat Exchanger icon until its pop‐up label appears (see 
Figure 11‐02). 

 
Figure 11-02: The pop-up label that identifies the UnitOp icon 

3. Click the lower right corner of the Heat Exchanger icon, on the black triangle, 
to open the sub‐palette. Select the two‐sided heat exchanger icon as shown in 
Figure 11‐03. The icon that you clicked in the sub‐palette now appears on the 
main All UnitOps palette to represent the Heat Exchanger UnitOp. 

 
Figure 11-03: Selecting the two-sided heat exchanger icon 

4. Point the mouse cursor about an inch to the right of the feed icon and click. A 
two‐sided heat exchanger icon appears on the flowsheet where you clicked.  

Note: The UnitOp ID label of 1 should appear in a circle next to the heat exchanger 
icon. For each subsequent UnitOp that you draw, CHEMCAD will assign an ordinal 
number in this way, to uniquely identify each piece of equipment on the flowsheet. 

5. Return to the All UnitOps palette, and again click the Heat Exchanger icon’s 
black triangle. To switch from the two‐sided model to a single‐sided model, 
you’ll need to select the appropriate icon (see Figure 11‐04) from the Heat 
Exchanger sub‐palette. 
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Figure 11-04: Switching to the single-sided heat exchanger icon 

6. Again move the cursor to the workspace, this time about an inch to the right 
of the first heat exchanger, and click the mouse. A single‐sided heat 
exchanger icon appears on the flowsheet where you clicked. Your flowsheet 
so far should look something like Figure 11‐05. 

 
Figure 11-05: The flowsheet so far 

7. Add the Flash and Valve UnitOp icons to your flowsheet, using the standard 
icons. 

8. For the condensate stabilizer, use a distillation column. Multiple distillation 
UnitOps are available, but for now, assume that the module you want to use 
is the rigorous distillation model called Tower. You’ll need a Tower icon with 
trays and a reboiler but no condenser; this is different from the default Tower 
UnitOp icon. Click the lower right corner of the Tower icon’s box to view the 
sub‐palette, then select the icon shown in Figure 11‐06. 

 
Figure 11-06: Selecting the appropriate Tower UnitOp icon 

9. Now that you have selected the appropriate Tower icon, add this UnitOp to 
the flowsheet. 
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10. Place three Product icons on the flowsheet, one for each product stream. You 
can quickly place three identical icons, simply by clicking repeatedly in a 
slightly different location. When you’ve clicked to create the third Product 
icon, right‐click to turn off the Product drawing tool. 

Drawing Streams 
Now that all of the UnitOps are in place, select the Stream tool and connect the 
various UnitOps as appropriate. Remember that each stream must start at a red 
outlet point on the upstream UnitOp, and end at a blue inlet point on the 
downstream UnitOp. 

To avoid having to re‐select the Stream tool each time, make sure that as soon as 
you click to complete one stream, you move the cursor to the next location and click 
to start the next stream. 

Draw streams to connect the following: 

• Feed stream to first heat exchanger’s left‐side inlet 

• First heat exchanger’s right‐side outlet to second heat exchanger’s left‐side 
inlet 

• Second heat exchanger’s right‐side outlet to flash inlet of your choice 

• Flash top outlet to first heat exchanger’s top inlet 

• First heat exchanger’s bottom outlet to nearest product icon 

• Flash bottom outlet to valve inlet 

• Valve outlet to tower inlet of your choice 

• Tower top outlet to nearest product icon 

• Tower bottom reboiler outlet to nearest product icon 

As you draw streams, CHEMCAD assigns stream IDs, just as it assigned UnitOp 
IDs when you created those items. The labels for stream IDs are displayed in 
squares, to distinguish them from the UnitOp IDs displayed in circles. 

Selecting Components 
Now you need to identify the components to be used in this simulation. Start by 
selecting Thermophysical > Select Components. This brings up the Select 
Components dialog box, shown in Figure 11‐07. 
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Figure 11-07: The Select Components dialog box 

For this example, you’ll choose components from the standard CHEMCAD 
database. In the Select Components dialog box, find and add each needed 
component, beginning with nitrogen: 

1. In the Search box, start typing the word nitrogen. 

2. As soon as you’ve typed ni, you should see 46 – Nitrogen – N2 highlighted in 
the Available Components area. Click the right arrow button to add nitrogen to 
your simulation. 

3. Use the scroll bar in the Available Components area to return to the top of the 
component list. 

4. Hold down the [CTRL] key on your keyboard as you click each of the 
following components in turn: 

• 2  Methane 

• 3  Ethane 

• 4  Propane 

• 5  I‐Butane 

• 6  N‐Butane 

5. Click the right arrow button, located to the right of the Available Components 
area, to add all of the selected components to your simulation. 

6. Now add the following components by double‐clicking each one in turn: 

• 7  I‐Pentane 

• 8  N‐Pentane 

• 10  N‐Hexane 
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Figure 11-08: The completed Select Components dialog box 

7. Save your component selections by clicking OK.  

Selecting Thermodynamic Options 
As soon as you have finished component selection, the Thermodynamics Wizard 
appears. This tool can suggest thermodynamics options to use with this simulation. 

CHEMCAD’s Thermodynamics Wizard works like this:  

1. First, it looks at the component list and decides what general type of model is 
required, i.e., equation‐of‐state, activity model, etc. 

2. Second, it looks at temperature and pressure ranges that you provide and 
decides which equation within a given category is best at the limits of those 
ranges. 

3. If the method is an activity model, the program then looks at the BIP 
database to see which model has the most data sets for the current problem. 
It then calculates the fractional completeness of the BIP matrix. If that fraction 
is greater than the BIP threshold parameter, it uses the chosen activity 
method; if not, it uses UNIFAC. 

The Thermodynamics Wizard is no replacement for engineering judgment. This tool 
uses an algorithm based on general rules, and is therefore fallible. The suggested 
model might not always be the best model for the system.  

Selecting thermodynamic options basically means selecting a model or method 
for calculating vapor‐liquid (or vapor‐liquid‐liquid) phase equilibrium (called the K‐
value option) and selecting a method or model for calculating the heat balance (called 
the enthalpy option). The commands for these selections are located on the 
Thermophysical menu. 

CHEMCAD has a library of dozens of K‐value models with a variety of options 
and about 12 enthalpy models. Making the proper selection from these libraries can 
sometimes be difficult. For the purposes of this tutorial, assume that you want to use 
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the Peng‐Robinson method for both the K‐value and enthalpy calculations. Follow 
these steps to select your thermophysical options: 

1. Accept the default temperature and pressure ranges in the Thermodynamics 
Wizard and click OK. 

2. Click OK again to accept the wizard’s suggested method of SRK. 

3. When the Thermodynamic Settings dialog box opens, find the Global K‐
Value Option selection, in the upper left corner of the K‐Value Models tab. 
The current setting is SRK, but for the purposes of the tutorial, you’ll need to 
select the Peng‐Robinson model. Click the down arrow at the right end of the 
selection box to view a long list of K‐value choices, then click Peng‐
Robinson. 

 
Figure 11-09: The new K-value selection in the Thermodynamic Settings dialog box 

4. Now click the Enthalpy Models tab. The Peng‐Robinson method has already 
been entered as the Global Enthalpy Options selection; this was done 
automatically because you chose Peng‐Robinson as your K‐value method. 
While you do have the option to override this choice, in this case you’ll need 
to keep the Peng‐Robinson model; leave all settings as they are and click OK 
to return to the main CHEMCAD workspace. 

For the purpose of this tutorial, the thermodynamic selections are now complete. 

Note: While you are not required to use the Thermodynamics Wizard, you should 
know how to use it, if only as a starting point for your simulations. You can revisit 
the wizard at any time by selecting Thermophysical > Thermodynamics Wizard.  
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Defining the Feed Streams 
Now it’s time to define your simulation’s feed stream. There are several ways that 
you can do this, but the quickest and most efficient way to define a single stream is 
to double‐click the stream line. 

Note: Before you proceed, verify that your engineering units are set to English in the 
Engineering Unit Selection dialog box, as described earlier in this tutorial.  

Double‐click the line for stream 1, your feed stream, to bring up the Edit Streams 
dialog box. 

 
Figure 11-10: The Edit Streams dialog box 

You will specify the feed stream according to the following rules: 

• The Stream Name field can display a stream label of up to 16 alphanumeric 
characters. This field is optional, and you can use any label you like. 

• The next four fields—Temp F, Pres psia, Vapor Fraction, and Enthalpy 
MMBtu/h—are the thermodynamic properties of the stream. According to the 
Gibbs Phase Rule, once a mixture’s composition is given, specifying any two 
of these four thermodynamic properties will define the other two. As such, 
defining the composition, temperature, and pressure for a mixture uniquely 
defines its vapor fraction and enthalpy. Alternatively, defining the 
composition, pressure, and enthalpy will uniquely define the mixture’s 
temperature and vapor fraction. 

Since enthalpies are calculated relative to a datum, the calculation of any 
given stream enthalpy is an involved process which is prone to errors. For 
this reason, CHEMCAD does not permit you to enter stream enthalpy as a 
constraint. 
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In addition to defining the stream’s composition, you must define exactly 
two of the following properties: temperature, pressure, and vapor fraction. 
The two variables that you specify will display as red text, while the third 
variable and the value enthalpy will be displayed in black when you flash the 
stream. 

An exception to this convention allows you to add heat duty with an empty 
stream. If you specify a total component flow rate of zero, you may specify a 
temperature, pressure, and enthalpy rate. A stream defined this way is 
treated as a heat duty, and is added to the heat balance of the unit. The 
temperature and pressure are arbitrary for this situation. 

• The Total flow unit and Comp unit fields work together to provide a variety 
of ways to define stream compositions. If the selected comp unit is mole, 
mass, or volume fraction (either globally or locally), then the Total flow unit 
selection is available. If the selected comp unit is a flow or amount option, 
then the total flow rate becomes the sum of the component flow rates, and 
the Total flow unit selection is not available. 

• If the Comp unit field selection is an amount flow unit (as opposed to a 
fractional unit), then the component flow rate values are automatically added 
as you enter them. The current sum is displayed in the Total flow field. 

• You can click the Flash button at any time to perform a flash calculation 
using the currently specified composition and thermodynamic properties. 
This enables you to obtain flash calculations quickly and without leaving the 
dialog box. 

• Fractions that do not add up to 1.0 are automatically normalized when you 
either click Flash or exit the dialog box. 

With these rules and behaviors in mind, enter the data for your feed stream. 

1. Begin with the stream temperature. Click the Temp F label, then click the 
empty field to its right. Type 75 and then press the down arrow key on your 
keyboard to continue. 

2. Type 200 in the Pres psia field, then press the down arrow key several times 
until you arrive at the Nitrogen field. 

Note: Before you continue, verify that the Comp unit field is set to lbmol/h. 

3. Type 100.19 in the Nitrogen field, and then in similar fashion, type the 
following numbers in the corresponding fields: 

• Methane: 4505.48 

• Ethane: 514 

• Propane: 214 

• I‐Butane: 19.2 
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• N‐Butane: 18.18 

• I‐Pentane: 26.4 

• N‐Pentane: 14 

• N‐Hexane: 14 

4. Click OK to save this stream information and return to the main CHEMCAD 
workspace. 

Enter UnitOp Parameters 
Now that you’ve specified your feed stream properties, it’s time to specify the 
characteristics of your UnitOps. The following sections address each UnitOp in turn. 

Note: As with streams, you can enter UnitOp parameters in various ways, but for the 
purposes of this tutorial, we’ll use the quickest and simplest method, double‐clicking 
each UnitOp to access its specification dialog box. 

First Heat Exchanger 
1. Double‐click the flowsheet icon for the first heat exchanger. The Heat 

Exchanger dialog box will appear, as shown in Figure 11‐11. 

 
Figure 11-11: The Heat Exchanger dialog box 

2. As with many types of UnitOps, the dialog box for specifying a heat 
exchanger consists of multiple tabbed pages. You can browse through the 
Specifications, Misc. Settings, and Cost Estimations tabs by clicking each 
tab in turn. 

3. The pressure drop on both sides of this exchanger is 5 psi. On the 
Specifications tab, find the Pressure Drops area, and enter 5 in both the Stream 
1 and Stream 4 fields.  

4. The first stream outlet must be at its dewpoint, so you’ll need to specify an 
outlet vapor pressure of 1. In the field next to Vapor fraction stream 2, enter 1. 
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5. Click OK to save the specifications for this UnitOp and close the dialog box. 

Second Heat Exchanger 
1. Double‐click the flowsheet icon for the second heat exchanger. The Simple 

Heat Exchanger dialog box will appear. 

2. The outlet temperature from this heat exchanger will determine how much of 
the liquid is removed in the flash drum. This, in turn, will determine the 
cricondentherm dewpoint of the product gas. Therefore, this specification is 
one of the key parameters of this process. As a first attempt, use an outlet 
temperature of ‐5° F. Enter 5 in the Pressure drop field and –5 in the 
Temperature of stream 3 field. 

 
Figure 11-12: Setting up the second heat exchanger 

3. Click OK to save the specifications for this UnitOp and close the dialog box. 

Flash Drum 
In this simulation, the flash drum is a vapor‐liquid separator and requires no 
specification. 

Valve 
1. Double‐click the valve flowsheet icon to bring up the Valve dialog box. 

2. The outlet pressure for this unit is 125 psia, so enter 125 in the Outlet pressure 
field. 

3. Click OK to save the specifications for this UnitOp and close the dialog box. 
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Stabilizer Tower 
1. Double‐click the tower icon to open the TOWR Distillation Column dialog 

box. Note that the settings for this UnitOp are divided into five tabs. 

2. On the General tab, enter the following: 

• Colm press drop: 5 

• No. of stages: 12 

• Feed tray for stream: 1 

3. Click the Specifications tab to make specifications for the column. This 
column has no condenser or side streams, so you will only be making 
specifications for the reboiler. Drop down the list of options for Select reboiler 
mode, and select the mode called 4 Bottom mole flowrate. 

4. Now you need to specify the numeric value of the reboiler flow rate. In the 
Specification field immediately to the right of your reboiler mode selection, 
enter a value of 30. 

5. Click OK to save the specifications for this UnitOp and return to the main 
CHEMCAD workspace. 

All of the data entry for the flowsheet is now complete. Before you continue, you 
should save your simulation. As noted earlier, it’s a good idea to do this periodically 
as you build the simulation, but completion of your UnitOp specifications is a 
particularly good time to stop and save. 

Run the Simulation 
To run the simulation, click the Run All button on the toolbar. 

The program first rechecks the data and lists any errors and warnings in the 
Messages pane. In this case, you should have no errors, although you will have 
warnings about estimates you have not given. You can ignore these warnings and 
proceed by clicking Yes. The calculation will then proceed. 

When the run finishes, a message box appears: Recycle calculation has converged. 
To close this dialog box and clear the screen, click OK. 

Review the Results and Print as Needed 
Before running and printing reports and plots, you should review the simulation to 
verify whether it meets the design criteria set out for this problem. 

Checking the Cricondentherm Dewpoint 
If you have chosen the proper outlet temperature for the second heat exchanger, the 
cricondentherm dewpoint for the product gas stream (stream 5) will be 20° F or less. 
The cricondentherm dewpoint, you will recall, is the highest dewpoint temperature a 
mixture will ever see at any pressure. The simplest way to identify the highest 
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dewpoint temperature of the product gas is to plot all of the dewpoint temperatures 
of the product gas, i.e., to plot a phase envelope. 

1. Start with the Plot menu, which provides access to all types of graphical 
reports. Select Plot > Phase Envelopes. In the Select Streams dialog box, 
specify stream 5, then click OK to bring up the Phase Envelope dialog box. 

2. No entries are required on this screen since you only need to look at the 
dewpoint line, but to make the plot more interesting, display the 0.25 and the 
0.5 vapor fraction lines in addition to the normal phase envelope boundaries. 
Complete the dialog box as shown in Figure 11‐13. 

 
Figure 11-13: Plotting vapor fraction lines along with the cricondentherm dewpoint 

3. Click OK to continue. CHEMCAD perform the required flash calculations to 
generate the specified phase envelope. Phase envelope results are produced 
in two formats: 

• A numerical tabulation (table) of the temperature, pressure, vapor 
fraction, vapor compressibility factor, and the liquid compressibility 
factor 

• A graphical plot of temperature and pressure for each vapor fraction line 
requested 

The tabular results will appear first; since you’re interested in the graphical 
results, close the window displaying the table. The screen will now look 
similar to Figure 11‐14. Note that the main CHEMCAD button toolbar is 
largely unavailable now, and the menu items have changed. 
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Figure 11-14: Phase envelope plot results 

4. To determine whether the cricondentherm dewpoint of stream 5 is 20° F or 
less, zoom in on the far right portion of the dewpoint curve. To do this, click 
and drag with your mouse to highlight that portion of the graph—
approximately 400 to 1000 psi and 0 to 30° F. When you release the mouse 
button, the selected area will fill the entire plot window, giving you a close‐
up view of specific data points. 

 
Figure 11-15: Zoomed-in plot results 

5. As this view shows, the highest dewpoint of this mixture is a little less than 
20° F, so the cricondentherm dewpoint is indeed within the target product 
gas specification. Right‐click the mouse anywhere in the plot window to 
return to the full plot view. 

6. To print the phase envelope plot, click the Print button and then follow any 
prompts from your printer. 

7. You can also try the following to practice working with plots in CHEMCAD: 

• Edit the text of the plot title (in this case, Phase Envelope for Stream 5) or the 
graph axis labels by selecting Graph > Edit Titles. In the Chart Titles 
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dialog box, make any desired changes and then click OK to view the 
updated chart. 

• Select Graph > Edit to open the Chart Explorer, which provides access to 
settings for color, size, layout, and various other aspects of the plot 
presentation. 

8. Return to the main CHEMCAD window by selecting File > Close. 

Checking the Bottoms Stream Purity 
This problem also requires that the percent of propane in stream 9 be 1%. You can 
check to see if you’ve achieved this specification by checking the stream composition 
report available on the Report menu. First, though, you’ll need to set the flow units 
for the stream composition. 

1. Select Report > Set Flow Units to bring up the View Flow Rate Unit dialog 
box. Click the Mole % button and then click OK to apply this selection and 
close the dialog box. 

2. Now select Report > Stream Compositions > Select Streams. In the Select 
Streams dialog box, enter 9 and then click OK to continue. 

3. The resulting tabular data window shows that propane is greater than the 1% 
specification (see Figure 11‐16). This means that the initial design is too 
conservative. To correct this, you can go back and re‐specify the column to 
produce precisely 1% propane in the bottom. 

 
Figure 11-16: Stream Composition report for stream 9 

4. Select File > Exit in the tabular data window to return to the main 
CHEMCAD window. 
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Re-running the Simulation 
You can now re‐run the stabilizer, specifying that you want 1% propane in the 
bottom. 

1. Double‐click the Tower UnitOp to bring up the TOWR Distillation Column 
dialog box for the stabilizer. 

2. Click the Specifications tab. You need to change the reboiler mode from 4 
Bottom mole flowrate to a purity specification. Click the Select reboilers mode 
drop‐down list and select 6 Bottom component mole fraction. 

3. With this change of mode, you need to specify the desired purity and the 
component for which it is being specified. In the Specification field, enter .01. 
In the Component drop‐down list, select 4 Propane. 

4. Click OK to save your changes and return to the main CHEMCAD 
workspace. 

5. You can now re‐run the calculations for the condensate stabilizer. While you 
could accomplish this using the Run All command, it’s more efficient to re‐
run only the UnitOp that you have changed. The quickest way to do this is to 
right‐click the UnitOp icon on the flowsheet and select Run this UnitOp. Run 
the Tower UnitOp using this method. 

As soon as you see the Run finished message in the bottom left corner of the 
CHEMCAD window, you can check on the propane content of the bottom stream. 
You’ve already seen how to get a detailed Stream Composition report; you can also 
use the Flowsheet Quickview feature to get instant stream information without even 
clicking the mouse. 

Find the Flowsheet Quickview button at the far right end of the CHEMCAD 
toolbar. If this button is not currently activated (with a thin outline and a white 
button background), click the button to turn on this feature. 

 
Figure 11-17: Turning on the Flowsheet Quickview feature 

With Flowsheet Quickview turned on, point your mouse cursor at stream 9 on 
the flowsheet. After a moment, a pop‐up information window appears, listing 
stream properties including composition. The value for propane should be 1 or very 
close to 1, as shown in Figure 11‐18. 
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Figure 11-18: Checking the propane content of stream 9 

Now that you have achieved the results that you set out to produce, save the 
simulation, using either File > Save or the Save button on the toolbar. 

Producing a Text Report 
The Report menu offers a broad array of text reports, as described in Chapter 8, 
Output and Reports. For the purpose of this tutorial, assume that you want to view 
and print out a report with the following information: 

• For Streams 1, 5, 8 and 9, the stream composition in mass flow rates and mole 
fractions, as well as the default stream properties 

• The equipment summaries for every piece of equipment in the flowsheet 

• Tower tray profiles for the condensate stabilizer 

Because you want a report with a broad range of information about your 
simulation, use the Consolidated Report option. 

1. Select Report > Consolidated Report to bring up the Consolidated Report 
menu. From here, you can specify exactly what you want to include in your 
report. 

2. Start by specifying which streams you want to include. Click Select Streams 
to open the Select Streams dialog box. 

3. Click the All streams box to clear the default check mark, then type the 
numbers 1, 5, 8, and 9 into stream ID boxes. Click OK to return to the 
Consolidated Report menu. 

4. Now select which UnitOps you want to include. Click Select Unit 
Operations to open the Select UnitOps dialog box. 

5. The Print all UnitOps option is selected by default. In this case, you do want 
to include all UnitOps in the report, so verify that this box is checked and 
then click OK to return to the Consolidated Report menu. 

6. Click Stream Properties to open the Property Options dialog box. Here, you 
can select any combination of items on the General and Crude/Solid tabs to 
determine what stream properties will be included in the report. Checked 
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items will be included by default; to toggle any item on or off, simply click 
the corresponding box. 

For the purpose of this tutorial, use the default settings in this dialog box. 
Click Cancel to close the dialog box and return to the Consolidated Report 
menu. 

7. Click Stream Flowrate/Compositions to open the Flow/Composition Options 
dialog box. Click the checked box next to Mole flow rate to turn off this 
default option. Then, click the Mass flow rate and Mole fractions boxes to 
turn both of those options on. Click OK to save your settings and return to 
the Consolidated Report menu. 

8. Finally, specify which information to print for the condensate stabilizer 
distillation column by clicking Distillation Summaries. In the Distillation 
Options dialog box, the information you’re looking to print—Tray profile—is 
already selected. Click OK to return for the last time to the Consolidated 
Report menu. 

9. To generate the report, click Calculate and Give Results. The report displays 
in a separate window, with a format suitable for printing. You can edit, save, 
and print the report as needed. 

10. When you finish reviewing and working with the report, close the report 
window to return to the main CHEMCAD workspace. 

Generating a Process Flow Diagram 
As you know, the streams and UnitOps on a flowsheet only tell part of the story of 
your process. Fortunately, CHEMCAD provides many features to help you add the 
extra content needed to turn a plain flowsheet into a full‐fledged process flow 
diagram (PFD) for others to review and use. 

To prepare your finished simulation to be printed as a PFD, you’ll add a stream 
databox containing the heat and material balance for the entire flowsheet. You’ll 
place that databox underneath the flowsheet diagram and then add a title to the area 
above the flowsheet. Finally, you will create a new layer in this simulation and 
assign the PFD‐specific items to that layer, so that you can hide them from view 
when working and display them again quickly for printing. 

Follow these steps to prepare and print the PFD: 

1. Start by zooming out to give yourself more workspace. If you use a mouse 
that is equipped with a scroll wheel between the mouse buttons, you can 
point at the center of your flowsheet and roll the scroll wheel down a few 
clicks to zoom out. If you don’t have a scroll wheel, you can select View > 
Zoom Options > Out. 

2. Now place the databox containing the heat and material balance for this 
flowsheet. Select Format > Add Stream Box to bring up the Select Streams 
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dialog box. Because you want to include all streams, leave the settings the 
way they are and click OK to continue. 

3. In the Databox Property Options dialog box, review the default selections, 
indicated by checked boxes. For the purposes of this tutorial, leave the 
selections as they are and click OK to continue. 

4. In the Databox Settings dialog box, you can control the font style and size of 
the databox text, as well as the use of dividing lines within the box. Accept 
the default settings here and click OK. 

5. The stream databox appears in the upper left corner of the CHEMCAD 
workspace, but you want to place it below the flowsheet. The databox is 
already selected, so point your mouse cursor anywhere inside the box and 
then click and drag to reposition it. Move the databox until it is centered 
below the flowsheet diagram. 

Note: You can also resize a databox by selecting the box and then clicking and 
dragging any of the sizing handles at the corners. Drag in to make the databox 
smaller, or out to make it larger; notice that the text adjusts in size to fit the box. 

6. Now place a title on the PFD to describe the process. In the All UnitOps or 
Drawing Symbols palette, find and select the Text tool. 

7. Move the cursor to a point somewhere above the flowsheet and click the 
primary mouse button. A vertical insertion point line begins to blink where 
you have clicked. Type the words Condensate Stabilizer PFD and then click 
any blank spot on the CHEMCAD workspace. 

8. To make this text larger, select Format > Font. In the Font dialog box, change 
the Size setting to 18 and then click OK. 

9. Click and drag the new heading to center it above the flowsheet diagram. 

10. Finally, set up a layer for your stream databox and title so that you can 
display or hide these items as a single unit. At the bottom of the CHEMCAD 
Explorer pane, click the Simulation tab, then right‐click the Layers item and 
select New. 
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Figure 11-19: Creating a new layer using the CHEMCAD Explorer 

11. In the New Layer dialog box, type a name for the new layer. For this 
example, name the layer PFD Elements, then click OK to create the layer. 

12. Now add the two PFD elements to the layer. Click the title that you placed 
above the flowsheet, then hold down the [SHIFT] key and click inside the 
stream databox that you placed below the flowsheet. Both items should now 
be selected, with small black boxes visible in each corner. 

13. In the CHEMCAD Explorer pane, double‐click the Layers item to expand it, 
then right‐click on your newly created PFD Elements layer and click Add 
Selected. 

 
Figure 11-20: Adding selected items to your new layer 

14. The title and stream databox are now part of the PFD Elements layer. This 
layer is visible, as indicated by the green check mark on its icon. Click this 
icon or the name PFD Elements to toggle the layer off, causing the title and 
stream databox to disappear; then click again to make them visible. 

15. With the PFD elements visible, select View > Zoom Options > Zoom to Fit. 
This custom‐fits the entire PFD to the available workspace for optimal 
printing. To print, you can either select File > Print or click the Print button 
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on the main CHEMCAD toolbar. Follow the prompts for your printer to 
complete the printing process.  

16. To close CHEMCAD, select File > Close, or click the Close button in the 
upper right corner of the CHEMCAD window. Click Yes at the message 
asking whether you want to exit CHEMCAD, then click Yes again to save 
changes to the simulation. 
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CC-THERM Tutorial 
This tutorial walks you through the rating of a heat exchanger. The example you’ll 
work with is the condensate stabilizer example described in the CC‐STEADY STATE 
tutorial, which looks like this: 

 
While it’s recommended that a new CHEMCAD user build this simulation from 

the ground up to gain proficiency with the software, a ready‐made example called 
CHEMCAD Tutorial.CC6 is also available. This file is located by default in the 
directory called My Documents\My Simulations\Examples\Tutorials. 

Your objective is to rate the first heat exchanger in this flowsheet. The equipment 
you’re working with is a countercurrent gas/gas heat exchanger with the following 
geometry and dimensions: 

• TEMA class = R 

• TEMA type = BEM 

• Fouling factors = 0.001 both sides 

• Shell inside diameter = 27” 

• Number of tubes = 646 

• Tube outside diameter = 0.75” 

• Tube wall thickness = 0.065” 

• Tube length = 20’ 

• Tube pattern = rotated triangular (60°) 

• Tube pitch = 0.9375” 

• Baffles: 10, equally spaced 

• Baffle type = single segmental 

• Baffle cut = 35% (diameter) 

• Impingement plate present 

• Shell‐side nozzles = one, 12” 
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• Tube‐side nozzles = one, 12” 

• Baffle to shell I.D. clearance = 0.3125” (diameter) 

• Shell I.D. to OTL clearance = 0.35433” (diameter) 

• Tube to baffle hole clearance = 0.035” (diameter) 

• Space at top of bundle = 2.8” 

• Carbon steel tubes; all other materials A‐285‐C 

• 5 rows per sealing strip 

Overview of the Heat Exchanger Sizing Process 
The CC‐THERM module enables you to generate heat curves and specify heat 
exchangers. This process involves the following steps: 

1. Identify the tube‐side stream. 

2. Generate and finalize the heat curve and properties on both sides of the 
exchanger. 

3. Define general information about the exchanger. 

4. Specify any desired tube data. 

5. Specify any desired shell data. 

6. Specify any desired baffle data. 

7. Specify any desired nozzle data. 

8. Specify any desired specific clearances. 

9. Specify the materials used in the construction of the heat exchanger. 

10. Specify any desired miscellaneous data. 

11. Run the sizing calculations. 

12. Review results and create plots as needed. 

Identify the Tube-side Stream 
Once the simulation is complete in CC‐STEADY STATE, you can start sizing the first 
heat exchanger by identifying the tube‐side stream: 

1. Click on the first heat exchanger icon and then select Sizing > Heat 
Exchangers > Shell & Tube. 

2. A message box prompts you to select a stream entering the exchanger’s tube 
side. Click OK to continue. 

3. At the Select Streams dialog box, either type 1 or click stream 1 on the 
flowsheet, then click OK. 
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4. CC‐THERM displays data for all four streams around the exchanger in a 
separate report window. Review or print the data as needed and then close 
the report window. 

Generate the Heat Curve 
Once the tube‐side stream is identified, CC‐THERM prompts you through the setup 
of the heat curve. The Heat Curve Parameters dialog box displays as soon as you 
close the report from the previous step. 

 
Figure 11-21: The Heat Curve Parameters dialog box 

To account for the change in physical properties across the heat exchanger, CC‐
THERM divides the analysis into zones. These zones are thermodynamic segments 
based on equal temperature changes or equal enthalpy increments. There are two 
options to choose from: 

• Equal enthalpy: Increments of equal enthalpy change 

• Bubble‐dew point: Increments of equal enthalpy change between the dew 
and bubble points, with separate zones for superheating and subcooling if 
present 

The default setting is the bubble‐dew point option. For either segmentation 
method, you can also decide how many zones to calculate for the exchanger. The 
more zones you specify, the more accurate the calculations will be, but calculations 
will also be slower. The industry standard is 10 zones (11 points), which is the 
default entry here, but you can select any number by making an entry in the 
Number of cutting points field. Bear in mind that the number of points equals the 
number of zones plus one. 

For this tutorial, leave all the default settings and click OK to continue. CC‐
THERM calculates the 11 points needed for the heat curve and displays a plot like 
the one shown in Figure 11‐22. 
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Figure 11-22: Heat curve plot for first heat exchanger 

This plot enables you to inspect the calculated heat curve for any obvious 
problems in the setup of the analysis. Click OK to close this window and continue. 

Define General Specifications 
The next dialog box to appear is called General Specifications. Here, you can provide 
basic information governing heat exchanger calculations, such as process type, 
allowable pressure drop, fouling factor, TEMA class and type, and so forth. 

This dialog box has two tabs, and most of the fields on both tabs have default 
settings. The tab that initially displays is called General Information, and it includes 
the following settings: 

• Calculation mode: This entry determines whether you are designing or 
rating a heat exchanger. Use the default setting of Rating. 

• TEMA class/standard: This entry specifies the exchanger’s TEMA class, 
which is primarily a function of its mechanical details. Use the default setting 
of TEMA R. 

• Orientation: This entry specifies whether the exchanger is mounted 
horizontally or vertically. Use the default setting of Horizontal. 

• TEMA front end head, TEMA shell type, and TEMA rear end head: To 
establish the basic configuration of the exchanger, you must define these 
characteristics of the exchanger according to TEMA designations. The 
simplest and most common kind of exchanger is a fixed tubesheet, or BEM, 
TEMA type. Select B ‐ Bonnet for the front head, E ‐One Pass for the shell 
type, and M ‐ Fixed Tubesheet (B head) for the rear head. 

• Process type: In some cases, you must identify the process type, for example 
in the case of pool boiling or falling‐film condensation. In this case, use the 
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default selection of Sensible Flow for both tube side and shell side, as there 
is no phase change on either side of the exchanger. 

• Fouling factor ‐ To allow for fouling on the inside and outside of the tube, 
you can enter fouling factors. Use the default setting of 0.001 (English units) 
on both sides. 

On the Modeling Methods tab, you can select the formulas to be used in certain 
aspects of the heat exchanger calculations. For the purposes of this tutorial, use the 
program’s default selections. Click OK to continue. 

Set Tube Specifications 
The Tube Specifications dialog box now appears, populated with default entries in 
all fields. 

 
Figure 11-23: The Tube Specifications dialog box 

Enter 646 in the Number of tubes field and click OK to continue. 

Set Shell Specifications 
The next dialog box to appear is called Shell Specifications. 

 
Figure 11-24: The Shell Specifications dialog box 
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The only value that you need to specify here is the shell diameter. Unless you 
check the Use standard pipe as shell box, CC‐THERM assumes that the value 
entered here is the actual shell inside diameter. Type 2.25 (the equivalent in feet to 
27”) in the Shell diameter field and then click OK to continue. 

Note: The CHEMCAD suite has a handy built‐in conversion feature that can help 
when input fields require a different unit of measure than the data you have. Place 
your cursor in any numeric data entry field, and then press [F6] to bring up a dialog 
box that offers conversion units relevant to the selected field. Type the value you 
have in the appropriate field and press [ENTER] to convert to other units. Verify the 
results of the conversion and then click OK. CHEMCAD automatically selects the 
appropriate units for the field and enters that converted value. 

Set Baffle Specifications 
The Baffle Specifications dialog box displays next. 

 
Figure 11-25: The Baffle Specifications dialog box 

Most of the default entries here are appropriate for this example; you do, 
however, need to specify the baffle spacing and baffle cut. 

Baffle Spacing 
All that you know for the purposes of baffle spacing is that there are 10 baffles 
equally spaced. Erase any default values for spacing and enter 10 in the Number of 
baffles field. CC‐THERM will calculate equal spacing for the baffles. 

Baffle Cut Percent 
The baffle cut percent can be based either on diameter or on area. The Basis of cut 
field identifies the basis for the specified cut; use the default setting of Diameter, and 
enter 35 in the Baffle cut percent field. Click OK to continue. 

Set Nozzle Specifications 
The Nozzle Specifications dialog box now appears. 
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Figure 11-26: The Nozzle Specifications dialog box 

The default entries are acceptable for this example, so you only need to enter the 
inside diameter for the inlet and outlet nozzles on both the tube and shell sides. All 
of these nozzles have 1’ internal diameters. 

Enter 1 in each of the four fields at the top of the dialog box, then click OK to 
continue. 

Set Clearance Specifications 
You will now see the Clearance Specifications dialog box. 

 
Figure 11-27: The Clearance Specifications dialog box 

CC‐THERM always defaults to TEMA clearances, so normally no entry is 
required in this dialog box. In this case, the clearances are known, so you should 
enter them in the event they do not conform exactly to TEMA. You can use the [F6] 
feature noted earlier in this tutorial to convert the given clearances from inches to 
feet. 

Also, because there is an impingement plate, you need to enter the space at the 
top of the bundle. Type 0.233333 in the Space at Top of Bundle field and then click 
OK to continue. 
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Set Material Specifications 
The next dialog box to appear is called Material Specifications. 

 
Figure 11-28: The Material Specifications dialog box 

Here, you can specify the materials of construction for the heat exchanger. For 
this example, use the default entries: carbon steel for the tubes and A‐285‐C for all 
other materials. Click OK to continue 

Set Miscellaneous Specifications 
The last dialog box to appear is called Miscellaneous Specifications. 

 
Figure 11-29: The Miscellaneous Specifications dialog box 

The only field that is important to this example is Rows per Sealing Strip. The 
default entry of 5 is what the example calls for, so leave the dialog box as it is and 
click OK to continue. 

Run Sizing Calculations 
Now that you have specified heat exchanger data in all of the required dialog boxes, 
the Shell and Tube Exchanger menu appears. Note that this menu is what you will 
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see if you return to shell and tube sizing for this exchanger at any time after this 
initial specification. 

 
Figure 11-30: The Shell and Tube Exchanger menu 

Click the Calculate button on the menu. The calculation will run very fast, 
showing runtime messages on the status bar and then returning you to the Shell and 
Tube Exchanger menu. 

Review Results and Create Plots 
Now that calculations are complete, you can click the View Results button to see the 
result of the heat exchanger calculations. The View Results menu will appear. 

 
Figure 11-31: The View Results menu 

Click any of these buttons to view various reports on everything from baffle 
parameters to vibration analysis. When you select a report, the data displays in a 
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separate window, which you can review or print and then close. To return to the 
Shell and Tube Exchanger menu at any time, click the Exit button. 

You can also display results graphically by clicking Plot. This opens the Plot 
menu, from which you can select a variety of zone‐by‐zone graphs. 

 
Figure 11-32: The Plot menu 

These plots open in a plot window, just like the heat curve plot that you we saw 
at the beginning of this tutorial. When you click OK to close any plot, you will return 
to the Shell and Tube Exchanger menu. 

You can also print tabulated, hard‐copy reports using the Select Reports and 
Generate Reports options on the Shell and Tube Exchanger menu. First, click Select 
Reports to bring up the Report Selection dialog box. 

 
Figure 11-33: The Report Selection dialog box 

Select either WordPad or Excel as your report viewer, and check the boxes for the 
reports that you want to generate. Click OK to return to the Shell and Tube 
Exchanger menu, then click Generate Reports. All of the reports that you selected 
will be generated and displayed using the viewer that you chose. 

You can now review or print the report; when you close the report window, you 
will return to the Shell and Tube Exchanger menu. Click Exit to close the menu, then 
click Yes when asked whether you want to save your changes. 
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CC-BATCH Tutorial 
This tutorial walks you through the process of using CC‐BATCH to simulate a batch 
distillation column. 

Description of the Problem 
The simulation you will create is a five‐step batch distillation campaign, as 
illustrated in Figure 11‐34. The objective is to separate 100 lb•mol of mixed propane, 
butane, pentane, and hexane into three separate tanks, producing 99% pure butane. 

 
Figure 11-34: The batch distillation flowsheet 

The following are detailed specifications for this problem: 

Thermodynamic Selections 
• K-value: Peng‐Robinson 
• Enthalpy: Peng‐Robinson 
 

Column Specifications 
• No. of internal stages: 8 
• No. of operations: 5 
• Internal stage holdup: 0.01 ft3  
• Condenser holdup: 0.1 ft3 
• Condenser pressure: 14.7 psia 
• Column pressure drop: 2 psia 
 

Initial Charge Conditions 
• Temperature: Calculated 
• Pressure: 16.7 psia 
• Vapor Fraction: 0 at bubble point 
• Total amount of charge: 

100 lb•mol 

Initial Charge Composition (mole frac) 
• Propane: 0.1 
• N-Butane: 0.3 
• N-Pentane: 0.1 
• N-Hexane: 0.5 
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Operating Step 1 
• Purpose: Propane removal 
• Reflux ratio: 5 
• Distillate molar flow rate: 2 
• Stop when: Distillate mole 

fraction of N‐Butane is 0.2 
• Materials to be added at start: 

None 
 

Operating Step 2 
• Purpose: Propane removal 
• Reflux ratio: 20 
• Distillate molar flow rate: 2 
• Stop when: Distillate mole fraction of 

N‐Butane is 0.985 
• Materials to be added at start: None 

Operating Step 3 
• Purpose: Butane production 
• Reflux ratio: 25 
• Distillate molar flow rate: 2 
• Stop when: Accumulator mole 

fraction of N‐Butane is 0.99 
• Materials to be added at start: 20 

lb•mol of mole fraction 40% N‐
Butane/60% N‐Hexane, at its 
bubble point at 16.7 psia 

 

Operating Step 4 
• Purpose: Pentane removal 
• Reflux ratio: 15 
• Distillate molar flow rate: 2 
• Stop when: Distillate mole fraction of 

N‐Hexane is 0.2 
• Materials to be added at start: None 
 

Operating Step 5 
• Purpose: Pentane removal 
• Reflux ratio: 25 
• Distillate molar flow rate: 2 
• Stop when: Bottom mole fraction 

of N‐Hexane is 0.9998 
• Materials to be added at start: 

None 

 

Overview of the Batch Distillation Process 
The process of building the flowsheet and simulating the batch distillation involves 
the following steps: 

1. Create a new simulation. 

2. Select engineering units. 

3. Draw the flowsheet. 

4. Select the components. 

5. Select thermodynamic options. 
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6. Specify pot charge. 

7. Specify the distillation column. 

8. Define operating steps. 

9. Run the simulation. 

10. Review the results and print as needed. 

Creating a New Simulation 
Start by creating a new simulation and giving it a name. 

To do this, launch CHEMCAD and then Select File > Save to open the Save As 
dialog box. Navigate to the directory where you want to store the simulation (try My 
Simulations, located under My Documents) and give your simulation a name, 
leaving the type as CHEMCAD 6 (*.cc6). Then click Save to create the file and return 
to the main CHEMCAD window. 

Selecting Engineering Units 
Select Format > Engineering Units to open the Engineering Unit Selection dialog 
box. 

The English units option is the default and is currently highlighted. To change 
the engineering units system, you would click the Alt SI, SI, or Metric button; you 
could then change any of the individual units as well. For this tutorial, you will use 
English units, so click Cancel to exit this dialog box without making changes. 

Drawing the Flowsheet 
As described in Chapter 5, creating a flowsheet is a matter of placing UnitOp icons 
on the screen, connecting them with streams, and then adding various graphical 
objects to enhance the drawing. 

Placing UnitOps 
Begin by placing the Batch Column unit on the screen. 

1. On the All UnitOps palette, click the Batch column tool (see Figure 11‐35) 
and then click in the main CHEMCAD workspace. The batch column icon 
appears where you clicked. 

 
Figure 11-35: The icon representing a batch column 

2. Click the Tank tool (see Figure 11‐36). On the workspace, click to the right of 
the batch column to place a tank icon. Then click just below the first tank, and 
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click again below the second tank. When you have placed all three tanks on 
the flowsheet, right‐click to deactivate the Tank tool. 

 
Figure 11-36: The tank icon 

3. Click the Product tool (see Figure 11‐37) and in similar fashion, place three 
product arrows on the flowsheet, each one below and to the right of a tank 
icon. Right‐click to deactivate the Product tool. 

 
Figure 11-37: The product icon 

Drawing Streams 
Now that all of the UnitOps are in place, select the Stream tool and connect each 
tank’s outlet to the nearest product arrow. These are the only streams that you need 
for this tutorial. 

Note: In this simulation, the batch distillation column transfers products to the tanks 
based upon batch operation parameters that you provide. Stream connections 
between the column and the tanks are not necessary, and are ambiguous given the 
dynamic nature of such streams. 

Remember that each stream must start at a red outlet point on the upstream 
UnitOp, and end at a blue inlet point on the downstream UnitOp. To avoid having to 
re‐select the Stream tool each time, make sure that as soon as you click to complete 
one stream, you move the cursor to the next location and click to start the next 
stream. 

As you draw streams, CHEMCAD assigns stream IDs, just as it assigned UnitOp 
IDs when you created those items. The labels for stream IDs are displayed in 
squares, to distinguish them from the UnitOp IDs displayed in circles. 

At this point, the flowsheet should look similar to Figure 11‐34. 
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Selecting Components 
Now you need to identify the components to be used in this simulation. Start by 
selecting Thermophysical > Select Components. 

For this example, you’ll choose components from the standard CHEMCAD 
database. In the Select Components dialog box, find and add each needed 
component. 

1. Hold down the [CTRL] key on your keyboard as you click each of the 
following components in turn: 

• 4  Propane 

• 6  N‐Butane 

• 8  N‐Pentane 

• 10  N‐Hexane 

2. Click the right arrow button, located to the right of the Available Components 
area, to add all of the selected components to your simulation. The Select 
Components dialog box should now look like Figure 11‐38. 

 
Figure 11-38: The completed Select Components dialog box 

3. Save your component selections by clicking OK. 

Selecting Thermodynamic Options 
As soon as you have finished component selection, the Thermodynamics Wizard 
appears. This tool can suggest thermodynamics options to use with this simulation. 

CHEMCAD’s Thermodynamics Wizard works like this:  

1. First, it looks at the component list and decides what general type of model is 
required, i.e., equation‐of‐state, activity model, etc. 

2. Second, it looks at temperature and pressure ranges that you provide and 
decides which equation within a given category is best at the limits of those 
ranges. 
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3. If the method is an activity model, the program then looks at the BIP 
database to see which model has the most data sets for the current problem. 
It then calculates the fractional completeness of the BIP matrix. If that fraction 
is greater than the BIP threshold parameter, it uses the chosen activity 
method; if not, it uses UNIFAC. 

The Thermodynamics Wizard is no replacement for engineering judgment. This tool 
uses an algorithm based on general rules, and is therefore fallible. The suggested 
model might not always be the best model for the system.  

Selecting thermodynamic options basically means selecting a model or method 
for calculating vapor‐liquid (or vapor‐liquid‐liquid) phase equilibrium (called the K‐
value option) and selecting a method or model for calculating the heat balance (called 
the enthalpy option). The commands for these selections are located on the 
Thermophysical menu. 

CHEMCAD has a library of dozens of K‐value models with a variety of options 
and about 12 enthalpy models. Making the proper selection from these libraries can 
sometimes be difficult. For the purposes of this tutorial, assume that you want to use 
the Peng‐Robinson method for both the K‐value and enthalpy calculations. Follow 
these steps to select your thermophysical options: 

1. Accept the default temperature and pressure ranges in the Thermodynamics 
Wizard and click OK. 

2. Click OK again to accept the wizard’s suggested method of SRK. 

3. When the Thermodynamic Settings dialog box opens, find the Global K‐
Value Option selection, in the upper left corner of the K‐Value Models tab. 
The current setting is SRK, but for the purposes of the tutorial, you’ll need to 
select the Peng‐Robinson model. Click the down arrow at the right end of the 
selection box to view a long list of K‐value choices, then click Peng‐
Robinson. 

 
Figure 11-39: The new K-value selection in the Thermodynamic Settings dialog box 
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4. Now click the Enthalpy Models tab. The Peng‐Robinson method has already 
been entered as the Global Enthalpy Options selection; this was done 
automatically because you chose Peng‐Robinson as your K‐value method. 
While you do have the option to override this choice, in this case you’ll need 
to keep the Peng‐Robinson model; leave all settings as they are and click OK 
to return to the main CHEMCAD workspace. 

For the purpose of this tutorial, the thermodynamic selections are now complete. 

Note: While you are not required to use the Thermodynamics Wizard, you should 
know how to use it, if only as a starting point for your simulations. You can revisit 
the wizard at any time by selecting Thermophysical > Thermodynamics Wizard.  

Specifying Pot Charge 
Now that you have thermodynamics and components defined for this simulation, 
and you have a batch column in the flowsheet, you can define the pot charge for the 
column. 

You will specify the pot charge according to the following rules: 

• The Temp F, Pres psia, Vapor Fraction, and Enthalpy MMBtu/h fields are 
the thermodynamic properties of the charge. According to the Gibbs Phase Rule, 
once a mixture’s composition is given, specifying any two of these four 
thermodynamic properties will define the other two. As such, defining the 
composition, temperature, and pressure for a mixture uniquely defines its 
vapor fraction and enthalpy. Alternatively, defining the composition, 
pressure, and enthalpy will uniquely define the mixture’s temperature and 
vapor fraction. 

Since enthalpies are calculated relative to a datum, the calculation of any 
given enthalpy is an involved process which is prone to errors. For this 
reason, CHEMCAD does not permit you to enter enthalpy as a constraint. 

In addition to defining the pot composition, you must define exactly two of 
the following properties: temperature, pressure, and vapor fraction. The two 
variables that you specify will display as red text, while the third variable 
and the value enthalpy will be displayed in black when you flash the charge. 

• The Total flow unit and Comp unit fields work together to provide a variety 
of ways to define charge composition. If the selected comp unit is mole, mass, 
or volume fraction (either globally or locally), then the Total flow unit 
selection is available. If the selected comp unit is an amount option, then the 
total charge becomes the sum of the component quantities, and the Total 
flow unit selection is not available. 

• If the Comp unit field selection is an amount unit (as opposed to a fractional 
unit), then the component charge values are automatically added as you 
enter them. The current sum is displayed in the Total flow field. 
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• You can click the Flash button at any time to perform a flash calculation 
using the currently specified composition and thermodynamic properties. 
This enables you to obtain flash calculations quickly and without leaving the 
dialog box. 

• Fractions that do not add up to 1.0 are automatically normalized when you 
either click Flash or exit the dialog box. 

With these rules and behaviors in mind, enter the data for your pot charge: 

1. Double‐click the batch column to open the Edit Batch Charge dialog box. 

 
Figure 11-40: The Edit Batch Charge dialog box 

2. In the Pres psia field, type 16.7, then press [TAB] and type 0 in the Vapor 
Fraction field. 

Note: It’s important that you actually type a 0 over the existing 0 entry in the Vapor 
Fraction field. This tells CC‐BATCH that you are choosing to specify a vapor 
fraction. 

3. In the Comp unit field, select mole frac. You can now type a value of 100 in 
the Total flow field.   

4. Type 0.1 in the Propane field, and then in similar fashion, type the following 
numbers in the corresponding fields: 

• N‐Butane: 0.3 

• N‐Pentane: 0.1 

• N‐Hexane: 0.5 

5. Click OK to save this charge information and continue. 
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Specifying the Distillation Column 
When you have specified the pot charge, CC‐BATCH displays the Batch Distillation 
Column dialog box. 

 
Figure 11-41: The Batch Distillation Column dialog box 

Make the following entries on the General tab of this dialog box: 

• Number of stages: 8 

• Number of operation steps: 5 

• Stage holdup: .01 

• Condenser holdup: 1 

• Cond pressure: 14.7 

• Colm pres drop: 2 

When you have entered these parameters, click OK to save the data and 
continue. 
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Defining the Operating Steps 
When you have completed the initial column specification, the Batch Operation 
Parameters dialog box appears. 

 
Figure 11-42: The Batch Operation Parameters dialog box 

In this dialog box, you’ll define the parameters for each operating step of the 
batch campaign. Before you begin, you need to understand how CC‐BATCH handles 
tank assignments. 

The Product assignment fields identify the accumulator to which a product or 
decant stream will be sent. You can use this option even if you do not place tanks on 
the flowsheet; simply designating a UnitOp ID number is sufficient. In this case, it’s 
important that you designate a UnitOp ID that is not already in use.  

Since CC‐BATCH permits vapor‐liquid‐liquid distillation, there may be two 
liquid phases in the condenser, possibly giving rise to decanting of one phase or the 
other. The Distillate Tank # field entry represents the tank that accumulates the 
distillate. The Decanter Tank # field entry represents the tank that accumulates the 
decanted liquid, if any. 

Operating Step 1 
For operating step 1, make the following entries in the Batch Operation Parameters 
dialog box: 

• Change the Startup option field to 1 Start with total reflux. 

• In the Product assignment area, enter 2 in the Distillate tank # field. 

• In the First spec value field, enter 5 as the value of the reflux ratio. 

• In the Second spec value field, enter 2. 
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• In the Operation step stop options area, set the Stop when option to Distillate, 
set the Measured variable option to Mole fraction, and enter 0.2 in the Stop 
value field. In the Component field that now appears, select 2 N‐Butane. 

• In the Min. runtime field, enter 0.5. 

When you have made these entries, click OK to move on to the next operating 
step. 

Operating Step 2 
For operating step 2, make the following entries in the Batch Operation Parameters 
dialog box: 

• Enter 2 in the Distillate tank # field. 

• Enter 20 in the First spec value field and 2 in the Second spec value field. 

• Stop the operation when the mole fraction of N‐Butane in the distillate is 
0.985. 

When you have made these entries, click OK to move on to the next operating 
step. 

Operating Step 3 
Follow these steps for operating step 3: 

1. Make the following entries in the Batch Operation Parameters dialog box: 

• Enter 3 in the Distillate tank # field. 

• Enter 25 in the First spec value field and 2 in the Second spec value field. 

• Stop the operation when the mole fraction of N‐Butane in the 
accumulator is 0.99. 

2. Click the Additional Settings tab. Here you will specify the addition of 20 
moles of mixture to the pot, with a composition of 40% butane and 60% 
hexane. Check the Add material to pot box and then click OK to bring up the 
Edit Batch Charge dialog box. 

3. In the Pres psia field, type 16.7, then press [TAB] and type 0 in the Vapor 
Fraction field. 

4. Enter the following composition settings: 

• Set the Comp unit field to mole frac. 

• Enter 0.6 in the N‐Butane field. 

• Enter 0.4 in the N‐Hexane field. 

• Enter 20 in the Total flow field. 

5. Click OK to continue to the next operating step. 
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Operating Step 4 
For operating step 4, make the following entries in the Batch Operation Parameters 
dialog box: 

• Enter 4 in the Distillate tank # field. 

• Enter 15 in the First spec value field and 2 in the Second spec value field. 

• Stop the operation when the mole fraction of N‐Hexane in the distillate is 0.2. 

• In the Min. runtime field, enter 0.5. 

When you have made these entries, click OK to move on to the final operating 
step. 

Operating Step 5 
For operating step 5, make the following entries in the Batch Operation Parameters 
dialog box: 

• Enter 4 in the Distillate tank # field. 

• Enter 25 in the First spec value field and 2 in the Second spec value field. 

• Stop the operation when the mole fraction of N‐Hexane in the residual 
charge at the bottom of the column is 0.9998. 

• In the Min. runtime field, enter 0.5. 

When you have made these entries, click OK to continue. 

The Run Time Information Dialog Box 
At the completion of the last operating step, the Run Time Information dialog box 
displays. Here, you can choose which variables will be plotted when you run the 
simulation. 

 
Figure 11-43: The Run Time Information dialog box 
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For this example, the default display—a plot of distillate mole fractions for all 
four components—is what you want, so click OK to bring up the Batch Distillation 
menu. 

 
Figure 11-44: The Batch Distillation menu 

This menu provides access to the entry screens for all defined operation steps, as 
well as options for inserting, deleting, and copying operation steps. You might want 
to review the operating steps and verify your entries before running the simulation. 
When you are finished, click the Exit button to close the menu. 

Running the Simulation 
To run the simulation, click the Run All toolbar button. CC‐BATCH first checks the 
input data for errors or omissions. You may see the following types of messages: 

• Error messages must be fixed before the simulation can proceed. Under‐
specification of the batch column would be an example of this type of error. 

• Warning messages are usually input omissions, which may or may not cause 
problems upon execution. These are non‐fatal errors that do not necessarily 
need to be corrected prior to simulation. 

Assuming that you correctly specified the pot charge and subsequent operation 
steps, you should see no messages; the program will proceed directly to the 
calculation. 

You will see the distillate mole fractions plotted on the screen in a plot window. 
Each time the program proceeds to the next operating step, a new plot window will 
open, along with a new tab at the bottom of the main CHEMCAD workspace. 
During the run, only the current step’s plot is visible. When the simulation is 
finished, the dynamic plot will quit scrolling and a Run finished message will appear 
at the far left end of the CHEMCAD status bar. 

After the run, you can view the plot for a particular operating step by clicking 
the corresponding tab at the bottom of the CHEMCAD workspace. To close any 
plot’s tab, click the Close button (marked with an X) on the tab. To close all of the 
plot tabs at the same time, select Window > Close All Charts. 
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Reviewing and Printing Results 
Once the simulation is complete, you can review the results interactively before 
printing a hard copy. The commands needed to do this are located in the Report and 
Plot menus. 

Plotting the Results 
For batch calculations, the most convenient way to examine the output is to plot the 
results. To do this, click your batch column UnitOp and then select Plot > Dynamic 
Plots > Batch Column History. 

This brings up the Batch Column Plots dialog box. From here, you can generate a 
plot that encompasses the entire campaign. For example, you can follow these steps 
to plot distillate mole fractions across all operating steps: 

1. In the Plot variable field, select the 0 Mole fractions option. 

2. In the Of the field, select the 3 Distillate option. 

3. In the Components to plot area, use the first four fields to select the four 
components found in the distillate. 

 
Figure 11-45: The completed Batch Column Plots dialog box 

4. Click OK to view the composite plot, which should resemble Figure 11‐46. 
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Figure 11-46: Composite plot showing composition of distillate over time 

Review or print the results as needed, and then close the plot tab to return to the 
simulation. 

Generating Text Reports 
You can also view certain batch results in tabular format. To do this, select Report > 
Batch Results. A summary of the results of this simulation displays in a separate 
window. Review or print the results as needed, and then close the report window to 
return to the main CHEMCAD window. 

Generating a Full Report 
The Report menu offers a broad array of text reports, as described in Chapter 8, 
Output and Reports. For the purpose of this tutorial, assume that you want to view 
and print out a report with the following information: 

• Operating step results 

• Batch column history 

• Final batch column holdup 

Because you want a report with a broad range of information about your 
simulation, use the Consolidated Report option. 

1. Select Report > Consolidated Report to bring up the Consolidated Report 
menu. 

2. Click Batch/Dynamic Results to open the Batch/Dynamic Options dialog 
box. Select the first three options Print operation results, Print history, and 
Print final holdups. 
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Figure 11-47: The Batch/Dynamic Options dialog box 

3. Click OK to return to the Consolidated Report menu. 

4. To generate the report, click Calculate and Give Results. The report displays 
in a separate window, with a format suitable for printing. You can edit, save, 
and print the report as needed. 

5. When you finish reviewing and working with the report, close the report 
window to return to the main CHEMCAD workspace. 
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Piping Tutorial 
A piping network represents the flow of fluids through several pieces of equipment. 
If sufficient variables (flow rate and pressure) are specified on the piping network, 
CHEMCAD calculates the unknown variables. 

For fluid flow through equipment, flow rate may be calculated as a function of 
the inlet and outlet pressure. If you know any two of these three variables, 
CHEMCAD can calculate the third. 

In this tutorial, you will work with CHEMCAD’s piping features. You will 
perform control valve and orifice sizing and rating; simulate complex piping 
networks; use feedback controllers; calculate NPSH; and make appropriate 
equipment selections. 

Control Valve Sizing Example 
This portion of the piping tutorial covers control valve sizing, control valves, and the 
use of nodes. 

Problem Statement 
For this part of the tutorial, reference the flowsheet shown in Figure 11‐48. This 
example is called Example 1, and it’s located in the My 
Simulations\Examples\Piping folder.  

D-1
-9F
225 psig

D-2
-1F
15 psig

D-3
-28F
0.2 psig

 
Figure 11-48: Diagram of control valve sizing example  

You need to size control valves for handling a flow of 113,000 lb/hr of liquid 
ammonia in each line coming from vessel D‐1. You must select properly‐sized valves 
and then determine the percent open for each valve at the rated service. 

To perform the initial sizing, all you need are streams with the correct properties 
(see Figure 11‐49). It is not necessary to model the tanks. 
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1
1 2

3

 
Figure 11-49: Streams for initial sizing 

All three streams in Figure 11‐49 are at the inlet conditions of ‐9° F and 225 psig. 
The divider splits the 226,000 lb/hr flow into two equal flows of 113,000 lb/hr of 
ammonia. 

To perform the initial sizing, follow these steps: 

1. Click the Run All button on the main CHEMCAD toolbar to calculate the 
flow information for streams 2 and 3. Both streams should be at ‐9° F, 225 
psig, and 113,000 lb/hr of ammonia. 

2. Click stream 2 to select it. The stream is selected when it is shown bracketed 
by black squares. Select Sizing > Control Valve to bring up the Control Valve 
Sizing dialog box. 

 
Figure 11-50: The Control Valve Sizing dialog box 

3. In the Downstream pressure field, enter 15. Click OK to display a control 
valve sizing report in a separate window. CHEMCAD reports the properties 
of the stream and the calculated parameters for the valve. 

4. Repeat the procedure for stream 3, using a downstream pressure of 0.2 psig. 

Rating Case 
The next task is to rate these valves in a simulation. You need to determine the valve 
position for these valves in this service at 113,000 lb/hr. Since this task models the 
behavior of the control valves, you will need a slightly larger flowsheet, as shown in 
Figure 11‐51. 
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Figure 11-51: Flowsheet for rating valves in a simulation 

The flash UnitOps at the end are not necessary; they are included to illustrate the 
vapor and liquid flow rates in separate streams if flashing occurs.  

The divider is still set to 113,000 lb/hr, and the flash tanks are set to the mode 
called Specify T and P; calculate V/F and Heat. Flash UnitOp #2 is set to ‐1° F and 15 
psig. Flash UnitOp #3 is set to ‐28° F and 0 .2 psig. 

Follow these steps to rate the control valves: 

1. Double‐click the icon for control valve #4 to open the Control Valve dialog 
box. 

 
Figure 11-52: The Control Valve dialog box 
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2. In the Valve flow coefficient (Cv) field, enter 36. In the Downstream 
pressure field, enter 15. Select the Operating mode option called Fix 
flowrate, adjust valve position. Click OK. 

3. Now double‐click the icon for control valve #5. For this valve, select the same 
operating mode that you used for valve #4. Specify a valve flow coefficient of 
54 and a downstream pressure of 0.2 psig, and then click OK. 

4. Click the Run All button on the toolbar to run the simulation. 

5. To view the results, first click a blank area of the CHEMCAD workspace to 
ensure that no UnitOps are currently selected. Then select Report > UnitOps 
> Select UnitOps. 

6. In the Select UnitOps dialog box, type 4, press [RETURN], and then type 5. 
Click OK to bring up a report for these two valves. 

The report shows that valve #4 is at 72.5% open, and valve #5 is at 53.3% open. 

To see how much vaporization occurs across valve #5, right‐click the valve and 
select View Stream Properties. This volume change is why CHEMCAD chose a 
larger valve for the second stream. With the vaporization occurring in the valve, a 
smaller two‐inch valve body would be approaching sonic velocity through the valve 
body. 

Flow Rate as a Function of Pressure 
In typical CHEMCAD simulations, information flows in one direction: downstream. 
Upstream conditions determine the downstream conditions. In most simulations, 
you simply set the flow rates and pressures of feed streams. Pressure drops are 
either calculated based on flow or specified through UnitOps, and the downstream 
pressures, flow rates, and so forth are calculated when you run the simulation. 

For piping simulations, flow rate and pressure are dependent on each other. The 
backpressure on valves, pipes, and other UnitOps affects the flow rate through the 
valve. Likewise, the flow rate through a valve (or through a pipe or a pump) 
determines the downstream pressure. 

In flow models like the control valve sizing model, it is sometimes useful to let 
flow rate vary as a function of the pressure. For example, suppose a process upset in 
the system shown in Figure 11‐53 caused the pressure in vessel D‐2 to rise from 15 
psig to 30 psig. Assuming the upset occurs faster than the valves react, what is the 
new flow rate from D‐1? 
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D-1
-9 F
225 psig

D-2
-1 F
30 psig (UPSET condition)

D-3
-28F
0.2 psig

Cv=36
72.5 % open

Cv=54
53.3% open

 
Figure 11-53: Vessel D-2 in an upset condition 

To answer this question, you need a special UnitOp called a node. A node is a 
point in the simulation that has a pressure, a flow coming in, and a flow going out. 
The node units create a network, solving for flow rate at each point based on the 
fixed pressures. Nodes are placed on the flowsheet immediately upstream and 
downstream from each control valve. Figure 11‐54 shows the system with nodes in 
place. 
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Figure 11-54: Nodes located upstream and downstream from control valves 

The function of the divider—to split the incoming flow—is now handled by node 
#6. The node will balance the flow rates so that all streams entering and exiting the 
node are at the same pressure. Nodes are also placed between the flash vessels and 
the control valves. At the nodes you can fix the pressures, and let the flow rate vary 
as a function of valve position and pressure difference. 

To see how these nodes are set up, you can double‐click node #6 to open the 
Node dialog box. 
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Figure 11-55: The Node dialog box 

The fixed pressure at this node is 225 psig. The inlet flow mode is set to Free inlet 
stream, and the two outlet streams are set to Flow set by UnitOp. The flow into each 
control valve will be determined by the control valve opening position and the 
pressure difference across the valve. 

For node #9, the fixed pressure is set to 30 psig, and for node #10, the pressure is 
0.2 psig. Flow into each of these nodes is controlled by the control valve using the 
Flow set by UnitOp mode; flow out is set to Free Outlet stream. 

The control valves need to be changed to fix the valve position and calculate flow 
rate. To do this, set the Operating mode for each valve to Fix valve position, adjust 
flowrate. 

After making this change, click the Run All toolbar button to run the simulation. 
After running, you can view the streams around node #6 by right‐clicking the node 
and selecting View stream composition. The resulting report (Figure 11‐56) shows 
that the flow rate for stream 11 (upstream from D‐2) has dropped from 113,000 lb/hr 
to 109,138 lb/hr. This illustrates the effect of backpressure on the flow rates through 
the valves. 

 
Figure 11-56: Stream composition report for node #6 
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Simple Flow Example 
This portion of the piping tutorial covers control valve sizing, feedback controllers, 
NPSH, orifice sizing/rating, pipe sizing/rating, and the Pipe UnitOp. 

Problem Statement 
The piping system shown must be designed to transport 120 gpm of glacial acetic 
acid at 70‐140° F. The pressure at the inlet is known at 20 psia, and the outlet must be 
no less than 20 psia. The piping system and its individual elements must be sized for 
design conditions and then rated at operating conditions. The goal is to determine 
the NPSHa and head requirements for future pump selection. 

 
Figure 11-57: Piping isometric for this problem 

This example is called Example 2, and it’s located in the located in the My 
Simulations\Examples\Piping folder. 

Creating the Simulation 
Follow these steps to create and run this simulation: 

1. Convert the piping isometric in Figure 11‐57 to a CHEMCAD flowsheet. Pipe 
UnitOps are used to represent entire sections of piping, including fittings: 

2. Select Sizing > Piping and select the applicable streams to bring up the Pipe 
Sizing dialog box. 
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Figure 11-58: The Pipe Sizing dialog box 

3. Select the Typical sizing for single phase option and use standard schedule 
40 pipe. Click OK to view a line sizing report for the selected stream. 

Note: Since the fluid in this system is sub‐cooled liquid and all flows are constant, 
this calculated line size should apply to all piping in the system. The exception is the 
pump suction pipe, which as a general rule should be one size larger. 

4. Select Sizing > Orifice and select the stream on the discharge side of the 
pump. In the Orifice Sizing dialog box, select D and D/2 pressure taps, enter 
3 as the pipe inside diameter, and enter 100 as the water differential pressure. 
Click OK to bring up an orifice sizing report for the selected stream. 

Note: Using the calculated bore hole, CHEMCAD determines the flow resistance 
factor of the orifice as shown: 
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The orifice sizing report gives the Kr value, which you will use later in the Pipe 
Sizing and Rating dialog box. 

5. To size the control valve, select stream #1 and then select Sizing > Control 
Valve. In the Downstream pressure field, enter 15, and select the Single‐seat 
option. Since stream #1 is at 20 psia, you are simply sizing a control valve to 
produce a pressure drop of 5 psi. Click OK to view a control valve sizing 
report for the selected stream. 

6. Double‐click control valve #4 to open the Control Valve dialog box. Enter the 
valve flow coefficient (Cv) of the valve from the sizing report, set the valve 
position to 50%, and set the operating mode to Fix flow and position, 
calculate Pout. Click OK to save these settings and close the dialog box. 
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7. Double‐click the heat exchanger icon to open the Simple Heat Exchanger 
dialog box. Enter a pressure drop of 2 psi and set the outlet temperature to 
140° F. Click OK to continue. 

8. Tabulate and specify the valves, fittings, pipe lengths, and elevation changes 
of each section of pipe. For all of these pipes, set the Method field to 2 Single 
Phase flow, set the Sizing option to 0 Rating, and use flanged fittings 
throughout. 

Pipe #1 
1 entrance, well rounded 
2 ball valves  
4 standard elbows, 90‐degree 
1 tee, flow‐through branch 
35 feet of piping 
‐8’ elevation change 
 

Pipe #3 (before control valve) 
1 swing check valve, clearway 
2 ball valves  
2 tee, flow‐through run 
1 orifice plate (as previously determined)
14 feet of piping 
14’ elevation change 
 

Pipe #5 (after control valve) 
2 ball valves 
2 tee, flow‐through run 
3 standard elbows, 90‐degree 
1 exit from pipe 
24 feet of piping 
2’ foot elevation change 
 

Pipe #7 (after E‐1515) 
1 ball valve 
4 standard elbows, 90‐degree 
1 tee, flow‐through run 
1 well rounded entrance 
1 exit from pipe 
157 feet of piping 
5’ elevation change 
 

9. Specify the pump outlet pressure at some arbitrary value (try 25 psia) and 
make a trial run. Check the calculated outlet pressure. You can then iterate to 
find the required pump head. 

Using Controllers to Simplify the Problem 
While manually changing the pump outlet pressure will get you where you need to 
be, it’s easier to let CHEMCAD do the work. The Controller UnitOp can adjust this 
pressure for you. 

A feedback controller in CHEMCAD has nothing to do with process control 
valves or PID settings. In a CHEMCAD steady‐state model, the term feedback control 
refers to a mathematical controller. It’s a math tool used to adjust a variable on a 
flowsheet until a target value reaches a specified value. 

Follow these steps to use a feedback controller to calculate the required outlet 
pressure: 
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1. Right‐click stream #8 and select Insert unit. Click OK at the pop‐up message 
and then click the Controller tool in the All UnitOps palette. 

2. Click near the existing stream to place a controller icon on the flowsheet. The 
stream automatically re‐routes through this icon, as shown in Figure 11‐59. 

7
7 8

8 9

 
 Figure 11-59: Insertion of feedback controller 

3. In the Controller dialog box, specify the following and then click OK: 

• Controller mode: Feed‐backward 

• Adjust this variable: Unitop, ID number 2, Variable 2 Output pressure 

• Until this: Stream, ID number 8, Variable 2 Pressure 

• Is equal to this target: Constant 20, Units 4 Pressure 

When you run the simulation, the controller will automatically change the pump 
outlet pressure until the pressure leaving the last pipe unit is equal to 20 psia. You 
now know the head requirements for your pump. 

Calculating NPSHA 
The net positive suction head, better known as NPSH, is defined as the total pressure 
available at the pump suction minus the pumping fluid’s vapor pressure. It is almost 
always reported in feet of pumped fluid or water. 

Every pump has a specified NPSH requirement (NPSHr) at a given operating 
speed. To ensure reliable operation, the available NPSH (NPSHa) must be greater 
than the NPSHr. If not, cavitation and shortened service life may result.  

To select the appropriate pump, you need to calculate NPSHa. In CHEMCAD, 
this is an easy task. Simply check the Calculate NPSHa box in the Pump dialog box, 
and then run the simulation. Now when you pull up the Pump dialog box, the 
calculated NPSHa is displayed.  

Note: It is important to the NPSHa calculation that the inlet piping to the pump be 
correctly specified. If the piping specifications are not complete, the pressure at the 
inlet may not be accurate, leading to an inaccurate NPSHa calculation 
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Branched Flow Example 
This portion of the piping tutorial covers the Node UnitOp, pipe networks, pump 
selection criteria, and Pump UnitOp performance curves. 

Problem Statement 
The previous piping system has been changed. Due to the branched flow to the two 
heat exchangers, the problem is no longer a simple one. 

 
Figure 11-60: Piping isometric showing branched flow 

This example is called Example 3, and it’s located in the located in the My 
Simulations\Examples\Piping folder. 

The branched flow is a difficult problem to solve using the controller approach. 
Both exchangers have different piping and therefore different flow rates. You need 
an approach where you split and recombine flows, and have the simulation calculate 
the pressure and flow rates in an iterative manner. The Node UnitOp gives you this 
flexibility. 

Remember that a node is a point where pressure is uniform. There may be 
multiple inlets and outlets. The flow rates for each stream will be balanced by 
CHEMCAD to reach a single pressure. You can specify the pressure or allow it to 
vary. 

Creating the Simulation 
Convert the piping isometric to a CHEMCAD flowsheet, as shown in Figure 11‐61. 
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Figure 11-61: The flowsheet representing this piping system 

In CHEMCAD, Pipe UnitOps are used to represent entire sections of piping, 
including fittings. Node UnitOps are placed where pressure or flow rate are 
unknown. 

For this example, assume a pressure drop of 2 psi across each heat exchanger. 
Tabulate the valves, fittings, pipe lengths, and elevation changes of each section of 
pipe. Use flanged fittings throughout. 

Pipe #1 
1 entrance, well rounded 
2 ball valves  
4 standard elbows, 90‐degree 
1 tee, flow through branch 
35 feet of piping 
 

Pipe #2 (before control valve) 
1 swing check valve, clearway 
2 ball valves  
2 tee, flow through run 
1 orifice plate (as determined above) 
14 feet of piping 
 

Pipe #3 (after control valve) 
1 ball valve 
1 tee, flow through run 
2 standard elbows, 90‐degree 
10 feet of piping 

Pipe #4 (to E‐1514) 
1 tee, flow through branch 
1 ball valve 
1 exit from pipe 
3 standard elbows, 90‐degree 
26 feet of piping 
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Pipe #5 (from E‐1514) 
1 ball valve 
1 well rounded entrance 
3 standard elbows, 90‐degree 
1 tee, flow‐through branch 
30 feet of piping 

Pipe #6 (to E‐1515) 
1 ball valve 
1 exit from pipe 
1 tee, flow‐through run 
1 standard elbows, 90‐degree 
14 feet of piping 

   
Pipe #7 (from E‐1515) 
1 standard elbow, 90‐degree 
1 ball valve 
1 well rounded entrance 
1 tee, flow‐through run 
10 feet of piping 

Pipe #8 (to V‐1522) 
3 standard elbows, 90‐degree 
1 exit from pipe 
147 feet of piping 
 

   
At this time you don’t know the pump specifications, so set the pump to Specify 

Outlet Pressure and leave the pressure specification blank. The Node UnitOp will 
solve for the pressure increase, and set the pump outlet pressure accordingly. 

Set up the nodes with the following information: 

• Node 3: Variable pressure, use current stream rate for inlet, flow set by 
UnitOp for outlet, elevation = 20 feet 

• Node 5: Variable pressure, flow set by UnitOp for both inlet and outlet, 
elevation = 34 feet 

• Node 7: Variable pressure, flow set by UnitOp for both inlet and outlet, 
elevation = 34 feet 

• Node 9: Variable pressure, flow set by UnitOp for both inlet and outlet, 
elevation = 34 feet 

• Node 12: Variable pressure, flow set by UnitOp for both inlet and outlet, 
elevation = 50 feet 

• Node 16: Variable pressure, flow set by UnitOp for both inlet and outlet, 
elevation = 38 feet 

• Node 18: Variable pressure, flow set by UnitOp for both inlet and outlet, 
elevation = 42 feet 

• Node 20 (last node): Fixed pressure, 20 psia, flow set by UnitOp for inlet, free 
outlet stream for outlet, elevation = 43 feet 

Running the Simulation 
To run the simulation, click the Run All button on the main CHEMCAD toolbar.  
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Once the simulation has run, check the Pump UnitOp’s pressure increase. This 
tells you the head requirements of the pump. Using this information and the flow 
rate (120 gpm), you can consult a pump handbook to determine the correct pump 
size. 

Selecting a Pump 
The following pump curve data is representative of the type of equipment that 
would be appropriate for this application. 

Pump Curve
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Figure 11-62: Combined pump curves for a sample pump 

To enter this curve into your pump, open the Pump dialog box and select 
Specify Performance Curve for the pump mode. This setting allows you to enter 
multiple speed lines and an operating speed. For the purposes of this tutorial, enter 1 
for the number of speed lines and set the pump speed to 1750 RPM. Click OK to 
bring up the Performance Curve dialog box. 
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Figure 11-63: The Performance Curve dialog box 

Here you can enter as many points as you want to define your curve. 
CHEMCAD will fit a quadratic equation to the points, creating a smooth curve fit for 
your data. 

Now that you have entered the pump performance curve, you must add node 
UnitOps to the suction side of the pump to allow the flow rate to vary. In this way, 
you can calculate the maximum flow rate of your system.  



 

CHEMCAD Version 6 User Guide  185 

Index 

 

 
 
 
 
 

.CC6 files, 29 

Adding a single component, 93 

Adding components to a simulation, 42 

All UnitOps palette, 37 

Apply Component Changes dialog box, 96 

Applying a template, 92 

Assigning objects to a layer, 87 

Attaching a simulation file to an e‐mail, 33 

Batch Reactor/DVSL History plot, 69 

Batch Results report, 79 

Binary LLE plot, 80 

Binodal Plot, 80 

Binodal/Residue Curves plot, 80 

Building a basic simulation, 35 

Bulk Properties dialog box, 97 

C++, using to create a custom mixing rule, 104 

C++, using to create custom thermodynamics, 102 

Calling Chemstations, 15 

Cases, saving, 32 

CC‐BATCH tutorial, 154 

CC‐DYNAMICS, 59 

CC‐STEADY STATE tutorial, 122 

CC‐THERM tutorial, 144 

CHEMCAD 

  Main menu, 23 

  Toolbar, 23 

  Tutorials, 121 

  Getting help with, 14 

  Installing, 7 

  Interface, 17 

  Licensing, 10 

  Modules, 3 

  Opening older files, 33 

  Overview, 1 

  Products and features, 3 

  System requirements, 7 

  User components in, 30 

CHEMCAD Coach pane, 27 

CHEMCAD Dialog Editor, 101 

CHEMCAD Explorer, introduced, 18 



Index 

186  CHEMCAD Version 6 User Guide 

CHEMCAD Symbol Editor, 98 

CHEMCAD tutorials 

  CC‐BATCH, 154 

  CC‐STEADY STATE, 122 

  CC‐THERM, 144 

  Piping, 170 

Chemical components, selecting, 41 

Chemstations web site, 15 

Coach, 27 

COM interfaces, 117 

Component Object Model (COM), 117 

Components 

  Adding, 42 

  Finding, 41 

  Removing, 43 

  Selecting, 41 

Composite Curves plot, 80 

Connecting streams to UnitOps, 38 

Consolidated reporting, 79 

Control Valve Sizing dialog box, 54 

Controller Convergence plot, 81 

Convergence Parameters dialog box, 62 

Costing calculations, customized, 100 

Creating a custom UnitOp dialog box, 101 

Creating a layer, 86 

Creating a new simulation, 31 

Creating a template, 92 

Creating an Excel Data Map, 108 

Creating custom components, 93 

Creating Excel UnitOps, 113 

Creating custom UnitOps, 100 

Curve Temperature Cut Ranges dialog box, 96 

Custom components, 93 

Custom enthalpy model, 102 

Custom K‐value model, 102 

Custom mixing rule, creating using VBA, 104 

Custom reaction, creating using VBA, 104 

Custom UnitOp icon 

  Creating, 98  

  Adding to a subpalette, 99 

Custom UnitOp, creating using VBA, 104 

Custom UnitOps, creating, 100 

Customized costing calculations, 100 

Customizing CHEMCAD, 91 

Customizing the CHEMCAD screen, 23 

Customizing thermodynamics, 102 

Data interfaces to CHEMCAD, 107 

Data Map Execution Rules dialog box, 111 

Data Maps, creating, 108 

Databoxes, 82 

Default icon for UnitOp, 37 

Defining streams, 46 

Defining UnitOps, 47 

Deleting a template, 92 

Dialog box, customizing, 101 

Dialog Editor utility, 101 

Dist Curve Characterization dialog box, 96 

Distillation report, 78 

Dongle 

  For CHEMCAD licensing, 10 

  Reprogramming, 12 

Drawing a flowsheet, 36 

Drawing streams on a flowsheet, 38 

Drawing tools, 40 

Dynamic Column History plot, 69 

Dynamic Column History report, 69 

Dynamic operation, setting up, 61 

Dynamic plots, 81 

Dynamic Run Time Schedule dialog box, 64 

Dynamic simulation, running, 66 

Dynamic simulations, strategies for, 61 

Dynamic Stream History plot, 69 

Dynamic Stream History report, 70 

Dynamic UnitOp History report, 70 

Dynamics Menu, 63 

Dynamics reports, 79 

Dynamics 

  Additional input for, 60 

  Defined, 59 

  Output, 68 

  Plotting results, 69 

  Recording streams and UnitOps, 65 

  Running one step at a time, 67 

  Text‐based results, 69 

  Toolbar buttons for, 62 

Edit Distillation Curves menu, 97 

Edit Feed Streams button, 46 

Edit Stream Group dialog box, 73 

Edit Streams dialog box, 46 

Ellipse tool, 40 



 Index 

CHEMCAD Version 6 User Guide  187 
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Errors and Warnings tab, on Messages pane, 22 

Example files, 30 

Excel Data Map Editor, 108 

Excel Data Mapping feature, defined, 107 

Excel Databox Settings dialog box, 84 

Excel range boxes, 84 

Excel UnitOps, creating, 113 

Flowsheet databoxes, 82 

Flowsheet templates, 91 

Flowsheets, drawing, 36 

Flowsheet‐based graphs, 80 

Global Enthalpy Option, 45 

Global K Value Option, 45 

Graphical reports, 80 

Grid, 26 

Groups 

  Stream, 72 

  UnitOp, 76 

Heat Curves plot, 81 

Hiding a layer, 88 

High‐fidelity modeling, defined, 49 

Hydrocarbon Correlation dialog box, 96 

Icons, creating, 98 

Installing CHEMCAD, 7 

Job files, 29 

K‐value options, selecting, 44 

Layers, 85 

  Assigning objects to, 87 

  Creating, 86 

  Deleting, 88 

  Hiding and viewing, 88 

  Removing objects from, 88 

License Settings screen, 11 

Licensing CHEMCAD, 10 

Licensing, for dynamics, 59 

Licensing, for high‐fidelity modeling, 58 

Line sizing, 51 

Line tool, 40 

Locked for Editing dialog box, 31 

Low‐fidelity modeling, defined, 49 

Main menu, 23 

Manage Component Databases dialog box, 94 

Mass and Energy Balances report, 79 

Messages pane, 22 

Moving a pane, 25 

Moving UnitOp icons, 38 

Multi‐line tool, 40 

My Simulations directory, 32 

Neutral file import, 97 

New Component dialog box, 93 

New simulation, creating, 31 

Notes tab, on Messages pane, 23 

Older CHEMCAD files, 33 

Ole for Process Control (OLE), 114 

OPC 

  Applications, 114 

  Compliance, 114 

  Namespace, 116 

  Server operations, 115 

OPC server, using CHEMCAD as, 114 

Open command, 31 

Opening an existing simulation, 31 

Opening an older CHEMCAD file, 33 

Palette pane, introduced, 20 

Palettes, customizing, 21 

Particle Size Distribution report, 76 

PFD printing, 88 

PFDs, 82 

Phase Envelopes plot, 80 

Pinning and unpinning panes, 25 

Pipe Profile plot, 81 

Piping tutorial, 170 

Plots in CHEMCAD, 80 

Plots, dynamic, 81 

Plotting dynamic results, 69 

Plug Flow Reactor Profile plot, 81 

Polygon tool, 40 

Printing a process flow diagram, 88 

Printing CHEMCAD reports, 82 

Process flow diagrams, 82 

Properties, of streams, 46 

Pseudocomponent Curves plot, 81 
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Pseudocomponent Curves report, 76 

Pseudocomponent range, defining, 96 

Record Streams dialog box, 65 

Recording streams and UnitOps for dynamics, 65 

Rectangle tool, 40 

Redo command, 26 

Regress Component Properties menu, 95 

Regressing data into a user‐added component, 95 

Relief device sizing, 57 

Removing components from a simulation, 43 

Renaming a template, 92 

Report Format dialog box, 71 

Report setup, 71 

Reports for dynamic simulations, 69 

Reports 

  Dynamics, 79 

  Printing, 82 

  Stream compositions, 74 

  Stream properties, 75 

  UnitOp‐based, 76 

Reprogramming a dongle, 12 

Re‐routing a stream, 39 

Reset to Initial State button, 67 

Residue Curves plot, 80 

Resizing a pane, 24 

Resizing UnitOp icons, 38 

Results, reviewing, 48 

Reviewing run results, 48 

Routing streams, 39 

Run from Current State button, 66 

Run from Initial State button, 66 

Run time, setting, 63 

Run Trace tab, on Messages pane, 22 

Running a dynamic simulation, 66 

Running a simulation, 48 

Save As command, 32 

Save as Initial State button, 68 

Saving a simulation, 32 

Saving different cases, 32 

Search for UnitOp(s) field, 21 

Search Options dialog box, 42 

Select Components dialog box, 41 

Select Data Map dialog box, 111 

Select Destination Database dialog box, 94 

Select Single Component dialog box, 95 

Selecting components, 41 

Selecting engineering units, 36 

Selecting K‐value and enthalpy options, 44 

Selective printing, 85 

Setting run time for dynamics, 63 

Simulation files 

  Introduced, 29 

  Creating, 31 

  E‐mailing, 33 

  Opening, 31 

  Overview of building, 35 

  Saving, 32 

Simulation, running, 48 

Single component, adding, 93 

Sizing, introduction, 50 

Spec sheet report, 77 

Spec sheets, output to Excel, 113 

Specifying UnitOps, 47 

Starting a new simulation, 31 

Stream boxes, 82 

Stream composition reports, 74 

Stream composition, viewing, 75 

Stream groups, creating, 72 

Stream Properties plot, 80 

Stream property reports, 75 

Streams 

  Drawing on a flowsheet, 38 

  Defining, 46 

  Re‐routing, 39 

Switching to dynamics, 61 

Symbol Editor utility, 98 

Symbols, creating, 98 

Technical support, contacting, 15 

Templates 

  Applying, 92 

  Creating, 92 

  Defined, 91 

  Deleting, 92 

  Renaming, 92 

Text reports, 71 

Text tool, 40 

Thermodynamic Settings dialog box, 45 

Thermodynamics report, 78 

Thermodynamics settings, manually selecting, 45 

Thermodynamics Wizard, 44 



 Index 

CHEMCAD Version 6 User Guide  189 

Thermodynamics, customizing, 102 

Thermophysical data graphs, 80 

Toolbar, 23 

Topology report, 78 

Tower Profiles plot, 81 

TP boxes, 83 

TPXY plot, 80 

Tray Sizing dialog box, 55 

Undo command, 26 

UnitOp boxes, 83 

UnitOp dialog box, customizing, 101 

UnitOp groups, creating, 76 

UnitOp icons 

  Creating customized, 98 

  Manipulating, 38 

UnitOps 

  Adding to a flowsheet, 36 

  Selecting default icon for, 37 

  Listing of all available, 5 

  Specifying, 47 

UnitOp‐based plots, 81 

UnitOp‐based reports, 76 

Update Simulation Format dialog box, 34 

Updating a CHEMCAD license, 12 

User‐specified file, plotting, 81 

Valve Tray dialog box, 55 

VBA 

  Custom mixing rules, 104 

  Custom reactions, 104 

  Custom UnitOps, 104 

  Using to customize CHEMCAD, 104 

VBA‐defined mixing rule, using, 106 

VBA‐defined reaction, using, 105 

VBA‐defined UnitOp, using, 106 

Vessel Sizing dialog box, 53 

View Property Options dialog box, 75 

View/Edit Component Data menu, 94 

Viewing a layer, 88 

Web site for Chemstations, 15 

Zoom Options menu, 27 
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